PDA

View Full Version : No Display after installing FC7



rgv_wrigger
13th August 2007, 06:55 PM
hello,
i installed fedora 7 on my machine. the setup went smoothly. but when grub boots into fedora (dual boot with windows xp sp2), the screen shows:

Booting the kernel
Red Hat Nash Version 6.0.9 starting
(and then the time service starts successfully)
Starting udev: [OK]

after this the display goes blank and the lcd turns itself off after a couple of seconds.
i press alt-ctrl-F1 now and the display reappears with the content mentioned above and an additional line reading:

Enabling /etc/fstab swaps: [OK]

i was using fedora 6 earlier flawlessly (which i had upgraded to from fedora 5, not a fresh install). so, i did a fresh install of fedora 6 and tried upgrading to fedora 7 but the same results as a fresh install of fedora 7. additionally my grub menu now shows 3 fedora entries as listed below:

Fedora (2.6.20-2925.9.fc7xen)
Fedora-xen (2.6.18-1.2798.fc6xen)
Fedora-base(2.6.21-1.3194.fc7)
Microsoft Windows XP Pro

the 1st and 3rd entries lead to the same situation as above with slightly different preceding jargon. the 2nd entry though gives the following msg:

Kernel /xen.gz-2.6.18-1.2798.fc6
Error 15: File not found
Press any key to continue...

My system config is:
AMD Athlon X2 4600+ AM2
MSI K9N Diamond m/b
1GB DDR2 Ram
Seagate Barracuda 7200 rpm 320 GB SATA hdd
ATI Radeon x1600 Pro 256mb GDDR3

thnx

rgv_wrigger
15th August 2007, 06:46 PM
someone reply plz

ajoian
15th August 2007, 08:12 PM
Try not to use the xen kernel unless you really need it. Try to upgrade to the latest version of Fedora by issuing the command : yum -y update

climbak
17th August 2007, 10:15 AM
I am having this same problem. I get to the same part of the boot up and my monitor shuts off. Ctrl+Alt+F1 brings the display back and my system is stuck at the same point.

rgv_wrigger
17th August 2007, 06:56 PM
Try not to use the xen kernel unless you really need it. Try to upgrade to the latest version of Fedora by issuing the command : yum -y update
@ajoian

thnx for replying.
im almost a newbie to troubleshooting linux... could u plz tell me how to exactly not use the xen kernel and still use fedora 7. also since the linux system is not starting how can i possibly issue any request on yum.
a pointer: as far as i know (and i don't know much), xen kernel is used in f7... but im having the same problem with fc6 as well. whereas earlier f6 worked without glitch on the same machine when i upgraded to fc6 from fc5.
also one info i missed, im using 64 bit versions.

rgv_wrigger
20th August 2007, 06:25 PM
today i fresh installed f7 again and this time without the xen kernel by removing all virtualization packages and still the status is the same.
also, could anyone tell me how to get into txt mode.

climbak
20th August 2007, 09:24 PM
I tried the same thing and so far nothing has worked. To boot into the text console: when in grub, highlight the kernel you wish to boot into, press 'e', then highlight the line that has vmlinuz and press 'e' again. it will come up with a little boot option deal and type a space and the number 3 after the line. it should look something like "... quiet 3". hit enter then press 'b' to boot.

rgv_wrigger
21st August 2007, 06:52 PM
thnx for the help.
are u still at the same pt where i am stuck or hav u made any progress? tell me also when u get through this prob :)
what is ur system configuration anyway?

i am still of the opinion that there is something wrong with the graphics handling and not virtualization or anything else... coz i upgraded my system from fc5 to fc6 and it worked... then i updated from fc6 to f7 and it didn't work... but then when i reinstalled fc6 bak afresh then fc6 also gives the exactly same problem... try taking some lead from here

glennzo
21st August 2007, 08:12 PM
When you ctrl/alt/f1 you are in a virtual terminal. Login as root with root's password. Try editing the file /etc/X11/xorg.conf. Look for the line that mentions the video driver. Change it to 'vesa' and save the file. Type 'startx' and see if you get to the GUI.

Sting14
23rd August 2007, 12:27 AM
When you ctrl/alt/f1 you are in a virtual terminal. Login as root with root's password. Try editing the file /etc/X11/xorg.conf. Look for the line that mentions the video driver. Change it to 'vesa' and save the file. Type 'startx' and see if you get to the GUI.

I was having this same problem to. I edited my xorg.conf and changed the drive from "nv" to "vesa". I restarted X, and I had a display! I rebooted the computer and it was running fine. GDM came up, started loading all the services, and firstboot started running. At the end of firstboot, I clicked "Finish" and the screen went black. My monitor remained 'on' letting me know it was still getting a signal, but it was just black. I could no longer do ctrl+alt+Fkeys to get to a different TTY. Also, restarting X with ctrl+alt+backspace yielded no results. Now, when I boot Fedora, I see GDM loading all the services, then the screen goes black once all the services are loaded, but before I get to the "Enter your username" prompt.


EDIT:

So I decided to try to see if I could ssh to the machine and change some display settings in xorg.conf. I was able to obtain the IP address by booting another OS. I loaded Fedora back up, and the screen went blank. I went over to my other computer and tried to SSH in. I was able to ping it, and it was up, but could not ssh in. I'm thinking sshd just isnt up or something. So this confirms the machine is still running, just the display is all funky...


Any thoughts now? I'm definitely confused 8(

JN4OldSchool
23rd August 2007, 12:32 AM
nv is running in services. Just boot up in init3 and log in as root and do:

rpm -ivh http://rpm.livna.org/livna-release-7.rpm
rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-livna

then

yum install kmod-nvidia

and reboot. This should do you.

DrEntropy
23rd August 2007, 12:51 AM
JN! Might this work with a VERY similar prob with an nvidia card and core6 with a substitution of "6" for "7" in the release version?

BTW: West central FL here, too.

JN4OldSchool
23rd August 2007, 12:58 AM
JN! Might this work with a VERY similar prob with an nvidia card and core6 with a substitution of "6" for "7" in the release version?

BTW: West central FL here, too.

Yessir, should work fine. You can always edit the xorg.conf to say "vesa" instead of "nv" and it should boot ok. Then you can install kmod-nvidia from a terminal. Alternately, just do it from init3 on a text login.

Sting14
23rd August 2007, 02:49 AM
YES! it worked!

It's almost 100% fine too. The only problem I have right now, is that the nvidia module isn't loaded until towards the end of loading the services. So when GDM starts I don't see any of the messages until I get to the login screen.

Is there a way to make the nvidia module load earlier?

Sting14
23rd August 2007, 03:09 AM
nevermind. I rebooted and it loaded earlier this time. All problems solved!

swizzel
23rd August 2007, 05:07 AM
hey, so i am having a similar problem also only i have a Intel Centrino 2.0Ghz laptop with an ATI Mobility x700 graphics card. I tried changing my xorg.conf to say 'vesa' instead of what was there, 'radeon' i believe and when i restarted i got the following error message...

"Failed to start the X server (your graphical interface). It is likely that it is not set up correctly. Would you like to view the X server output to diagnose the problem?"

So in the output down at the bottom there is...

(EE) VESA(0): Set VBE Mode failed!

Fatal server error:
AddScreen/ScreenInit failed for driver 0

and yes this is my first linux installation so i probably messed something up while installing.

It gives me the option to configure the X server which i tried and set it to generic LCD, the resolution i use and radeon again and it just goes black after hitting okay.

*edit* i guess i should have mentioned i installed fedora 7

climbak
23rd August 2007, 05:25 AM
I have tried my xorg.conf with both vesa and frglx for my ati card and X will not load. I have gotten lots of different error messages. when I have gotten the above situation as swizzel did and i received a similar error. Not the same but I can't remember what it was. I cannot seem to get x server to run with any driver at all.

swizzel
23rd August 2007, 11:39 PM
anyone have any luck fixing this with ATI cards?

glennzo
24th August 2007, 12:20 AM
I have tried my xorg.conf with both vesa and frglx for my ati card and X will not load. I have gotten lots of different error messages. when I have gotten the above situation as swizzel did and i received a similar error. Not the same but I can't remember what it was. I cannot seem to get x server to run with any driver at all.
Find out what the horizontal and vertical refresh rates are for your monitor and what the default and or maximum resolution is. There are entries for these in xorg.conf. Often times the mode lines or refresh rates are incorrect

climbak
25th August 2007, 10:03 PM
Find out what the horizontal and vertical refresh rates are for your monitor and what the default and or maximum resolution is. There are entries for these in xorg.conf. Often times the mode lines or refresh rates are incorrect
How exactly would I do this and edit them to the correct values?

glennzo
26th August 2007, 12:59 AM
Find the brand and model of your monitor. Get the specs from the manufacturer or Google them. Once you find out what the horizontal and vertical rates are post them here, then I'll give you an example of what that section of xorg.conf should look like.

climbak
26th August 2007, 01:00 AM
How do I edit xorg.conf from the text console.

rgv_wrigger
26th August 2007, 11:44 AM
Find the brand and model of your monitor. Get the specs from the manufacturer or Google them. Once you find out what the horizontal and vertical rates are post them here, then I'll give you an example of what that section of xorg.conf should look like.

my monitor is a ViewSonic VA1912wb lcd. H. frequency 56 KHz, V. frequency 60 Hz, Resolution 1440x900, pixel clock 105MHz. the monitor is connected to the DVI of my ATI Radeon x1600 Pro. tell me if u need my xorg.conf also. it is using vesa for now.

climbak
26th August 2007, 12:44 PM
try using just the standard monitor cable. I was able to boot into the gui that way. I still can't get anything but the vesa driver to work though so the display sucks right now.

glennzo
27th August 2007, 01:04 AM
my monitor is a ViewSonic VA1912wb lcd. H. frequency 56 KHz, V. frequency 60 Hz, Resolution 1440x900, pixel clock 105MHz. the monitor is connected to the DVI of my ATI Radeon x1600 Pro. tell me if u need my xorg.conf also. it is using vesa for now.
Here's what I would do. Open a terminal as root and make some changes to the xorg.conf file but first back it up by typing
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
Next type vi /etc/X11/xorg.conf. In the vi editor hit the INS key. You are now in edit mode. Find the section that looks like this:
Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Modes "1280x800"
EndSubSection
Make sure that the modes line says 1440x900
Find the section that looks like this:
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30-107
VertRefresh 48-120
EndSection
Make sure that these lines:
HorizSync 30-107
VertRefresh 48-120
reflect you monitors refresh rates. If the lines are not there add them. They should look like this:
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30-82
VertRefresh 50-85
EndSection
Save the file by typing these keys: ESC :wq! and press enter. Type startx and see if you get the GUI. Also, try with and without the 'vesa' driver.