PDA

View Full Version : Non-stand resolution



davidkaye
2nd May 2004, 04:41 PM
I installed Fedora Core 2 Test 3 on a ZD7000 (specifically a ZD7058CL) laptop. It has a huge 17" wide screen that prefers a resolution of 1440x900. Here is a link to the specs of my system:

http://h10025.www1.hp.com/ewfrf/wc/genericDocument?lc=en&cc=us&docname=c00042933

When I installed Fedora, I couldn't find an appropriate monitor to use. Also, I found that Fedora Core 2 prefers to use xorg.conf for its X settings, but changing them there resulted in no change. Also, the Screen Resolution utility proved useless in changing to the proper resolution. I really like Fedora, but I need to get this resolved before proceeeding.

Can anyone help me, please?

Thanks,

David

rkrijger
3rd May 2004, 02:08 PM
I have the same problem. I cannot seem to adjust the resolution to anything more than 640x480. The problem could also be the gfx card. I have a NVidia Geforce 2 MX... There are a lot of threads on (problems with this) card. Perhaps you can find your anwer there. I havent tried yet...

Regards,
Robin...

gonzalo76
4th May 2004, 06:01 AM
I know how to help you, it's very easy (it worked for me)

What Fedora are you using, 1 or 2?

For Fedora Core 1, please copy here your /etc/X11/XF86Config.

For Fedora Core 2, please coy here your /etc/X11/xorg.conf.

We'll be in touch.

gonzalo76
4th May 2004, 05:43 PM
Basically, what you would have to do is edit your /etc/X11/XF86Config (FC1) or /etc/X11/xorg.conf (FC2) adding "1440x900" at the beggining of Section "Screen" + SubSection "Display" + Mode.

Here's mine "Screen" /etc/X11/XF86Config Section:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
As you can see, my video card supported modes are, 1024x768, 800x600 and 640x480.

HOWTO:

1. You'll have to add "1440x900" at the beggining of 'Modes' section. Make sure that the resolution you want, appears first in the line Modes like this:


Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
2. Log out from KDE and log in again.

3. Configure the monitor seetings: open a console, log in as root (su -) and run:

/usr/bin/redhat-config-xfree86 and select the desired resolution.

4. Tip: You should be able to toggle through different resolutions with [ctrl alt -] or [ctrl alt +]. That will cycle through the screen resolutions you have listed in your /etc/XF86Config file. The plus and minus signs are the ones on the numerical keypad and not Shift&- etc.

5. You can also try changing "Depth" to 16.
Depth 16 instead of 24.

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
6. Make sure you have your monitor and video card selected properly.

Good Luck !

rkrijger
4th May 2004, 07:02 PM
Originally posted by gonzalo76
Good Luck ! [/B]

Well i'll give it a shot. Thanks for helping so far. I hope it works. I will get back here!!!

rkrijger
4th May 2004, 07:51 PM
It doesn't work... :(
First of all, I am using Fedore Core 1.92 Test 3
The redhat-config-xfree86 cmd does not exist
I used system-config-display (mentioned in /etc/X11/xorg.conf)

I added the modes first in xorg.conf
Then ran system-config-display and selected 1600x1200
The UI prompted me to logout and restart X
I did (CTRL-ALT-BACKSP)
Still 640x480

Heres some output in /var/log/Xorg.0.log

[...]
(II) NV(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) NV(0): I2C device "DDC:ddc2" removed.
(II) NV(0): ... none found
(II) NV(0): Probing for EDID on I2C bus B...
(II) NV(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) NV(0): I2C device "DDC:ddc2" removed.
(II) NV(0): ... none found
(II) NV(0): Unable to detect display type...
(==) NV(0): ...Using default of CRT
(II) NV(0): Unable to detect which CRTCNumber...
(==) NV(0): ...Defaulting to CRTCNumber 0
(II) NV(0): Using CRT on CRTC 0
(--) NV(0): VideoRAM: 32768 kBytes
(==) NV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) NV(0): Monitor0: Using default hsync range of 28.00-33.00 kHz
(II) NV(0): Monitor0: Using default vrefresh range of 43.00-72.00 Hz
(II) NV(0): Clock range: 12.00 to 350.00 MHz
(II) NV(0): Not using default mode "640x350" (hsync out of range)
(II) NV(0): Not using default mode "320x175" (hsync out of range)

[...]


Plz help... :)

Regards,
Robin...

gonzalo76
4th May 2004, 08:06 PM
That's why I said:

What Fedora are you using, 1 or 2?

For Fedora Core 1, please copy here your /etc/X11/XF86Config.

For Fedora Core 2, please coy here your /etc/X11/xorg.conf.


Could you copy here your xorg.org file

Thanks

rkrijger
4th May 2004, 08:16 PM
Originally posted by gonzalo76
That's why I said:
Could you copy here your xorg.org file
Thanks

Okay, sorry, here you are:


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "microsoft"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor 1600x1200"
### Uncomment if you don't want to default to DDC:
# HorizSync 31.5 - 94.0
# VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

dhs13
5th May 2004, 12:29 AM
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of
the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

### Uncomment if you don't want to default to DDC:
### Uncomment if you don't want to default to DDC:
# HorizSync 31.0 - 64.0
# VertRefresh 50.0 - 120.0
### Uncomment if you don't want to default to DDC:
# HorizSync 31.5 - 37.9
# VertRefresh 50.0 - 70.0
### Uncomment if you don't want to default to DDC:
# HorizSync 31.5 - 37.9
# VertRefresh 50.0 - 70.0
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Sony Multiscan 17sf"
### Uncomment if you don't want to default to DDC:
# HorizSync 31.5 - 37.9
# VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "ati"
VendorName "Videocard vendor"
BoardName "ATI Mach64"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Prometheus
5th May 2004, 12:46 AM
About 6 lines up from the bottom of your first post is the line you need to edit that starts wiht mode and lists all the different resolutions. Add in the one you want, then go in to etc/x11/xorg.config and select it and voila! it should work just fine

dhs13
5th May 2004, 02:01 AM
I have added "1024x768" and added it to the proper line in modes.

I don't understand what you mean be "select it" ?

Picomp314
5th May 2004, 02:08 AM
Yeah.. I have also had quite a few problems with this type of thing, particularly on HP lcd's for some reason they are not well supported in Linux

dhs13 & rkrijger: change DefaultDepth to 16 and Depth to 16 as well, sometimes this was the only way I could fix it...

dhs13
5th May 2004, 02:23 AM
I changed the depth to 16 and 16. Opened up display settings and even through I added 1024x768 this didn't show up as a selection option. Also when I opened up display setthins, it went back to 640x480. When I finished installing Fedora, setting was 1024x768. When I logon on Fedora went back to 640x480.

gonzalo76
5th May 2004, 02:28 AM
Originally posted by rkrijger
Okay, sorry, here you are:

# Xorg configuration created by system-config-display

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor 1600x1200"
### Uncomment if you don't want to default to DDC:
# HorizSync 31.5 - 94.0
# VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Well, what you'll have to do is:

1. Edit the Section "Screen" and add "1440x900" like this:


Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1440x900" "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
2. Uncomment the CATALYST Display Drivers line:

### Uncomment if you don't want to default to DDC:
# HorizSync 31.5 - 94.0
# VertRefresh 50.0 - 90.0

to


### Uncomment if you don't want to default to DDC:
HorizSync 31.5 - 94.0
VertRefresh 50.0 - 90.0
I think these values are correct, I could not find your HSync and VRefresh. You should find it if these values were not correct.

3. Modify Depth 24 to 16

DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16

(It's important to log out and log in again)

4. Then, go to System + Monitor or Display or Resize and Rotate Display or something like that and select the new resolution size.
(You'll not have to do this 'cause Fedora will detect the new XF86Config screen resolution automatically)

5. For a better performance, you should also install the new NVIDIA drivers available from here (http://www.nvidia.com/object/linux_display_ia32_1.0-5336.html)

Good Luck

gonzalo76
5th May 2004, 02:35 AM
Originally posted by dhs13
I changed the depth to 16 and 16. Opened up display settings and even through I added 1024x768 this didn't show up as a selection option. Also when I opened up display setthins, it went back to 640x480. When I finished installing Fedora, setting was 1024x768. When I logon on Fedora went back to 640x480.

You're doing something wrong.
Check my posts again.

Good Luck

rkrijger
5th May 2004, 07:27 AM
Originally posted by gonzalo76
Good Luck [/B]

It worked! Thank you so much!
I have looked op the HSYNC and VREFRESH (or something like that) on the internet of my monitor and put these values in the XOrg file.

It still did not work, but I noticed I had a larger res on my login screen. Then I checked "Screen Resolution" in the menu and here the res was set to 640x480. Put them to 1600x1200. And it worked! Now I'm happy!

Next prob: installing vlc, but probably a thread on this already exists! :)

Once again: many thanks for your help!!!

Regards,
Robin...

dhs13
5th May 2004, 12:16 PM
Using this as an example: I did the following:
Modify Depth 24 to 16
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
to
[CODE]DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16

It still doesn't work.

dhs13
5th May 2004, 12:47 PM
In my case, I remove all references to DDC and it work.

davidkaye
5th May 2004, 10:47 PM
I was able to increase it to 1024x768, but not to 1440x900. I also tried chaning from "nv" to "nvidia", and that destroyed my display. I had to reboot. Here is my xorg.conf:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

### Uncomment if you don't want to default to DDC:
### Uncomment if you don't want to default to DDC:
# HorizSync 31.5 - 37.9
# VertRefresh 50.0 - 70.0
### Uncomment if you don't want to default to DDC:
# HorizSync 31.5 - 37.9
# VertRefresh 50.0 - 70.0
### Uncomment if you don't want to default to DDC:
# HorizSync 31.0 - 70.0
# VertRefresh 50.0 - 120.0
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "HP D2837 HP 70 17-inch Display"
### Uncomment if you don't want to default to DDC:
HorizSync 30.0 - 64.0
VertRefresh 50.0 - 100.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce FX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Thanks for you help,

David

Picomp314
6th May 2004, 12:40 AM
davidkaye: First off, what version of Fedora Core are you running?

Next you have to install the nvidia drivers from their website if you want to use the closed source binary drivers, only after you install it can you change Driver "nv" to Driver "nvidia"

gonzalo76
6th May 2004, 12:50 AM
Originally posted by rkrijger
It worked! Thank you so much!
I have looked op the HSYNC and VREFRESH (or something like that) on the internet of my monitor and put these values in the XOrg file.

It still did not work, but I noticed I had a larger res on my login screen. Then I checked "Screen Resolution" in the menu and here the res was set to 640x480. Put them to 1600x1200. And it worked! Now I'm happy!

Next prob: installing vlc, but probably a thread on this already exists! :)

Once again: many thanks for your help!!!

Regards,
Robin...

Great !!!

davidkaye
6th May 2004, 03:41 AM
I am using Fedora Core 2 Test 3. I installed the 5336 nVidia driver, but telling xorg.conf to use that causes the screen to go blank.

David

Ragman
10th May 2004, 08:31 PM
This is from memory.. I will post my xorg.conf file tonight so that you can see a copy that works (I have essentially the same HP laptop and installed FC2 Test 3 this weekend). The elements below are correct, but the description of their placement may be suspect.

In the "monitor" section, uncomment the lines for horizontal and vertical. Then, add "Modeline "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync" (no quotes).

Those were the only two changes I needed to make. It took two tries, the first did not work and did not include the Modeline statement. The idea to add it was purely a SWAG and not based upon knowing anything about this process <grin>. I have seen the Modeline values in the zd7000 news group and, in addition, the Nvidia documentation mentions a downloadable program to generate the statements. I don't remember its name. The current level of Nvidia dirvers (5???) have been noted in the zd7000 Forum to have a flicker (I had it too w/ FC1 and the Nvidia driver). Using strictly the FC2 components; no flicker!!

One other thing -- mine was a clean install of FC2 rather than an upgrade.

BTW, I installed both Gnome and KDE and, so, have visibility to more than one graphical tool for monitor configuration. After making these changes to the configuration file, one of the tools provides 1440x900 and the other does not. I do not know whether the tools are affected by the information in the xorg.conf file or not. Once the xorg.conf changes were entered by hand and working, I did not use the tools to make any changes; only to observe their offerings.

Ragman
11th May 2004, 05:38 AM
As promised, here is my xorg.conf file:


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

### Uncomment if you don't want to default to DDC:
### Uncomment if you don't want to default to DDC:
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1440x900"
### Uncomment if you don't want to default to DDC:
HorizSync 31.5 - 100.0
VertRefresh 59.0 - 75.0
Modeline "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce FX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1440x900" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

davidkaye
13th May 2004, 07:03 PM
Thanks. It worked perfectly. I am trying to get all of the hardware/features of my ZD7000 working under Fedora Core 2, and would like to try to put together a guide to help others with this model (recording it will also help me if I need to repeat it). I wanted to send you a private message, but you seem to have disallowed that in your settings. What features have you been able to get working on your ZD7000? What features haven't you been able to get working?

Ragman
14th May 2004, 07:54 PM
Glad this worked for you too!! Good idea about producing a guide; I'll be glad to help.

I did not include e-mail as I have been afraid of the web bots getting in and then spamming me to death. If the forum is able to prevent that, then I will see about adding it to my info.

Last night I tested PCMCIA with no joy. I have an Adonics Zip that was not recognized and neither was my Compact Flash card (it is in a PCMCIA adaptor). I do not recall whether I tested the Zip w/ FC1, but do not think so. I suppose this should be my next project.

Sound works OK. When I right click on the speaker icon and then open the controls panel there are two tabs at the top. I am not able to get to the 'zd' right now, so this is from memory... One tab refers to OSS and the other to ALSA. I may need to change something in the configuration as the ALSA control seems to be dead. Have not been too concerned, though, as the other side works. Given that there is sound, I am happy...

I have not yet attempted anything with the wireless as I only have wired Ethernet in the house. The wired side was detected during the installation and it works fine.

I have not worked w/ the various buttons yet, but I am hoping to get them working... While they are not absolutely necessary there will be, for me at least, a "cool factor" to having them work.

The digital card reader slots have not been tested yet either. In fact, that is pretty much the status of everything else too with the exception of USB.

My USB floppy worked with FC1, but there has not yet been an opportunity to use it with the FC2 Test3 software. My SanDisk Cruzer Mini 256 is working now, though -- it did not work at all with FC1. I have to use an explicit mount command and will soon try to get it working with automount.