PDA

View Full Version : How to make fedora to work with a LCD Monitor



BJ Mirooni
7th August 2007, 04:28 PM
I have been using a CRT monitor up to now without any problem.
I have recently purchased a LCD monitor (LG Flatron - model L204WT). I can not configure fedora to work with this monitor. No matter what adjustments I do, it goes back to the inital parameters and when connected to the LCD monitor I just get a black monitor with the message: Out of Range (frequency).

Can some one help me.

stepher
7th August 2007, 05:53 PM
It's not clear if you are making the changes in FC or in your monitor.

If you're not that familiar with Fedora, here's my suggestion. Plug in your CRT (amke sure it operates normally) and go into System/Administration/Display (should be in top "panel"). Make changes to support the LCD monitor. Then shut down your machine and remove the CRT and plug in the LCD. Bring the system back up, go back into display and fine-tune the settings. The caveat is that when you make the changes while connected to the CRT, you might "disable" the CRT at that point. Try it and see what happens.

It may also be that your display card is set for a fixed frequency and that may be a problem. Make sure you select a frequency that is compatible with both the CRT and the LCD (usually 60 Hz). Once you get the LCD up and running, you can modify to your heart's desire :)

Good luck...Steph

lmo
7th August 2007, 06:12 PM
I have been using a CRT monitor up to now without any problem.
I have recently purchased a LCD monitor (LG Flatron - model L204WT). I can not configure fedora to work with this monitor. No matter what adjustments I do, it goes back to the inital parameters and when connected to the LCD monitor I just get a black monitor with the message: Out of Range (frequency).

Can some one help me.Mine did the same thing.
CTRL-ALT-F1 takes to a text login:
login as root
from there, shutdown X-windows with:
init 3

I read the ranges for fh and fv from the box that my new LCD came in.
My ranges: fh 31-80, fv 60-75
Yours will be different
I edited the file /etc/X11/xorg.conf to fix.
I added Section Monitor
Section "Monitor"
Identifier "Monitor0"
HorizSync 31.0 - 80.0 # Your ranges are probably different
VertRefresh 60.0 - 75.0 # Your ranges are probably different
EndSectionThe added this line under Screen Section
Monitor "Monitor0"
Start up X-windows with:
init 5

Post your /etc/X11/xorg.conf file for additional assistance.

bbehnam
7th August 2007, 11:56 PM
Did post #3 answer your question? If not, what video card are you using? If it's a nvidia card I might be able to help.

BJ Mirooni
9th August 2007, 02:37 PM
Yes it is an nVidia. Could you please help me more.

bbehnam
14th August 2007, 04:37 PM
Yes it is an nVidia. Could you please help me more.

Hang in there :)

I'm going to make you a step by step guide.

The quick answer is you need to install the latest nvidia drivers, and to do that you need to do the following things:

1- add Livna repository to your yum
2- install the nvidia drivers from livna
3- if you are on a 64bit system add the 32bit libraries for compatibility reasons.

The above worked for me. I will have a keystroke by keystroke solution for you today sometime.

bbehnam
14th August 2007, 05:50 PM
Hi,

Here is a step by step solution to fix or kill your system :D

HUGE NOTE: Read this entire post first before doing anything. This guide assumes you have a new and current graphics card and NOT a legacy card. This means you are not using a GeForce 2, 3, 4, MX, or 96xx series card.

Note that <CR> means: "press the enter key."

Start your system until you get to the video out of range screen. Wait 30 seconds or more to make sure the system is really at run level 5.

1- Press the CTRL+ALT+F1 button to go to a console login window:

login as user: root <CR>
enter root password <CR>

2- Add livna repository by typing the following command:

rpm -ivh http://rpm.livna.org/livna-release-7.rpm <CR>

3- Install the latest nvidia kernel driver module:

yum install kmod-nvidia xorg-x11-drv-nvidia <CR>

4- Configure the display:

nvidia-config-display enable <CR>

5- OPTIONAL STEP: If this is a 64bit system, add the 32bit libraries for compatibility [not sure if it's necessary. I did it for my system] :

yum install -y xorg-x11-drv-nvidia-libs-32bit <CR>

6-Restart the nvidia service:

service nvidia restart <CR>

You should now either see the Xlogin screen or you should be able to see it by pressing CTRL+ALT+F7 :) . If you are really paranoid you can restart your system.


KNOWN PROBLEMS:

If you turn on desktop effects, your graphical desktop may hang and you will not be able to get out of it. CTRL+ALT+F1 will not work.

Symptoms are the Xdesktop is there, the mouse works, but all the toolbars and buttons are gone. You can't logout, restart, ...etc. You are stuck!

Therefore, don't turn on the desktop effects unless you have figured out how to fix this.
I have this same problem too but I'm too busy to figure out what is wrong right now.

One final warning:

These steps worked for me. I hope they work for you too; but, I make no promises. I'm not a fedora expert. I'm just another user who is trying to help.

If this guide makes your system worse off than when you started, then you are going to need the help of someone who is a lot more knowledgeable than I am about Linux. I won't be able to help because I don't know enough :) Good luck, and I hope this helps.