PDA

View Full Version : monitor sync



dwl
2nd May 2004, 02:10 PM
Hi, I've just upgraded my motherboard and tried to install Fedora Core1. The installation gets so far, then my monitor comes back with a message stating that the hsync and vsync are not supported.
Can anyone help?

My motherboard is a MSI KM2M with onboard S3 Prosavage DDR graphics and I'm using a AOC 7klr monitor.


Dave

gonzalo76
2nd May 2004, 05:04 PM
I don't know if you have problems with the signal output or with the scan frequency of your monitor.

Anyway, the signal output of your monitor is:
Sync.:TTL Level H/V
Sync.: Positive/Negative

The Scan Frequency of your monitor is:
Horizontal: 30K-95KHz
Vertical: 50-160Hz


The installation gets so far, then my monitor comes back with a message stating that the hsync and vsync are not supported.
From where did that message come from? From Fedora Core or directly from your AOC monitor?
Could you finish the installation of Fedora Core?

If you could not finished, start again the installation and select a generic 17'' monitor or another model, I don't know.

If you installed Fedora Core, check your /etc/X11/XF86Config file to see if the horizontal and vertical scan frequency are correct. If not, edit it with the right h/v scan frequency parameters.
I have a ViewSonic E70fb monitor:


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "E70fb-2"
DisplaySize 320 240
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Check your video card too, which one do you have? I have an GeForce NVidia driver.
See my config:


Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Good Luck

Monitor specifications:
http://www.anz.aocmonitor.com/specs/AOC_FlatCRT_Specs%20Sheet.pdf

dwl
2nd May 2004, 05:59 PM
Thanks for the reply,
I'm booting off Fedora Core1 CD1 and anaconda is running - it probes the hardware and detects the video card type as S3 ProSavage KM133, and the monitor type as an AOC Spectrum. It then attempts to run the X Server, this is when the screen goes balank and the error message appears - The error message is comming from the monitor, 'Attention out of range H:23.8Khz V:37.8 Hz'.
I am unable to carry on with the installation.

Dave

gonzalo76
2nd May 2004, 07:20 PM
The error message is comming from the monitor, 'Attention out of range H:23.8Khz V:37.8 Hz'.
Well, H: should be 30KHz and V: should be 50Hz.

You could install Fedora Core under text mode (not graphical), or wait to Fedora Core 2 final version to be released in a couple of weeks


Greetings

dwl
2nd May 2004, 07:32 PM
The monitor works fine with Windows 98. I also tried a CTX VL700 monitor with the Fedora installation and had the same problem. I'm a beginning to think it may be the integrated S3 ProSavage graphics controller.
I wonder if anybody else has had problems or success with the S3 ProSavage?

Thanks

gonzalo76
2nd May 2004, 11:14 PM
I'm a beginning to think it may be the integrated S3 ProSavage graphics controller.
Well, I think that too.

dwl
6th May 2004, 07:55 PM
Just to let you know, I managed to get Red Hat 7.3 installed on my machine - it thought my ProSavage was a Vesa and installed no problem. I then upgraded to Fedora Core 1 - it thought my ProSavage was new hardware, but I chose to ignore the change. I now run Fedora with my ProSavage configured as a Vesa.
I long way round the problem!
Anyways - I think the Fedora install is just not up to the job - why does it not configure to a basic graphics mode that will work on the majority of machines. 5/10 for Fedora so far!

kimatrix
10th May 2004, 05:49 PM
i got a s3 prosavage on a laptop, and it works fine.
Ke the screen isn't 100% sharp as it should be and it has some problems with playing movies (it plays them but not 100% qwality more like 70%/80%)

But that could be becose i got no iedea what kind of a screen i have so i just choosed lcd 1024x768 :P

Hellme
13th May 2004, 02:20 PM
Had the same problem trying to install RH9 on a nVidia GeForce 5600FX and an LG F700P monitor. I kept on getting a message from the monitor that the frequency was out of range.

To finish the install in text mode, don't use the default install option (Enter) when Anaconda starts; instead type 'linux skipddc' which will stop it from probing the video card. Once the installation is done, use the VESA driver, which should work, and that'll get X running in graphical mode.

I had no problems installed FC1 on my system with the same spec. I didn't need to change anything, and anaconda auto-detected the video card. I'm running at 1280x1024/24bit/millions of colours, and so far, no issues.