PDA

View Full Version : Support For Mp3



vladja
6th August 2007, 03:45 PM
Well, 2 months ago i started to use Fedora 7 and now i like it. But i found a big problem : i can't play mp3!

I understand the problem with patents, but i think someone must to developp a codec pack for audio and video, free and easy installation.

I tried install gstreamer ugly, but i can't, it's fault of dependencies. I've already installed all dependencies, but i still can't install gstreamer(rpm), always it appears a message like that : error dependencies mpeg2. The problem is with libmpeg2, but i've already installed.

I don't have problems with ogg, it's a good format, but i have a big collection of music(4,000 +songs) and recode it it's a big work.

The question is : what's the posibble problem wiht gstreamer ugly? i have another alternatives, there's another codecs?

Please, help me. Thanks.

Janl
6th August 2007, 03:52 PM
It sounds like you've been mixing repositories. Tell us which repositories you are using and the error output when you try to install gstreamer-plugins-ugly and we should be able to help you.

leigh123linux
6th August 2007, 03:54 PM
Try

su -
rpm -Uvh http://rpm.livna.org/livna-release-7.rpm
yum install gstreamer-*

vladja
6th August 2007, 04:48 PM
Well, i tried install followings repositories : firstly "gst-plugins-ugly-0.10.6.tar.tar" ; and secondly "gstreamer-plugins-ugly-0.10.5-2.lvn7.i386.rpm"

Is this the problem?

vladja
6th August 2007, 04:52 PM
With the firs test i get a message like that "error dependencies liboil 3.5 or newer is needed" and with the second i get "error dependencies mpeg2"

vladja
6th August 2007, 04:55 PM
Ah, i forgot anything, I DON'T HAVE INTERNET CONECTION, I USE CYBER CAFE.

leigh123linux
6th August 2007, 05:10 PM
Ah, i forgot anything, I DON'T HAVE INTERNET CONECTION, I USE CYBER CAFE.

Heres a deps list for gstreamer-plugins-ugly ( you will need all the providers and each provider package may have unmet deps as well )

[root@localhost leigh]# yum deplist gstreamer-plugins-ugly
Loading "downloadonly" plugin
Loading "tsflags" plugin
Loading "changelog" plugin
Loading "allowdowngrade" plugin
Loading "security" plugin
Loading "protectbase" plugin
Finding dependencies:

Finished
74 packages excluded due to repository protections
package: gstreamer-plugins-ugly.x86_64 0.10.5-2.lvn7
dependency: libstdc++.so.6()(64bit)
provider: libstdc++.x86_64 4.1.2-12
dependency: libgthread-2.0.so.0()(64bit)
provider: glib2.x86_64 2.12.11-1.fc7
provider: glib2.x86_64 2.12.13-1.fc7
dependency: libc.so.6()(64bit)
provider: glibc.x86_64 2.6-3
provider: glibc.x86_64 2.6-4
dependency: liba52.so.0()(64bit)
provider: a52dec.x86_64 0.7.4-10.lvn6
dependency: libstdc++.so.6(CXXABI_1.3)(64bit)
provider: libstdc++.x86_64 4.1.2-12
dependency: rtld(GNU_HASH)
provider: glibc.x86_64 2.6-3
provider: glibc.i386 2.6-3
provider: glibc.i686 2.6-3
provider: glibc.i386 2.6-4
provider: glibc.x86_64 2.6-4
provider: glibc.i686 2.6-4
dependency: libgstriff-0.10.so.0()(64bit)
provider: gstreamer-plugins-base.x86_64 0.10.12-2.fc7
dependency: libgstbase-0.10.so.0()(64bit)
provider: gstreamer.x86_64 0.10.12-1.fc7
dependency: libstdc++.so.6(GLIBCXX_3.4)(64bit)
provider: libstdc++.x86_64 4.1.2-12
dependency: libmpeg2.so.0()(64bit)
provider: mpeg2dec.x86_64 0.4.1-2.lvn6
dependency: libpthread.so.0()(64bit)
provider: glibc.x86_64 2.6-3
provider: glibc.x86_64 2.6-4
dependency: libid3tag.so.0()(64bit)
provider: libid3tag.x86_64 0.15.1b-3.fc6
dependency: liboil-0.3.so.0()(64bit)
provider: liboil.x86_64 0.3.10-1.fc7
provider: liboil.x86_64 0.3.12-3.fc7
dependency: libpthread.so.0(GLIBC_2.2.5)(64bit)
provider: glibc.x86_64 2.6-3
provider: glibc.x86_64 2.6-4
dependency: libc.so.6(GLIBC_2.3)(64bit)
provider: glibc.x86_64 2.6-3
provider: glibc.x86_64 2.6-4
dependency: libdvdread.so.3()(64bit)
provider: libdvdread.x86_64 0.9.7-2.fc7
dependency: libc.so.6(GLIBC_2.2.5)(64bit)
provider: glibc.x86_64 2.6-3
provider: glibc.x86_64 2.6-4
dependency: libgmodule-2.0.so.0()(64bit)
provider: glib2.x86_64 2.12.11-1.fc7
provider: glib2.x86_64 2.12.13-1.fc7
dependency: libc.so.6(GLIBC_2.4)(64bit)
provider: glibc.x86_64 2.6-3
provider: glibc.x86_64 2.6-4
dependency: libm.so.6()(64bit)
provider: glibc.x86_64 2.6-3
provider: glibc.x86_64 2.6-4
dependency: libgsttag-0.10.so.0()(64bit)
provider: gstreamer-plugins-base.x86_64 0.10.12-2.fc7
dependency: libmp3lame.so.0()(64bit)
provider: lame-libs.x86_64 3.97-4.lvn7
dependency: libglib-2.0.so.0()(64bit)
provider: glib2.x86_64 2.12.11-1.fc7
provider: glib2.x86_64 2.12.13-1.fc7
dependency: libdl.so.2()(64bit)
provider: glibc.x86_64 2.6-3
provider: glibc.x86_64 2.6-4
dependency: librt.so.1()(64bit)
provider: glibc.x86_64 2.6-3
provider: glibc.x86_64 2.6-4
dependency: libgstaudio-0.10.so.0()(64bit)
provider: gstreamer-plugins-base.x86_64 0.10.12-2.fc7
dependency: libsidplay.so.1()(64bit)
provider: libsidplay.x86_64 1.36.57-12.fc7
dependency: libgcc_s.so.1()(64bit)
provider: libgcc.x86_64 4.1.2-12
dependency: libgstreamer-0.10.so.0()(64bit)
provider: gstreamer.x86_64 0.10.12-1.fc7
dependency: libmad.so.0()(64bit)
provider: libmad.x86_64 0.15.1b-4.lvn6
dependency: libgobject-2.0.so.0()(64bit)
provider: glib2.x86_64 2.12.11-1.fc7
provider: glib2.x86_64 2.12.13-1.fc7
dependency: gstreamer >= 0.10.1
provider: gstreamer.x86_64 0.10.12-1.fc7
provider: gstreamer.i386 0.10.12-1.fc7
dependency: libxml2.so.2()(64bit)
provider: libxml2.x86_64 2.6.28-2
provider: libxml2.x86_64 2.6.29-1.fc7
dependency: libgcc_s.so.1(GCC_3.0)(64bit)
provider: libgcc.x86_64 4.1.2-12
[root@localhost leigh]#

igknighted
6th August 2007, 05:13 PM
Ah, i forgot anything, I DON'T HAVE INTERNET CONECTION, I USE CYBER CAFE.

nm... thanks leigh

webbruno
6th August 2007, 05:23 PM
Hey! I use cybercofees too!!! The problem (I believe) is that you are installing the wrong packages(libmpeg2), I Think that installing a package named mpeg2dec will solve your problem, try it on the http://rpm.pbone.net, the depencies are listed in a way that will easy your installations!! =)