PDA

View Full Version : So close to wireless broadcom.Yet so far away.



kubus007
3rd August 2007, 09:46 PM
Hello linux noob here I am running fedora core 6 kernel 2.6.18 on a compaq presario r3000. This laptop has a broadcom wireless card that I have been trying to get to work. The chipset is bcm4306 and I have read this card is supported by the native bcm43xx drivers. My problem is that the card works at boot it shows the card is ok, when I do iwlist eth1 scan it shows my network and the ones around me. Also wlassistant shows I am connected. So I have a connection but I can not ping and I can not connect to my wireless network. Here are the commands I have done so far to get the card somewhat running:

# yum install bcm43xx-fwcutter
Download the firmware: # wget http://boredklink.googlepages.com/wl_apsta.o
# bcm43xx-fwcutter -w /lib/firmware wl_apsta.o (or to the directory the target is saved in)
# /sbin/modprobe bcm43xx
# cp /usr/share/doc/bcm43xx-fwcutter-005/modprobe.bcm43xx /etc/modprobe.d/
# system-config-network

If you know what is going on and can help me I would gladly appreciate it.Thanks in advance. :confused:

scotta3234
3rd August 2007, 11:23 PM
Have a look at the instructions i wrote here: http://fedoraforum.org/forum/showthread.php?t=156282

I know that different firmware versions are working or not working with certain cards. Also, for me, wireless isn't working with the latest release of the .22 kernel (I believe the .47 one)

kubus007
4th August 2007, 12:17 AM
No it wasn't the firmware I found two different kinds. I also put the transmit rate at 1mb and that didn't do it.

Users of the softmac-based "bcm43xx" driver should use the firmware from here:


http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o

Users of the mac80211-based "bcm43xx-mac80211" driver should use the firmware from here:


http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2

kubus007
4th August 2007, 02:39 AM
I feel so stupid this was such an easy fix. Just follow the instructions above to get the card recognized by fedora, but remember to disable your wired nic before you can connect to the wireless network. I am so relieved.