PDA

View Full Version : CPUSPEED freezes the system when started



mdogruel
3rd August 2007, 03:45 PM
Problem: When cpuspeed daemon is activated, the system freezes. Pressing caps lock etc. momentarily brings the system back, but only for a second, and not after the second time. After that the system cannot recover, and a reboot is required.

The system is currently working fine without the cpuspeed deamon, but "sleep" does not work anymore properly.

I had once "top" running on one terminal, while at the same time I started the daemon on another one. This way I watched how the system was brought to a complete freeze: all running jobs' cpu percentages dropped to 0% just after a couple of seconds, as the cpuspeed decided to virtually "shutdown" my both cpu's. Then top itself froze, too.

My /etc/cpuspeed.conf looks like this:


VMAJOR=1
VMINOR=1

# uncomment this and set to the name of your CPUFreq module
DRIVER="powernow-k8"

# Let background (nice) processes speed up the cpu
OPTS="$OPTS -n"

# Add your favorite options here
#OPTS="$OPTS -s 0 -i 10 -r"

# uncomment and modify this to check the state of the AC adapter
OPTS="$OPTS -a /proc/acpi/ac_adapter/*/state"

# uncomment and modify this to check the system temperature
OPTS="$OPTS -t /proc/acpi/thermal_zone/*/temperature 75"

Do you know anything about this? Deleting this /etc/cpuspeed.conf made no change!

Thanks!
Mutlu

PatMcLJr
4th August 2007, 05:09 PM
I'll chime in only so you get some kind of reply. I can't say it will be useful.

OK, it's on a laptop, right? If not, then simply forget cupspeed, dump it all together, you don't need it.
I would guess, cause I don't know, you might be have a problem with the power management on a laptop that apm, or acip or a laptop utility in kde or something.

Best of Luck,
Pat Jr

mdogruel
5th August 2007, 02:08 AM
Yes, it's a laptop. Thanks for sending the first reply! :)

I am digging everywhere to find out some clues about what might have gone wrong.

Can I ask if your cpuspeed initialization script which is located under /etc/init.d/cpuspeed has these lines, or anything to do with "Xen"? If so, then I think I know what the problem is.


xendir="/proc/xen"

and this line, for instance:


if [ ! -f $lockfile ] && [ ! -d "$xendir" ]; then

Have a good weekend!
mutlu

PatMcLJr
5th August 2007, 03:21 PM
OK, I am posting this but what it means, I don't know.




#!/bin/sh
# Startup script for cpuspeed
#
# chkconfig: 12345 06 99
# description: Run dynamic CPU speed daemon and/or load appropriate
# cpu frequency scaling kernel modules and governors

# Source function library.
. /etc/rc.d/init.d/functions

[ -f /usr/sbin/cpuspeed ] || exit 0

prog="cpuspeed"

# Get config.
if [ -f /etc/cpuspeed.conf ]; then
. /etc/cpuspeed.conf
fi

cpu0freqd=/sys/devices/system/cpu/cpu0/cpufreq
cpus='/sys/devices/system/cpu/cpu[0-9]*'
testpat="${cpus}/cpufreq/scaling_driver"
lockfile="/var/lock/subsys/$prog"
xendir="/proc/xen"
logger="/usr/bin/logger -p info -t cpuspeed"
IGNORE_NICE=${IGNORE_NICE:-0}
module_loaded=false

some_file_exist() {
while [ "$1" ] ; do
[ -f "$1" ] && return 0
shift
done
return 1
}

governor_is_module() {
# Check to see if the requested cpufreq governor
# is provided as a kernel module or not
module_info=`/sbin/modinfo cpufreq-${governor} 2>&1 > /dev/null`
return $?
}

governor_module_loaded() {
# Check to see if we have a module loaded for
# the current cpufreq governor
if [ -e ${cpu0freqd}/scaling_governor ]; then
governor=`cat ${cpu0freqd}/scaling_governor`
else
governor="none"
fi
if [ "${governor}" != "none" -a `/sbin/lsmod | grep -c -w "cpufreq.${governor}"` -ge 1 ] ; then
return 0
fi
return 1
}

adjust_cpufreq() {
# First arg is a param under $cpu/cpufreq/
# Second arg is the value you want to set that param to
for cpu in ${cpus}; do
echo $2 > $cpu/cpufreq/$1
done
}

start_cpuspeed() {
echo -n $"Starting $prog: "
# cpuspeed daemon thresholds are specified as idle percentages,
# cpufreq modules as busy percentages, so we need to do some
# math here for use of unified config...
# DOWN_THRESHOLD doesn't mean exactly the same thing for
# cpuspeed as it does for the cpufreq governors, but close
# enough, and if not specified, we use same defaults as governors.
if [ -n "$UP_THRESHOLD" ]; then
let UP_THRESHOLD=100-$UP_THRESHOLD
else
UP_THRESHOLD=20
fi
if [ -n "$DOWN_THRESHOLD" ]; then
let DOWN_THRESHOLD=100-$DOWN_THRESHOLD
else
DOWN_THRESHOLD=80
fi
OPTS="$OPTS -p $UP_THRESHOLD $DOWN_THRESHOLD"
if [ -n "$MIN_SPEED" ]; then
OPTS="$OPTS -m $MIN_SPEED"
fi
if [ -n "$MAX_SPEED" ]; then
OPTS="$OPTS -M $MAX_SPEED"
fi
if [ "$IGNORE_NICE" -eq 0 ]; then
OPTS="$OPTS -n"
fi
daemon cpuspeed -d $OPTS
RETVAL=$?
return $RETVAL
}

stop_cpuspeed() {
if [ -n "`pidof cpuspeed`" ]; then
echo -n $"Stopping $prog: "
killproc cpuspeed -USR1
killproc cpuspeed -INT
fi
if [ -n "`pidof cpuspeed`" ]; then
killproc cpuspeed
fi
RETVAL=$?
return $RETVAL
}

start() {
if [ ! -f $lockfile ] && [ ! -d "$xendir" ]; then
if ! some_file_exist $testpat ; then
# Attempt to load scaling_driver if not loaded
# but it is configured

if [ -n "$DRIVER" ]; then
/sbin/modprobe "$DRIVER"
else
if [ -d /proc/acpi ] &&
grep flags /proc/cpuinfo | \
grep -q est ; then
# use ACPI as a fallback
/sbin/modprobe acpi-cpufreq 2> /dev/null
# if even ACPI didn't work, remove it
# and then next test will bail out.
[ -d ${cpu0freqd} ] || \
/sbin/modprobe -r acpi-cpufreq 2> /dev/null
else
# No scaling. Just exit.
return 0
fi
fi
fi

# If we get this far with no driver, we must have no scaling.
# We're doomed.
[ ! -f ${cpu0freqd}/scaling_driver ] && return 0

drv=`cat ${cpu0freqd}/scaling_driver`

case "$drv" in
centrino|powernow-k8|p4-clockmod|acpi-cpufreq|e_powersaver)
default_governor=ondemand
;;
*)
default_governor=userspace
;;
esac
governor=${GOVERNOR:-${default_governor}}
governor_is_module && /sbin/modprobe cpufreq-${governor}
if [ `grep -c -w ${governor} ${cpu0freqd}/scaling_available_governors` -ge 1 ] ; then
$logger "Enabling ${governor} cpu frequency scaling governor"
else
$logger "Invalid governor \"${governor}\" specified, falling back to ${default_governor}"
governor_is_module && /sbin/modprobe -r cpufreq-${governor}
governor=${default_governor}
governor_is_module && /sbin/modprobe cpufreq-${governor}
fi
adjust_cpufreq scaling_governor ${governor}
# cpuspeed daemon only runs w/userspace governor
if [ "${governor}" == "userspace" ]; then
start_cpuspeed
RETVAL=$?
else
if [ -n "$MIN_SPEED" ]; then
adjust_cpufreq scaling_min_freq $MIN_SPEED
fi
if [ -n "$MAX_SPEED" ]; then
adjust_cpufreq scaling_max_freq $MAX_SPEED
fi
if [ -n "$UP_THRESHOLD" -a ${governor} == "ondemand" ]; then
adjust_cpufreq ondemand/up_threshold $UP_THRESHOLD
fi
if [ -n "$DOWN_THRESHOLD" -a ${governor} == "conservative" ]; then
adjust_cpufreq conservative/down_threshold $DOWN_THRESHOLD
fi
if [ "$IGNORE_NICE" -eq 1 -a ${governor} == "ondemand" -o ${governor} == "conservative" ]; then
adjust_cpufreq ${governor}/ignore_nice_load $IGNORE_NICE
fi
echo -n "Enabling ${governor} cpu frequency scaling: "
success
RETVAL=0
fi
echo
# Technically, not quite right in non-cpuspeed daemon
# cases, but close enough to indicate that we're
# doing some sort of cpu frequency scaling.
[ $RETVAL = 0 ] && touch $lockfile
else
if [ -d "$xendir" ]; then
$logger "CPU Frequency scaling is currently not supported on xen kernels"
fi
return 0
fi
return $RETVAL
}

stop() {
[ ! -f ${cpu0freqd}/scaling_driver ] && return 0
drv=`cat ${cpu0freqd}/scaling_driver`
governor_module_loaded && module_loaded=true

if [ "${governor}" != "userspace" ]; then
echo -n "Disabling ${governor} cpu frequency scaling: "
$logger "Disabling ${governor} cpu frequency scaling governor"
for cpu in ${cpus}
do
echo userspace > $cpu/cpufreq/scaling_governor
cat $cpu/cpufreq/cpuinfo_max_freq > $cpu/cpufreq/scaling_setspeed
done
if [ $module_loaded == true ]; then
/sbin/modprobe -r cpufreq-${governor}
fi
success
RETVAL=0
else
stop_cpuspeed
RETVAL=$?
fi
echo
[ -n "$DRIVER" ] && /sbin/modprobe -r $DRIVER
[ $RETVAL = 0 ] && RETVAL=$?
[ $RETVAL = 0 ] && rm -f $lockfile
return $RETVAL
}

case "$1" in
start)
start
;;

stop)
stop
;;

status)
governor_module_loaded && module_loaded=true
if [ -d "$xendir" ]; then
echo "Frequency scaling not supported under xen kernels"
elif [ $module_loaded == true -o ${governor} == "performance" ]; then
echo "Frequency scaling enabled using ${governor} governor"
else
status cpuspeed
fi
;;
restart)
stop
start
;;
condrestart)
governor_module_loaded && module_loaded=true
if [ $module_loaded == true -o \
-n "`pidof cpuspeed`" -o \
${governor} == "performance" ] ; then
stop
start
fi
;;

*)
echo $"Usage: $0 {start|stop|restart|condrestart|status}"
exit 1

esac

exit $RETVAL


Hope it helps,
Pat Jr.

bpierce815
7th August 2007, 03:17 PM
I have this same issue. I initially added acpi=off to the boot command on grub, but that screwed up my irqs. Finding this thread, I turned off CPUSPEED and everything works fine except that my CPU always runs at full power, and this is a laptop so being able to throttle cpu would be nice.

I also have the same lines in my CPUSPEED init script.

Hardware:
Compaq Presario F572
Processor: AMD Athlon 64 X2
Ram: 1G DDR2
Drive: SATA 80Gig

Thanks

mdogruel
8th August 2007, 12:08 AM
OK, I managed to get cpuspeed back to behaving normally. It has nothing to do with those lines, my initial guess was wrong, it has nothing to do with the Xen kernel...

I had "noapic" in the kernel boot line on grub. Removing this made it work fine.

Bpierce815, I see that you have the same problem... So maybe you can try to delete acpi=off and see if cpuspeed would work fine again. Did you add that to make suspend work?

Cheers
Mutlu

mdogruel
8th August 2007, 12:41 AM
One more thing to add: the cpufreeze daemon and 'noapic' kernel option were working fine together with no problem until the current kernel ( 2.6.22.1-41.fc7).

Mutlu

bpierce815
8th August 2007, 06:05 PM
I have to add noapic to the end of the kernel line or the Operating system boots to a blank screen. Probably something to do with the nvidia card. I removed acpi=off after turning off cpuspeed daemon at boot and everything works fine. If i leave cpuspeed daemon turned on at boot and remove acpi=off, computer freezes, then unfreezes for a split second, then freezes again and on and on until I either find a way to shut it down or hold down the power button.

BTW, I have the x86_64 version of fedora 7 installed. Everything is working great except for cpuspeed, and I can live without that since my laptop usually stays plugged in anyway. Just a would be nice.

mdogruel
9th August 2007, 12:18 AM
What kernel are you using? Have you updated your kernel and nvidia driver recently? Are you getting weird irq warning messages?

I am using the x86_64 version as well. I had to put that noapic too, but it works with no problem now.

What if you add "irqpoll vga=normal" to your kernel options without the noapic or acpi=off, will it do any better?

If this doesn't help, try to put "irqpoll vga-normal acpi=off"

If you are still having problems:

a) change the "driver=nvidia" to "driver=nv" in your /etc/X11/xorg.conf (a restart required to see the effect)

b) if "a" fails, as a final resort, rename xorg.conf to something like xorg.old and see if everything will work fine after a reboot.

If you will need to change something but X does not load in any of the scenarios above, add just "3" to the kernel line on grub, without the quotations. It will start without the X support but you will be able to login.

Hope this helps.
Mutlu

bpierce815
9th August 2007, 03:46 AM
I will try what you suggest, but unfortunately, after a failed attempt to update the bios to possibly alleviate some of these issues, My computer is dead. Still under warranty so HP will fix but it will take a couple of weeks for them to get it back to me.

:(

mdogruel
9th August 2007, 12:00 PM
I was asked by HP to update my BIOS as well when I complained that it is making a high-pitch buzzing noise when run on battery only, while not using AC power. It didn't solve the noise problem, but I guess I am lucky not to have experienced the same with you. What is good about this BIOS upgrade is that suspend/sleep works better now. Still not perfect, though.

I wonder if these problems are all about using 64 bits version of Fedora, along with many i386 packages installed in parallel...

Good luck!

thechronic
10th August 2007, 07:18 AM
bpierce, I just bought the exact same laptop (compaq f572us) you did a few days ago and was trying to get fedora 7 running on it (geez, what a *****!). I'm at the exact same point you are (misery loves company), after loading the ndiswrapper module with modprobe, the system log indicates that irq0 isn't available. I actually went with the 32 bit version of fedora, hoping it would be easier to get everything working...guess not.

It seems I can only start the system if acpi=off. Otherwise it locks up while loading kernel+services. Even with the noapic option, I can't get that wireless card going.

How do you disable the CPUSPEED daemon before everything starts up? It looks like the daemon isn't even running when I go to the System->Administration->Services menu.

If I get anywhere with this thing, I'll be sure to post.

p.s. - The sound card also seems hopeless, it seems to detect it, but jams if you try playing anything...did you have any luck with this?

bpierce815
10th August 2007, 03:17 PM
Make sure first that you update the system with the latest kernel and updates.

When looking at Services, make sure that CPUSPEED is not checked. If it is checked then it is trying to load at boot time.

Make sure that you append "noapic irqpoll" to the kernel line in the boot statement in Grub.

I had no problems getting the wireless card up and running, once I was able to boot the laptop without the acpi=off option, and I was only able to do this once the cpuspeed service was stopped.

Once I get my laptop back I will experiment with installing the 32 bit version as well to see if the same procedures that I used will work with it as well.

It really is a good laptop, especially for the price, and all the hardware except for the CPUscaling seemed to be working excellently before I fried it.

mdogruel
10th August 2007, 08:44 PM
There is a solution to cpuspeed and other irq related problems here:

http://www.dogruel.com/index.php?option=com_content&task=blogsection&id=6&Itemid=38

Basically, routeirq or assign-bus could be the saver!

Cheers
Mutlu

bpierce815
10th August 2007, 09:33 PM
So for those that need clarification from the article: The kernel line in your grub.conf for 2.6.22.1-41 kernel should look like this:


kernel /boot/vmlinuz-2.6.22.1-41.fc7 ro root=LABEL=/ rhgb quiet pci=routeirq

or


kernel /boot/vmlinuz-2.6.22.1-41.fc7 ro root=LABEL=/ rhgb quiet pci=assign-buses


Can those that were having issues with HP/Compaq laptops try this, and report back?

I will try this as soon as I get my lappy back.

thechronic
13th August 2007, 08:16 AM
I've had no luck with all these options.
-I can't boot unless acpi=off, even though CPUSPEED is disabled.
-I have tried the assign-buses, routeirq, and irqpoll options. They all cause my PC to run extremely slowly, and lock while services load. Unusually, if I tap the power button quickly, it triggers it to move a few steps forward.
-The noapic option doesn't seem to have an effect on anything.
-bpierce, I've had no luck getting the wireless card to run...I keep getting the irq0 problem. Are you using ndiswrapper? I'm using the latest and greatest patches with kernel 2.6.22.1-41 (32 bit). I'm using the 'nv' drivers, not the proprietary ones from nvidia. I'm not sure if that will make a difference, but lspci indicates the graphics card is also using irq0...so it might work.
-I forgot to mention I tried getting ubuntu (yes I know, yuck) running on this pc as well...similar problems.

mdogruel
13th August 2007, 02:36 PM
What's the model of your laptop? "routeirq" solved my problem on my HP Pavilion. But I have recently had a BIOS upgrade. Can you check if you have the latest BIOS installed?

bpierce815
13th August 2007, 04:45 PM
What is the output of "chkconfig cpuspeed"?

I was running the x86_64 kernel to get mine to run. I couldn't even get i386 to install. If you are running the i386 kernel try installing x86_64 instead. You can check by typing "uname -a".

I could not boot without "noapic", "irqpoll" stopped erroneous messages popping up about IRQs and I could not get the wireless up with "acpi=off" because the wireless card would be assigned to irq0 which is invalid.

It is not going to matter what version of ndiswrapper or native drivers you use if you can not get the card assigned to a valid irq. Turning the cpuspeed service off before boot allowed me to run without "acpi=off".

Thanks,
Ben

bpierce815
13th August 2007, 04:52 PM
I forgot to mention that I had loaded the proprietary nvidia drivers as well. This may have an effect.

Chronic - I would be interested in knowing what combination works for you, please don't give up. I will have my laptop back in less than a weeks time and will start trying different combinations.

Thanks,
Ben

bpierce815
17th August 2007, 05:55 PM
OK. I got my laptop back and so far I have tried the routeirq option. Note - use pci=routeirq instead of just routeirq. Did this work? Well, half of the time. If I saw the NVIDIA logo prior to rhgb loading, I knew that everything was going to come up properly. If I did not, it would hang when starting X. This may be an issue because I am using NVIDIA drivers. I am not sure.

Off to try pci=assign-buses :D

bpierce815
17th August 2007, 06:12 PM
OK. pci=assign-buses results in "PCI unknown option: assign-buses" So no-go on that one.

Actually, booting with no options at all yielded the same result as pci=routeirq, would boot half of the time. I am wondering if there is some issue between the NVIDIA driver and apic? Turning APIC off boots the system everytime. Turning APIC on boots the system every other time. I will continue to research.

Fortunately, HP support did not format my hard-drive so I did not have to reinstall. Unfortunately this means that I am unwilling to create extra work for myself to try to install i386 versions of fedora and Ubuntu. - Sorry :(

However the X86_64 version of fedora is definately working well for me except for apic, and I hear this is an issue with many laptops.

Note-when I am able to fully boot without the noapic option, CPUSPEED seems to work.

- Ben

thechronic
20th August 2007, 03:24 AM
Well I installed the proprietary drivers from Nvidia.
-The x server won't start unless I have the noapic option (with the nvidia drivers)
-I have to boot with acpi = off, otherwise the computer jams while booting, but moves along if i tap the power button. This sucks as I won't be able to see how much power is remaining on my battery.
-irqpoll also causes jamming, and I have to tap the power button to keep moving
-The graphics now seems to be assigned a different irq (7) after installing the proprietary drivers. When I attempt to load ndiswrapper now, I still get an irq0 problem, but there are way less errors.
-I disabled cpuspeed on all runlevels, and this is confirmed by chkconfig
-I never updated the bios that came with the machine, how about you ben? Any instructions for doing it safely so that I don't have to end up sending my machine to compaq.
-I'll try out the 64 bit version which I wanted to avoid because of problems like installing Flash player and what not.

My specs are :
Compaq F572US
AMD 64 Athlon X2
1 GB RAM, 80 GB HDD
NVidia GeForce Go 6100

bpierce815
21st August 2007, 03:11 AM
The flash plugin problem is easy to get around. Just remove the x86_64 bit version of firefox and make sure that the i386 version is installed. Then the 32 bit plugins will work fine. That's the great thing about the x86_64 processors and kernels, you can run both 64 bit and 32 bit code.

- Ben

mdogruel
22nd August 2007, 01:11 AM
Bpierce, I don't know where you got that pci=assign-buses from, but it is only "assign-buses" or "irqpoll" without the "pci=" part. Or, have you first tried using these options without "pci="?

Try this:

kernel /vmlinuz-2.6.22.1-41.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet noapic noirqdebug assign-buses vga=normal

and see if it will do any better.

Good that HP didn't format your hd!
mutlu

bpierce815
22nd August 2007, 02:55 PM
Just tried vga=768 alone without noapic or irqpoll or the others. Everything is booting properly now. Must have been an issue with the NVIDIA card and specifying a vga framebuffer size fixes it. This is awesome. CPUSPEED is now working.

My grub.conf boot line looks like this:


title Fedora (2.6.22.1-41.fc7)
root (hd0,0)
kernel /vmlinuz-2.6.22.1-41.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet vga=768
initrd /initrd-2.6.22.1-41.fc7.img


I can't believe that I hadn't tried this before.

bpierce815
23rd August 2007, 10:21 PM
OK. I am posting just to give a status update. After trying everyting. The only thing that worked was setting vga=768 and leaving all other options default. This allowed me to run cpuspeed, however I would have random reboots. It would usually be between 30 minutes to an hour.

Turning off cpuspeed seemed to prevent the random reboots. I am checking sleep and hibernation now. If everything works, I may just give up on cpuspeed unless I really need it.

- Ben

thechronic
24th August 2007, 03:15 AM
good tip ben with the vga=768 thing, i was very close with the 32 bit version of fedora. I was able to get in with acpi working, and I got the wireless card working. of course I couldn't recreate the phenomenon, and the computer was really slow booting up. i'm going to try the 64 bit version now. actually, using the vga=768 option was how i originally got fedora 32 bit as well as ubuntu 32 bit to install on the laptop because it would keep locking up...i just forgot about it...

you forgot to answer this before, but did you update your bios?

Gnafu the Great
24th August 2007, 10:42 PM
I'm just chiming in. I got a good deal on the F572US, which I'm guessing might be the same deal some of you got :p. I needed a laptop for school and $500 was my budget. Anywho, I'll gladly join in the fight to help solve problems with this laptop once mine gets here (should be the middle of next week). I knew it wouldn't be the easiest to get working (AMD, Broadcom, etc.), but I don't mind a little fun and learning :D. Thank you all for the hard work you've done thus far!

EDIT: I'll also likely try some other distributions before settling on Fedora (or whatever), so I'll let y'all know if something works better/easier.

mdogruel
25th August 2007, 12:23 AM
Hi, vga=768 caused some random freezes here, as well. But a combination of things worked like a charm for me:


kernel /vmlinuz-2.6.22.1-41.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet noapic noirqdebug assign-buses vga=768

(I initially had 'vga=normal')

With these kernel options, I am able to do "suspend to ram" with no problem so far, it's quite reliable. I am using the nvidia driver, not nv, and also have no problem with open GL.

"Gnafu the great", with ndiswrapper wireless networking shouldn't be an issue even for laptops with broadcom chipsets. It wasn't stable enough, though, when I tried it on Ubuntu a couple of months ago.

My next challenge is now to have a stable system using the Xen kernels to boot different OSs from Linux ;)

Mutlu

Gnafu the Great
25th August 2007, 12:47 AM
Hi, vga=768 caused some random freezes here, as well. But a combination of things worked like a charm for me:


kernel /vmlinuz-2.6.22.1-41.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet noapic noirqdebug assign-buses vga=768

(I initially had 'vga=normal')

With these kernel options, I am able to do "suspend to ram" with no problem so far, it's quite reliable. I am using the nvidia driver, not nv, and also have no problem with open GL.

"Gnafu the great", with ndiswrapper wireless networking shouldn't be an issue even for laptops with broadcom chipsets. It wasn't stable enough, though, when I tried it on Ubuntu a couple of months ago.

My next challenge is now to have a stable system using the Xen kernels to boot different OSs from Linux ;)

Mutlu

Have you given QEMU and/or VirtualBox a try? I rather like them, and they don't require a special kernel.

mdogruel
25th August 2007, 01:54 AM
Yes I tried, but QEMU didn't work for me (couldn't install from an installation cd, due to some bug, would be off topic here...)

By the way, I have just updated my kernel to 2.6.22.4-65.fc7 (64 bit).

and guess what? :)

I removed all kernel options except for the standard "rhgb quiet".

I can confirm that on my HP Pavilion DV6000, with this new kernel, I am now able to boot with no problem, and having no irq problems. CPUSPEED is now working. Suspend to RAM is working. Direct rendering is working.

Furthermore, I am not using ndiswrapper anymore, I am using the firmware of my drivers directly, which is stable as well!

There is a happy person here:) Com'on guys, go and try the new kernel now! ;)

Mutlu (also means happy, literally)

Gnafu the Great
25th August 2007, 02:35 AM
Congratulations and thank you for allowing me to sleep well tonight! Any chance I could talk you into trying the 32-bit kernel, or do I get to be the guinea pig? ;)

And give VirtualBox a try; it's very nice :).

mdogruel
25th August 2007, 03:29 AM
TheChronic, from this thread, was going to try the 32 bit version. Let's wait until he reports if the new kernel would do any better for his laptop, too. Good night! ;)

thechronic
25th August 2007, 09:13 PM
I was using the 32 bit version all along...and it acts real screwy on this pc (compaq f572us). I was about to throw this pc out the window, but I saw that ben had a lot success with the 64 bit version on the exact same computer, so I switched last night. Best move ever. I have no problems whatsoever, the only extra grub option I had to add was vga=768. Wireless works, ACPI works, APIC works, CPUSPEED works, nvidia proprietary drivers work. The sound card seems to work better too, but I'm having jamming problems when I enable sound mixing, probably next big challenge.

Gnafu the Great
25th August 2007, 09:15 PM
I was using the 32 bit version all along...and it acts real screwy on this pc (compaq f572us). I was about to throw this pc out the window, but I saw that ben had a lot success with the 64 bit version on the exact same computer, so I switched last night. Best move ever. I have no problems whatsoever, the only extra grub option I had to add was vga=768. Wireless works, ACPI works, APIC works, CPUSPEED works, nvidia proprietary drivers work. The sound card seems to work better too, but I'm having jamming problems when I enable sound mixing, probably next big challenge.

Did you try the latest (as mentioned above) 32-bit kernel before making the switch? If not, I think I'll still try the 32-bit version and let y'all know how it goes.

Gnafu the Great
30th August 2007, 05:15 AM
Nevermind, I'm gonna go with 64-bit. After several failed attempts at getting a network install going with the i386 version, I have decided to try 64-bit tomorrow. I think my problem may have just been a misconfigured firewall, but I've already deleted the i386 ISO and I don't feel like redownloading it if 64-bit is more likely to work anyway :p. So yeah, I downloaded the 64-bit DVD at the same time as the 32-bit, so I've already got it. Now that my firewall is properly configured (I hope), I will attempt a 64-bit installation tomorrow. I'll let y'all know how it goes!

EDIT: Very fast install! Just used acpi=off with the boot.iso and pulled the files from a mounted DVD ISO over FTP (x86_64 version). I'm finishing updates now, at which point I'll try booting with the latest kernel and no added kernel options. After that, I get to add Livna and pimp my laptop :D. This is also my first 64-bit experience ;).

thechronic
31st August 2007, 03:17 AM
Some issues I have -
-My wireless card works perfectly, but with WPA enabled, NetworkManager can't consistently connect. I can connect once in a blue moon, but the rest of the time it just does the spinny thing. Do you guys have the same problem?

-I used nswrapperplugin to utilize 32 bit Flash Player in firefox. Works for the most part, but pandora.com is screwy when switching between music stations. Can somebody check if using the 32 bit version of firefox works better?

-My webbrowsing seems to be extremely slow compared to Windows...I fixed this by disabling the ipv6 modules...don't know why that would effect it, but does the trick. I think this is related more so to my ISP rather than linux.

Gnafu the Great
31st August 2007, 07:40 PM
Some issues I have -
-My wireless card works perfectly, but with WPA enabled, NetworkManager can't consistently connect. I can connect once in a blue moon, but the rest of the time it just does the spinny thing. Do you guys have the same problem?

-I used nswrapperplugin to utilize 32 bit Flash Player in firefox. Works for the most part, but pandora.com is screwy when switching between music stations. Can somebody check if using the 32 bit version of firefox works better?

-My webbrowsing seems to be extremely slow compared to Windows...I fixed this by disabling the ipv6 modules...don't know why that would effect it, but does the trick. I think this is related more so to my ISP rather than linux.

I'm just planning on using 32-bit Firefox, to avoid complications. I know I've seen mention of Firefox/Flash taking up a ton of resources when used in 64-bit mode, so I figured I'd avoid any problems and use 32-bit from the beginning. As for WPA, I found this (http://www.fedoraforum.org/forum/showthread.php?t=156282&highlight=Dell+1390) thread while searching on how to set up the wireless, and it mentions WPA_Supplicant at the bottom of the main post. Do you have that running? Does it make a difference?

Gnafu the Great
31st August 2007, 11:22 PM
thechronic, are you using fwcutter like in the thread I link to, or are you using ndiswrapper? I haven't been able to get the method explained in that thread to work yet.

EDIT: I got ndiswrapper working and I haven't had problems yet on my home network, so I'm gonna go with that ;). Besides, I get 54Mbps this way :p.

EDIT 2: I'm currently reinstalling with 32-bit to see if things work about as well. I noticed that a lot of the packages I had installed were taking up twice the space (both i386 and x86_64 packages installed). I know I don't need x86_64, but I do need i386, so I'd rather save space if the kernels work the same. I figure I'll have an overall faster and smaller system this way, because it won't be messing with compatibility all the time. I'll let y'all know if 32-bit seems to work as well (so far, the install is going just as smoothly as x86_64 with only vga=768 for a kernel parameter; I used acpi=off for the 64-bit install, though vga=768 probably would've worked).

EDIT 3: I've also left a 10GB partition for Fedora Development, which I'll be installing once 8 Test 2 is released. I'll also keep you up-to-date on that ;).

Gnafu the Great
3rd September 2007, 08:23 PM
32-bit install went as smoothly as 64-bit, and everything is working just as well (with just vga=768). I feel better now knowing that I'm not wasting space with double packages :p. Now I can hardly wait for 8 Test 2 so I can start playing with that leftover 10GB partition :D.