PDA

View Full Version : Problems with interface eth0



mitalub
2nd August 2007, 04:51 AM
I installed Fedora linux a couple weeks ago, and everything was going fine. Internet connection worked and everything.

Then today, I needed to temporarily move my cable modem. I disconnected the ethernet while the computer was still on (something I've never thought to be an issue).

Then, when I brought the cable modem back, and hooked it up as before, the internet has stopped working all together. Here's the facts:
* When I start the computer, I get "Determining IP information for eth0....[FAILED]".
* If I try and shut down the computer, it hangs permanently on "Shutting down interface eth0"
* I've tried various commands once the computer is started, but to no avail. For example "Service network restart" or "ifconfig eth0 up"
* I haven't changed anything since things last work, I merely disconnected the ethernet from the modem, and then reconnected.
* I've tested with another computer, and the ethernet should be working fine...

Any ideas? I'm really at a loss...

xxon
2nd August 2007, 02:50 PM
Which version of Fedora are you running? If it is a fresh install of FC7 you need to update your kernel and the issue should go away.

Hope that helps.