PDA

View Full Version : e2fsck on LVM?



ssdowd
2nd August 2007, 01:57 AM
I have my root partition mounted in a logical volume (/dev/VolGroup00/LogVol00) as an ext3 filesystem (basically one big filesystem for the hole machine). I now get an error when doing a dump on it:

/dev/mapper/VolGroup00/LogVol00: EXT2 directory corrupted while converting directory #3408057

If I run e2fsck -n /dev/VolGroup00/LogVol00 I see that there is some type of problem with this inode.

How do I safely run e2fsck on this fs? I tried booting from my FC5 rescue disk without mounting the filesystems, but it errors off when I try to run e2fsck /dev/VolGroup00/LogVol00 with a message about not being able to find it. How do I run e2fsck for a fs that is part of lvm?

/.autofsck is present and the fsck on boot says it is clean.

ssdowd
8th August 2007, 03:13 PM
In case anyone stumbles across this and needs an answer, I was not able to run e2fsck on a LVM disk using the FC5 rescue CD, but I was able to do it using the Fedora 7 Live CD.