PDA

View Full Version : solved: ntfs support for 2.6.22-1.41



hceylan
1st August 2007, 05:48 PM
That was in the 1-33 kernel complaints thread. This topic is to make it easy to find the self compiled rpm
For those who need ntfs support for 1-41 kernel, I am using a self compiled rpm.
yo can get it from below address...

http://www.batoo.org/fuse-kmdl-2.6.22.1-41.fc7-2.7.0-3_7.fc7.i686.rpm

Hasan Ceylan

NoSkill
1st August 2007, 05:58 PM
Does this one fix the NTFS-3G automount problem? I'm just curious as I didn't know the native NTFS driver had the same issue :confused:

(But thank you for making it available ;))

hceylan
1st August 2007, 06:21 PM
I got these installed

ntfs-config-1.0-0.4.rc5.fc7
ntfsprogs-1.13.1-6.fc7
ntfs-3g-1.710-1.fc7
kernel-2.6.22.1-41.fc7
fuse-2.7.0-3_7.fc7
fuse-kmdl-2.6.22.1-41.fc7-2.7.0-3_7.fc7
fuse-libs-2.7.0-3_7.fc7

and my tiny shinny usb 2,5" drives tells me it works ;)

NoSkill
1st August 2007, 06:41 PM
... and my tiny shinny usb 2,5" drives tells me it works ;)
Ah, cool :cool:

I might download/install it in the next few days if Fedora don't release a new SELinux package.

What did you have to change to get it to work with NTFS again?

NoSkill
2nd August 2007, 03:08 AM
NTFS was working fine before a yum update late last week!

Now I get during boot:

mounting local filesystems {failed]
mounting other filesystems [failed]
You'll have to set your SELinux to "Permissive" mode in "SELinux Management" for the NTFS automount to work on boot. When the selinux-policy-2.6.4-30.fc7.rpm update becomes available, you should be able to set it back to "Enforcing".

rjstaaf
2nd August 2007, 03:17 AM
This issue has been going full steam on the fedora-list mailing list all day today.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249943

NoSkill
2nd August 2007, 03:24 AM
This issue has been going full steam on the fedora-list mailing list all day today.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249943
Looking at that bug report suggests it is still busted in -30 too! I hope that it is just because it is in testing/development (not available to me yet through YUM) :(

ryptyde
2nd August 2007, 03:54 AM
There seems to be some confusion as to what works. I have a NTFS partition that I can access without any problems. When I plugin a USB hard drive that is NTFS then it will not mount. I'm in no hurry though as I can mount from a previous kernel or on a FC6 box if need be or from Windows if I get real desperate. :)

NoSkill
2nd August 2007, 04:46 AM
BTW how does one alter SELINUX?

See here for more info: http://www.crypt.gen.nz/selinux/disable_selinux.html

NoSkill
2nd August 2007, 05:02 AM
There seems to be some confusion as to what works. I have a NTFS partition that I can access without any problems. When I plugin a USB hard drive that is NTFS then it will not mount. I'm in no hurry though as I can mount from a previous kernel or on a FC6 box if need be or from Windows if I get real desperate. :)

The actual problem in regards to SELinux is that an up-to-date Fedora7 (after the 2.6.22-1.27 kernel) is not automounting any NTFS drives (or partitions) during the boot stage. Once you get to the desktop though you are able to manually mount the drives (or partitions) without problems. The trouble being that most internal hard drives (or partitions) don't automount by the desktop stage and need to be manually mounted (e.g: to access your Windows NTFS partitions/drives).

This only happens if you are using SELinux and it is set to "Enforcing". The "workaround" for this is to set SELinux to "Permissive", write your own customised policy rules, or use an earlier kernel (2.6.22-1.27).

NoSkill
2nd August 2007, 05:11 AM
popup lower left icon :
administration->selinux management->status
That's the way I did it, but I thought I'd offer the caution that link provided ;)


mounting local filesystems {failed]
mounting other filesystems [failed]
What are these "filesystems"? There maybe more than just NTFS issues, but I only know from what I've read about those problems (on my system).

What happens if you try SELinux "Disabled"?
Does that work?

(else, err, I dunno :eek: )

hceylan
2nd August 2007, 12:03 PM
Hi again,

The rpm I prepared is just the same version compiled on top of 1-41 kernel.

Those that are having problems with automount during the boot, if ntfs partition is dirty (suspended, hibernated or uncleanly shutdown), linux will refuse to mount. Just my 2 cents.

Hasan ceylan

NoSkill
4th August 2007, 04:08 AM
mounting local filesystems {failed]


I've just installed the latest SELinux Policy updates:
selinux-policy-2.6.4-30.fc7
selinux-policy-targeted-2.6.4-30.fc7

and I now get the mounting local filesystems [failed] issue when using "Enforced". The other "filesystems" all load up fine. But now with SELinux set to "Enforced" I still don't get my NTFS partitions automounted at boot (due to the "local filesystems" issue). I still have to manually mount my NTFS partitions once I'm in the Gnome or KDE desktop, or else I still have to use "Permissive" mode with SELinux :(

NoSkill
4th August 2007, 07:01 PM
in short: nothing has changed!

Since this happened, I've gotten 3-4 yum updates showing SELINUX updates to no avail!

I've just downloaded a fix for the SELinux/NTFS problem. If you want it, it is located here:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249943#c12

The instructions on how to install it are in the comment immediately after it (#13).

It works on my rig, no more automount problems using "Enforced" permissions :D