PDA

View Full Version : Disable Auto-renaming of ALLCAPS to lowercase



jvroig
1st August 2007, 04:55 PM
Hi.

A behavior I noticed in CentOS 4 that I have not see in Fedora 5 and 6 is now in Fedora 7.

Whenever I copy files to my USB flashdisk or removable harddisk in a USB enclosure, filenames and folder names that are written in all uppercase letters (like a folder named "HR" or "MTD") is converted to lowercase (becomes "hr" or "mtd"). This happens in CentOS4, but not in Fedora 5 and Fedora 6. I tested it on CentOS 5, and being based on Fedora 6, this unwanted behavior is gone.

But I just noticed it in Fedora 7 now. I backed up files from my Fedora 6 installation on a separate laptop, and none were converted to their lowercase equivalent. But when I plugged in my enclosure to this laptop running F7, all files and folders whose names consisted of only uppercase letters were automatically converted to lowercase. It is annoying. So after copying them to the harddisk of the laptop, I had to rename them. Once they are in the "main" harddisk (as opposed to the removable one in the enclosure), files named with all uppercase characters are left alone (as you would expect). It only happens in the removable media.

Does anybody know how to make Fedora 7 (and perhaps also CentOS4) stop doing that? It has never been a problem in Fedora 5 and 6. The filesystem of my flashdisks and HD USB enclosure is FAT32.

Thanks.

jvroig
2nd August 2007, 04:13 PM
<just a gentle bump after 24 hours>

Hello.
Does no one else notice this? You can try it out with any FAT32 flash disk. It is annoying especially when you are trying to back up files in your webserver for example.

Seve
2nd August 2007, 05:55 PM
Hello:
from a terminal
gconf-editor
/system
/storage
/default_options
/vfat

right click on the key in the right hand pane
and select edit
and change to
shortname=mixed

Reboot and give it a whirl again.

If your mount options are coming from your /etc/fstab then add the above as a mount option

Seve

lazlow
2nd August 2007, 06:24 PM
You might have to install gconf-editor

yum install gconf-editor


Afternoon Seve

Pretty handy thing here. Any chance you know how to force it to read .iso in all caps?

Thanks
Lazlow

Seve
2nd August 2007, 06:49 PM
Hello Lazlow:

How are things ?


Any chance you know how to force it to read .iso in all caps?

Not a clue :)

Seve

lazlow
2nd August 2007, 07:01 PM
For converting a lot of file names take a look at the convmv package. I use:

convmv --upper --notest *.*

quite a bit.


Seve

Ok, same old same old. Did your new PSU come in? Did they cover it under warranty?

Lazlow

Seve
2nd August 2007, 07:14 PM
Hello:
No PSU yet ?
Probably next week some time, I hope :)

Seve

jvroig
8th August 2007, 11:28 AM
Cool thanks.

One other thing I don't understand is that Fedora 7 does not mount my USB flashdisks :(

External HDs that are likewise connected through USB is ok, that's where my files came from. But My Kingston 2GB flashdisk, Kingston 1GB flashdsik, and Apacer 2GB flashdisks all do not get auto mounted. This has never been a problem in FC5, FC6, CentOS4, CentOS5, and also in the last two Ubuntu releases, as well as in another RHEL clone I've used, Scientific Linux.

I am wondering why Fedora 7 suddenly failed in this, at least for my HP Pavilion ze4910us. It is the only issue remaining that prevents me from replacing my FC6 installation.

Anybody have a clue about this?

Thanks in advance :) in the meantime, FC6 is rock-solid for me, and plays everything from .avi to wma files, CDs, DVDs, and serves me excellently in my sysdev work.