PDA

View Full Version : Compiz-Fusion install problem



PaulFXH
1st August 2007, 03:36 PM
I tried to install Compiz-Fusion from this guide (http://www.howtoforge.com/fedora7_beryl_compizfusion) but I'm not getting very far.
I get this error:

Error: Missing Dependency: compiz >= 0.5.1 is needed by package compiz-fusion-plugins-extra
Error: Missing Dependency: compiz = 0.5.1-0.11.20070720git.fc7 is needed by package compiz-gnome
Error: Missing Dependency: compiz >= 0.5.1 is needed by package compiz-fusion-plugins-main
Can't find these anywhere.
Any clues?
Thanks
Paul

NoSkill
1st August 2007, 05:54 PM
You can't find them? Are you sure? They should be at kagesenshi's repo site. If you followed that guide, then the repository should be accessible by YUM :confused:

PaulFXH
1st August 2007, 06:14 PM
You can't find them? Are you sure?
Well, as sure as it's possible for a human to be about anything :)
Two possible explanations for this strange behaviour are:

1) I have Beryl installed. Should I uninstall it before trying compiz-fusion? (although I really can't see why it would give rise to this error although the guide did say you can't have both together).

2) During the (aborted) install I get this message:

76 packages excluded due to repository protections
Could this have any bearing on my problem?

NoSkill
1st August 2007, 06:36 PM
Well, as sure as it's possible for a human to be about anything :)
Two possible explanations for this strange behaviour are:
1) I have Beryl installed. Should I uninstall it before trying compiz-fusion? (although I really can't see why it would give rise to this error although the guide did say you can't have both together).
Yes, you'll have to delete anything related to the existing compiz and/or beryl packages. Beryl is a descendent of the original compiz, but compiz-fusion is the (beta) reintegration of compiz+beryl. Because of this "new" relationship, beryl is now "excess baggage", but if it is left on your system it may/will cause issues.


2) During the (aborted) install I get this message:

76 packages excluded due to repository protections
Could this have any bearing on my problem?
If it aborted, then yum is just saying that it could not complete your request ;)