PDA

View Full Version : FC7 Firefox - can't download extensions



slycker
1st August 2007, 03:49 AM
Hi,
I just moved up to FC7 (fresh install) from FC6, and am having difficulty getting firefox to download extensions. I get a download error:

-----------------------------------------------------
Firefox could not download the file at:

....file location.....xpi

because: Download error
-228
-----------------------------------------------------

I've scoured the net, but found no working solutions for me. The mozilla/firefox help pages suggested either too small a cache or firewall issues, but that didn't seem to be it (though I had difficulty fully disabling the firewall for that test). My router's settings are exactly the same as they were with FC6, and shouldn't be any problem there.

Other sites suggested I remove the extensions.ini & other associated files, to be regenerated, and I did - to no effect.

I applied all the latest and greatest updates, but no joy there either.

One site had suggested downloading the extension file then dragging it into the addons window, but that gave me a new error, that the download file wasn't a valid extension. This was interesting, so I tried a number of different extensions that I knew to have previously worked, and none of them did.

Any insights?
Thanks!

slycker
1st August 2007, 04:56 AM
I just found a solution - removing the xine-mozilla plugin (from livna). I don't know why this was interfering, but hey, it gives me somewhere to start from.

conan1989
18th August 2007, 03:56 PM
I just found a solution - removing the xine-mozilla plugin (from livna). I don't know why this was interfering, but hey, it gives me somewhere to start from.

i'm having the same problem only it didn't work for me or i stuffed it up. i did the following;
su -
yum remove xine-mozilla

and didn't do anything

cheers for the land of aus

marko
18th August 2007, 04:43 PM
The mozilla/firefox help pages suggested either too small a cache or firewall issues, but that didn't seem to be it (though I had difficulty fully disabling the firewall for that test).

An easy way to disable the firewall totally for a short test:

(as root user):

service iptables stop

do your testing.....

service iptables start

Mark

conan1989
19th August 2007, 08:09 AM
thank you heaps, turns out it was SELinux that was making a mess of things

jeremywsmith197
16th December 2007, 10:55 AM
i've tried all the above solutions and still get that error. Anyone have any other advice? All worked fine in fc6 but since moving to 7 its been a problem. Almost discourages moving to fc 8 in fear of loosing something else.

Demz
16th December 2007, 11:20 AM
i tried, still nothng works,