PDA

View Full Version : Yum oddness



Jrandom
31st July 2007, 04:00 AM
Hello,

Yum is behaving rather strangely. I added some unmetered mirrors to my yum repos, and now i cant seem to download some files off the mirrors, even though if i do it manually all is well....


Here is the output from yum




um install sendmailLoading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core [1/3]
extras [2/3]
http://mirror.internode.on.net/pub/fedora/linux/extras/5/i386/repodata/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
Cannot open/read repomd.xml file for repository: extras
failure: repodata/repomd.xml from extras: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from extras: [Errno 256] No more mirrors to try.


However if i then use curl or wget



wget http://mirror.internode.on.net/pub/fedora/linux/extras/5/i386/repodata/repomd.xml
--11:49:23-- http://mirror.internode.on.net/pub/fedora/linux/extras/5/i386/repodata/repomd.xml
Resolving mirror.internode.on.net... 192.231.203.130
Connecting to mirror.internode.on.net|192.231.203.130|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1140 (1.1K) [application/xml]
Saving to: `repomd.xml'

100%[================================================== ================================>] 1,140 --.-K/s in 0s

11:49:23 (18.1 MB/s) - `repomd.xml' saved [1140/1140]



Is there a way to enable debugging in yum? I cant seem to find a verbose mode, or a mode that will step through or anything useful like that. Alternately does anyone know how yum actually does the package retrieval, or have an idea what might be the cause?

Previously I had some problems with IPv6 causing the dns lookup to fail and point to 1.0.0.0 all the time, but i thought i was over that when i blacklisted the ipv6 module...

pinging does correctly resolve the IP, so i am running out of ideas!

Thanks

bob
31st July 2007, 04:16 AM
Well, Fedora5 has reached End of Life and has been discontinued from most of the mirrorlists, so you're bound to have problems using yum. Any chance of upgrading to Fedora7 or at least Fedora6?

marko
31st July 2007, 04:18 AM
Jrandom

You can edit the /etc/yum.conf
and change the debuglevel to a number bigger than 2 (debuglevel=2 is the default,
10 is the highest it goes).
Also try commenting out the mirrorlist= entry in your fedora-extras.repo
file and comment in the baseurl=
Sometimes this helps to go straight to the base server and not one of
the mirrors (sometimes the mirrors aren't correctly updated in sync)
. If it works, remember to change it back since usually it's
best to use the mirrors. Like Bob said, since you're on F5 maybe
it should stay on baseurl or you should update to F7.

Mark

Jrandom
31st July 2007, 05:40 AM
as for updgrading to a new fedora, I'm only using the box as a lightweight server, so all i need is a few server progs. How complex is the update procedure, i assume i have to change kernel? I have a few custom kernel modules that i compiled from source, and recompiling is a bit of a drag (the source packages whilst well written were woefully managed).

Yeah, it worked before i used the local mirror and it then worked sporadically after that. thanks for the debug info, ill give that a whirl.

When you say baseurl i assume you mean the default fedora servers?

Thanks ppl.

Jrandom
31st July 2007, 05:54 AM
Hmm. Its definitely a name resolution issue. But its only occurring within yum.. I replaced the servers with the download.fedora.redhat.com and it still didn't work. I finally changed it to the IP of the fedora mirrors and it worked fine.

*sigh* WTF is going on?

Edit: Scratch that. Not the problem either. Now i'm getting 301 document moved for some IP substitutions. I cant seem to make heads or tails of the problem. Some horrible combination of IP & mirror hostname allowed me to get the DL to work, but it shouldn't have changed anything. I just don't understand!

bob
31st July 2007, 11:57 AM
Leigh has posted a possible solution here: http://forums.fedoraforum.org/forum/showthread.php?t=160195 However, for the long term, I'd consider using CentOS instead of Fedora for a server since the life span is 3 years for CentOS and it's essentially a no-cost version of RHEL; rock solid and very close to Fedora6.

Jrandom
1st August 2007, 01:06 PM
worked out the problem, it is a name resolution issue, though it is *very* odd that it only affects yum. I can see that yum is trying to connect to 1.0.0.0 by doing a netstat. Maybe its because yum is caching DNS entries somewhere? I can't think why ping is not affected, nor other operations like using a browser!

edit: Solution!

The router i use is an NB5plus4, details below. There appears to be a bug in the DNS forwarding if you use an automatically obtained DNS. By manually setting the DNS on the router everything worked fine. Oh for a decent router, or the ability to fix bugs in my firmware without having to worry about turning it into a brick. C'est la vie.



Model Number NB5Plus4
HW Revision V0.3
Gateway 1.C08NCT12.8227A
ATM Driver 4.05.04.01
DSL HAL 4.00.01.00
DSL Datapump 4.01.02.00 Annex A
SAR HAL 01.07.2a
PDSP Firmware 0.50
Boot Loader 1.2.1.5

Jrandom
11th August 2007, 05:34 AM
Update for googlers:
I found that this problem reappeared later. I then upgraded the modem firmware to version 373_1.C08NCT17.8227A_051125 from 373_1.C08NCT12.8227A_051125 using files from the netcomm website and it appears to have resolved itself once more.

I hope that this is the last of it.