PDA

View Full Version : Boot Partition seems to be corrupt



shadowspawn
30th July 2007, 10:00 AM
Hi,

I have been having problems launching nautilus, rebooting and shutting down for a while now and it has got steadly worse. :eek:
I am running with a FC6/Ubuntu/XP system with FC6 as my main OS - even convinced the wife to move over from XP.

First I noticed what was going wrong was that the Desktop refused to launch properly with a black blank background.
As a thought I tried FC6 logging into KDE rather than Gnome - miraculously everything returned to "normal".

I thought to try reinstalling GNOME - but YUMEX froze and when I rebootedthe GDM started to refuse to offer me the login screen.

I could still login to the PC command line and managed to STARTX sucessfully a couple of times (mainly as Root but occasionally as myself) but still has the problems with the desktop.

Anyway - trying to think a solution I though now would be the time to upgrade my system to Fedora 7. I booted into Ubuntu to tidy up my system (home drives, back up /etc ) in preperation and found Ubuntu behaving the same way. So had to manage this from the command line. - all except accesing the /boot drive for Fedora to back up grub.conf.

Inserting the Fedora7 DVD and booting from that and when "Searching for Fedora Installations" it decided to about and told me that the system was safe to reboot,
Same story when I tried with the FC6 DVD.

now I was really lost cant boot properly, cant install, and Ubuntu looking the same. So bit the bullet and tried XP - I have some software that allows me to read ext3 drives under windows but was unable to read the fedora /boot drive. :confused:

now I was really going mad at the PC. Then I though - amend Ubuntu's /etc/fstab and not mount the Fedora /Boot partition - magicaly everything back to the semblance of normal - except still the Fedora Problem.


On my /boot partition Fedora has installed a series of ?8? kernels - as I cant properly mount it I am readying from the Grub Menu.


Are there any suggestions as to how to get out of this mess - only remaining one that I can think of is to reformat the partition and see if I will then be able to reinstall Fedora -- but what if this does not work.

Ideas gratefully received before I do anymore damage to my system :D

shadowspawn
31st July 2007, 09:35 PM
Ok - seem to be back up and running.

While in Ubuntu I used e2fsck on the Boot partition - from them one in things got better.
Reinstalled GDM and able to log into Fedora.