PDA

View Full Version : unable to find gobject-2.8.0 needed to compile gtk-sharp 2.8.3 for FC4



someuser77
28th July 2007, 06:14 PM
Hello.
I am trying to install MonoDevelop (http://www.monodevelop.com/Download) on Fedora Core 4 to use it as a development environment to code C# on Linux and I ran into a small problem:
To compile MonoDevelop I need glib-sharp-2.0 and to install it from gtk-sharp-2.8.3 (http://www.monodevelop.com/Download) I need gobject-2.8.0 and I couldn't find any source or rpm packages.
The error I get when I try to compile gtk-sharp-2.8.3 is:

checking for GLIB... configure: error: Package requirements (gobject-2.0 >= 2.8.0) were not met.Where can I find gobject-2.8.0 or what do I need to do to install MonoDevelop?

leigh123linux
28th July 2007, 06:30 PM
try having a look at this site as they have prebuilt rpm's


http://www.go-mono.com/download-stable/fedora-4-i386/

someuser77
28th July 2007, 06:36 PM
Thank you for your reply leigh123@linux, but the glib-sharp2 version there is 2.4.3 and MonoDevelop needs >= 2.8.0.

leigh123linux
28th July 2007, 06:38 PM
Thank you for your reply leigh123@linux, but the glib-sharp2 version there is 2.4.3 and MonoDevelop needs >= 2.8.0.

I think FC4 is too old for this to work



Latest Gtk# (which are only supported on newer distros)

http://go-mono.com/sources-stable/

leigh123linux
28th July 2007, 06:48 PM
you could try a older version of monodevelop

http://rpmfind.net/linux/rpm2html/search.php?query=monodevelop

someuser77
28th July 2007, 09:19 PM
Thank you very much for the help leigh123@linux!
I removed mono from yum (yum remove mono) and all the mono rpms I installed (rpm -e package_name), then I installed Mono 1.2.1 (http://go-mono.com/archive/1.2.1/download/fedora-4-i386/) from the Old Releases (http://mono-project.com/OldReleases) (I also needed gtkhtml3-3.6.2-1.i386.rpm (http://fr.rpmfind.net/linux/rpm2html/search.php?query=libgtkhtml-3.6.so.18)) and I think it worked!