PDA

View Full Version : Install ATI x1300 Pro driver on Fedora 7



YevgenyEfter
28th July 2007, 09:47 AM
Hello!

After waiting for some time, the 8.39.4 ATI driver supports the xorg version. As it was released, I tried to install it on Fedora 7 with the ATI x1300 Pro video card. What happened was that after installing it, the X Server didn't start, and it said that I have some mistakes on the xorg.conf, and suggested to fix it. After "fixing", the xorg.conf used the vesa driver, as it was in the beginning.
Maybe anyone knows how I can make the card work on Fedora 7?

Thank in advance!

congoclash
28th July 2007, 10:32 AM
What repo are you getting the driver from, livna? Try these in your xorg.conf, it worked for me (with radeon X1300) before I gave up on fglrx proprietary driver. Too buggy, takes too much time to tweak and works only with a specific kernel version. IMHO the situation with accelerated video drivers has always been pathetic and a huge drawback to Linux in general. It forces me to use windoze more than I'd like.

Section "Module"
Load "bitmap"
Load "ddc"
Load "dbe"
Load "fbdevhw"
Load "record"
# Load "extmod"
Load "freetype"
Load "type1"
Load "glx"
Load "dri"
Load "int10"
Load "GLcore"
# Load "extmod" but omit DGA extension (the DGA extension is broken in the fglrx driver)
SubSection "extmod"
Option "omit XVideo"
EndSubSection
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "DesktopSetup" "single"
EndSection

Also try manually setting your HorizSync and VertRefresh in the monitor section. Hope this helps and let me know how it goes.

YevgenyEfter
28th July 2007, 10:45 AM
I used this guide:

http://news.softpedia.com/news/How-to-Install-Video-Drivers-on-Fedora-7-59919.shtml

Livna doesn't have the new driver.

I will try your xorg.conf. Thanks!

YevgenyEfter
28th July 2007, 12:54 PM
Thank you, congoclash!

When I edited the Modules section as you told me to do, the card started working!

Thanks again!