PDA

View Full Version : How to reinstall yum



Deb
28th July 2007, 02:36 AM
I recently upgraded to F7 from FC6. everything went fine but after 2-3 updates yum stopped working. got frustrated and removed yum, yum-utils pirut and yumsd - and was surprised to find there is no rpm package for the latest yum.
The duke site has only src.rpm and tar.gz- tried the tar.gz and then make make-install, no luck there- cant even do a clean uninstall as there is no make uninstall script. Overall I think I have completely messed up things here.
please advice.
deb

leigh123linux
28th July 2007, 02:48 AM
try ___________________________-



su -
wget http://ftp-stud.hs-esslingen.de/pub/fedora/linux/updates/7/i386/yum-3.2.1-1.fc7.noarch.rpm
rpm -ivh yum-3.2.1-1.fc7.noarch.rpm
yum clean all
yum update

Deb
28th July 2007, 01:53 PM
leigh123, thanks, that worked.

Deb
7th August 2007, 01:12 AM
after following leigh123's link I could reload yum again and it worked few times now I am having this problem when I want to update:-


$sudo yum update
Password:
Loading "installonlyn" plugin
Setting up Update Process
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 1.9 kB 00:00
No Packages marked for Update/Obsoletion


When from my experience I know that if you donot update for a week there will be some updates in the repo.
so I tried to clear the cache:-


$ sudo yum clean all
Loading "installonlyn" plugin
Cleaning up Everything
Error: Error accessing directory /var/cache/yum/updates/headers, [Errno 2] No such file or directory: '/var/cache/yum/updates/headers'

Actually the original error was :-


Error: Error accessing directory /var/cache/yum/updates/headers, [Errno 2] No such file or directory: '//var/cache/yum/updates/headers'


so I promptly went to /etc/yum.conf and removed the first "/" before var- but that did not improve matters as you can see.
Then loaded yum-utils and issued "sudo yum makecache"
after that it started working again- thought will post my experience just in case :D . Any ways any clue why yum was searching for headers in "//var/cache/yum/updates/headers" do you need to manually set the yum.conf right? is it a bug in "yum 3.2.1"?