PDA

View Full Version : Problems with codeblocks



WakkaDojo
27th July 2007, 03:46 AM
I recently installed code::blocks and wxGTK from source files. When I try to execute codeblocks, I get the following error:
./codeblocks
./codeblocks: error while loading shared libraries: libwx_gtk2u-2.8.so.0: cannot open shared object file: No such file or directory
Note the following line in my libcodeblocks.la file (located in /opt/codeblocks-svn/lib):
# Libraries that this one depends upon.
dependency_libs=' -L/opt/wx/2.8/lib -lwx_gtk2u-2.8 -lpthread -ldl'
Also, note the contents of my /opt/wx/2.8/lib folder:
ls /opt/wx/2.8/lib
libwx_gtk2u-2.8.so libwx_gtk2u-2.8.so.0 libwx_gtk2u-2.8.so.0.1.1 wx
What's wrong??

Milk_Man
27th July 2007, 08:54 AM
I get unable to delete Codeblocks::Username and it just freezes.....you not the only one who can't use it...

I was sorely disappointed that I couldn't use it.....

WakkaDojo
27th July 2007, 12:35 PM
Yeah, I know what you mean. It seemed like an amazing C/C++ IDE, and the cross compilation capabilities looked really fantastic.

WakkaDojo
27th July 2007, 12:44 PM
I solved the problem, which was pretty simple. All i needed was a symbolic link in /ur/lib:
sudo ln -s /opt/wx/2.8/lib/libwx_gtk2u-2.8.so.0 /usr/lib/libwx_gtk2u-2.8.so.0.

Milkman -- First I installed an RPM version of codeblocks and I too couldn't get it to work. Try compiling the tarball, you'll probably have more luck.

Milk_Man
27th July 2007, 12:56 PM
I solved the problem, which was pretty simple. All i needed was a symbolic link in /ur/lib:
sudo ln -s /opt/wx/2.8/lib/libwx_gtk2u-2.8.so.0 /usr/lib/libwx_gtk2u-2.8.so.0.

Milkman -- First I installed an RPM version of codeblocks and I too couldn't get it to work. Try compiling the tarball, you'll probably have more luck.

I'm pretty much a newbie with the console commands........I just haven't had the time to learn them.........But I really need to.....