PDA

View Full Version : KDE Install Error



markness
27th July 2007, 03:13 AM
I tried to switchdesk.


[root@cpe-74-76-131-49 ~]# switchdesk kde
Red Hat Linux switchdesk 4.0
Copyright (C) 1999-2004 Red Hat, Inc
Redistributable under the terms of the GNU General Public License
ERROR: KDE is not installed on your machine! to install KDE, please type
yum groupinstall "KDE Software Development"

I did what it said. This is the error message I get at the end of what seems to be a long install.


Error: python-devel conflicts with python < 2.4.4-1.fc6

Why does Linux hate me? :(

unixguru88
27th July 2007, 09:18 AM
Try "yum update" to update the whole system before installing KDE.

markness
27th July 2007, 05:56 PM
---> Downloading header for lm_sensors to pack into transaction set.
lm_sensors-2.10.1-1.fc6.i 100% |=========================| 26 kB 00:00
---> Package lm_sensors.i386 0:2.10.1-1.fc6 set to be updated
---> Downloading header for krb5-devel to pack into transaction set.
krb5-devel-1.5-21.1.i386. 100% |=========================| 41 kB 00:00
---> Package krb5-devel.i386 0:1.5-21.1 set to be updated
---> Downloading header for ruby-libs to pack into transaction set.
ruby-libs-1.8.5.52-1.fc6. 100% |=========================| 74 kB 00:00
---> Package ruby-libs.i386 0:1.8.5.52-1.fc6 set to be updated
--> Running transaction check
--> Processing Conflict: python-devel conflicts python < 2.4.4-1.fc6
--> Processing Dependency: libavahi-qt3.so.1 for package: kdnssd-avahi
--> Processing Dependency: e2fsprogs-devel for package: krb5-devel
--> Processing Dependency: libgpg-error-devel for package: libgcrypt-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for avahi-qt3 to pack into transaction set.
avahi-qt3-0.6.16-4.fc6.i3 100% |=========================| 9.4 kB 00:00
---> Package avahi-qt3.i386 0:0.6.16-4.fc6 set to be updated
---> Downloading header for libgpg-error-devel to pack into transaction set.
libgpg-error-devel-1.4-2. 100% |=========================| 4.1 kB 00:00
---> Package libgpg-error-devel.i386 0:1.4-2 set to be updated
---> Downloading header for e2fsprogs-devel to pack into transaction set.
e2fsprogs-devel-1.39-7.fc 100% |=========================| 23 kB 00:00
---> Package e2fsprogs-devel.i386 0:1.39-7.fc6 set to be updated
--> Running transaction check
--> Processing Conflict: python-devel conflicts python < 2.4.4-1.fc6
--> Finished Dependency Resolution
Error: python-devel conflicts with python < 2.4.4-1.fc6


Thats the last tidbit I could see in the terminal. Its still not working does anyone have any other ideas? This was after yum update said it had nothing to do.

Hlingler
27th July 2007, 06:19 PM
Hello:

Try as (root):
yum --exclude=python-devel update

V

markness
27th July 2007, 07:07 PM
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 1.2 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
No Packages marked for Update/Obsoletion


Thats what I got when I try it as root.

Hlingler
27th July 2007, 07:15 PM
Hello:

One more suggestion:
yum --exclude=*-devel groupinstall "KDE Desktop Environment"

V

markness
27th July 2007, 08:10 PM
# yum --exclude=*-devel groupinstall "KDE Desktop Environment"
Loading "installonlyn" plugin
Setting up Group Process
Setting up repositories
core 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 1.2 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Warning: Group KDE Desktop Environment does not exist.
No packages in any requested group available to install or update


Im baffled.

Hlingler
27th July 2007, 08:27 PM
Hello:

Oops! My bad - try:
yum --exclude=*-devel groupinstall "KDE (K Desktop Environment)"

V

EDIT: Or, to expand on unixguru88's suggestion:
yum --exclude=*-devel update
Oops again - you already tried that....

markness
27th July 2007, 10:00 PM
Dependency Installed: avahi-qt3.i386 0:0.6.16-4.fc6 fribidi.i386 0:0.10.7-5.1 gmp.i386 0:4.1.4-9.fc6 htdig.i386 3:3.2.0b6-8.fc6 kdelibs.i386 6:3.5.7-0.1.fc6 kdnssd-avahi.i386 0:0.1.3-0.1.20060713svn.fc6 lm_sensors.i386 0:2.10.1-1.fc6 xorg-x11-xdm.i386 1:1.0.5-5.fc6
Complete!
[root@cpe-74-76-131-49 ghost]# switchdesk kde
Red Hat Linux switchdesk 4.0
Copyright (C) 1999-2004 Red Hat, Inc
Redistributable under the terms of the GNU General Public License
Desktop now set up to run KDE.
[root@cpe-74-76-131-49 ghost]#


I tip my hat to you sir.

Hlingler
27th July 2007, 10:12 PM
No problem. Glad it worked out. Sometimes I do get it right.... :rolleyes:

V

markness
27th July 2007, 10:13 PM
Ok. I did the switchdesk, now how do I start kde? :P

Hlingler
27th July 2007, 10:20 PM
??? Switchdesk should be found somewhere on your menus; if not: "yum install switchdesk-gui"; or from command line: "switchdesk" should launch the GUI (if installed); once you open switchdesk-gui, just click on button for desired desktop, click apply, done. Should take effect immediately.

V

EDIT: Menu entry may be named "Desktop Switching Tool"

Hlingler
27th July 2007, 10:34 PM
OK, it doesn't take effect immediately. From GNOME desktop, you should find: System=>Preferences=>More Preferences=>Desktop Switching Tool. Select KDE and Apply. I get pop-up: "You must restart X Window System". To restart X: CTRL-ALT-Backspace, or simply logout/end session, log back in at login screen, should open to KDE. You can also set your preferences at the login screen: should be a menu somewhere to set default desktop environment.

EDIT: D*mmit! It seems that you must logout, and specifically select =>Session=>KDE at the login screen, then login.

V