PDA

View Full Version : Is it possible to turn off the KDE Daemon?



Jongi
27th July 2007, 02:17 AM
as the title says. And will things still automount without it?

Hlingler
27th July 2007, 02:31 AM
Hello:

What is this "KDE Daemon" that you are referring to? kwin? kdeinit? kdm?

Regards,
V

Jongi
27th July 2007, 12:36 PM
if you run kde, you will see it for instance when you pop a CD/DVD in. It's the pop up dialog box with options.

unixguru88
27th July 2007, 12:36 PM
You mean kded the service daemon. Open up kcontrol->KDE components->Services and uncheck the services you don't need.

Hlingler
27th July 2007, 06:06 PM
Hello:

You are referring to the KDE Media Notifications Daemon. The settings are located at: KMenu=>Control Center=>KDE Components=>Service Manager=>Start-up Services=>Media Notifier Daemon; click on it, then click "Stop", and/or uncheck the box so that it will not start when KDE starts.

Regards,
Vince

Jongi
27th July 2007, 06:06 PM
Yep KDED Media Manager looks like is the one I want gone.

EDIT: It's actually the Media Notifier Daemon

Jongi
28th July 2007, 10:39 PM
The problem now is that I manually have to mount DVDs and USB devices. How do I get around that?

Hlingler
28th July 2007, 11:04 PM
The problem now is that I manually have to mount DVDs and USB devices. How do I get around that?Turn the KDE Media Notifications Daemon back on!!!

Seriously, I don't know how you can have your cake and eat it too....


Regards,
V

Jongi
28th July 2007, 11:16 PM
Are you trying to tell me that there is no way to tell fc7 to just automatically mount the DVD without having a dialog box pop up? I refuse to believe that's the case.

Hlingler
28th July 2007, 11:29 PM
Hello:

If you have fstab setup correctly and autofs daemon running, disk should automount without notification. Relevant entry in my fstab:
/dev/hda /media/disk auto users,atime,auto,rw,dev,exec,suid 0 1Automount may require additional configuration. YMMV.

Regards,
V

EDIT: Sorry, I misunderstood your question in Post #7. Of course, a disk should automount without KDE Notifications Daemon, if it did so correctly before you turned KDE Notify Daemon off. A better response would have been: did you try to insert a disk, and see?

Jongi
5th January 2008, 10:23 AM
interestingly, i find that even with the daemon running, you have to choose a positive action when it pop up for the media to be mounted. It's not a case of KDE first mounting the media, then presenting you with a choice of actions. Something I find rather odd.

Hlingler
5th January 2008, 03:50 PM
When that window pops up after you load a disk, can't you choose one of the actions to be the default? I mean, can't you select "Load" or "Play" or "Burn CD" and then check the "Make this the default Action" box? I never see the pop-up, so I can't remember - I must have turned that Notifier Daemon off....

Or, It may be that your fstab or automount/autofs settings are not correct, because autofs (if it's running and configured correctly) should mount the disk automatically on system start or cd/dvd load, if that's what you set it up to do, regardless of whether or not the Notifier Daemon is turned on or off. I do recall having a difficult time getting autofs set up....

Regards,
V

Jongi
5th January 2008, 04:11 PM
At first I thought it to be a KDE issue. But I am having problems with automount on a system running xfce so I am wondering whether it is a wider issue (http://fedoraforum.org/forum/editpost.php?do=editpost&p=936958).

Hlingler
5th January 2008, 04:53 PM
Yes, it sounds like that is the case. There are actually two programs/packages involved: autorun and autofs. You may need to research these a little - as I said, I recall having difficulty with autofs, setting up the /etc/auto.master, /etc/auto.cdrom, /etc/auto.misc and other files, etc. I still have several hacked-up "experimental" copies of each file sitting in my /etc/ folder....

Regards,
V