PDA

View Full Version : Installing Win XP on xen fedora 7



ezeuba
26th July 2007, 10:50 AM
Hello,
I am a linux devotee and have been following some versions of fedora for some time now, since fc3 actually. My problem is with fedora7. I have been trying to install windows xp using xen (qemu actually), but always having the same problem: the file asms cannot be found on win xp sp2 cd. Can anyone help me out with this issue? I really need to get this wokring hence I have tried a couple of remedies like creating an iso of winxp sp2 and installing from there. This did not work. I initially tried from my dvd drive but still no show. I use dualboot winxp and fedora 7, but if I can get this virtualisation to work then I can have fedora as my only OS, and this will also save me some HDD space as I won't be needing partitioning again.
Thanks for any and all prompt suggestions.
Cheers

rcuetara
3rd August 2007, 08:24 PM
The problem is not with fedora. I had the same problem while installing Windows Xp on a virtual machine (kvm) in fedora 7, I got an error that setup could not continue because it couldn't read file d:\i386\asms due to some incorrect parameter. A web search came up with too many instances of the problem, with all kinds of systems, virtual and hardware.

Reading through a few dozen I found a variety of solutions, most dealing with replacing or modifying hardware, not a big help with a VM. There seems to be a general agreement that the problem is some sort of communication mixup with the cd or dvd drive. Sure enough, opening a console window on the installation and trying to read d:'s directory gave a message that the drive was not ready. XP finds the device but fails to recognize it is ready. There is also general agreement that a solution that always works is to bypass either of the two: Xp or the CD/DVD drive, for example by using a windows 98/me floppy to copy the \i386 directory to the hard disk and run setup from there. Again not a big help with a VM.

Fortunately for the both of us, after the VM installation fails, it will boot a sufficiently functional copy of windows, with the disk image already formatted, all that is needed is to copy the \i386 directory to the image and run setup from there.

Here is what you need to do:

1. Shut down the virtual machine. Try to exit XP gracefully or you will have to force the next step.

2. Mount the image.
I used lomount, my image is called xp6 in my home directory, as root I did:

lomount -t ntfs -diskimage ~cuetara/xp6 -partition 1 /mnt

3. Copy the i386 directory.
My xp cd was mounted on /media/VRMPVOL_EN, so I did:

cp -r /media/VRMPVOL_EN/i386 /mnt

4. When done unmount the image.

5. Restart the virtual machine

6. When you get the asms error type shift-F10 to open a console.

7. type c:\i386\winnt32.exe to start a fresh installation process

8. When prompted, select a new install.

9. Follow the windows installation procedure as usual.

I believe this should work with appropriate modifications in other distribution/VM setups.

-Ramon De La Cuetara

rsmithh
13th August 2007, 08:20 PM
The issue (for me at least) is that virt-manager failed to add the CD-ROM as a device to the VM configuration. Thus when Winxp tries to find the CD-ROM to copy its files, it can't.

You need to edit the /etc/libvirt/qemu/xxxxxxxxxxx.xml and add the following lines ...

<disk type='block' device='cdrom'>
<source dev='/dev/scd0'/>
<target dev='hdc'/>
</disk>

in the devices block

The restart libvirt with
/etc/init.d/libvirtd restart
Restart virt-manager, run the VM and you're all set.

If when you restart virt-manager the VM has disappeared it means you messed up the edit in some way.

stevea
17th August 2007, 11:21 PM
The issue (for me at least) is that virt-manager failed to add the CD-ROM as a device to the VM configuration. Thus when Winxp tries to find the CD-ROM to copy its ...

I had the same problem wit hWin2k installation. The initial install was perfect and then after reboot it should reconfigure add the SPs and request the keys - but it can't frind the CDROM.

I solved this by manually running the very long "qemu-kvm -M 512 -p PC ........ " adding "-cdrom /dev/scd0" and that worked.


Rsmithh has a much better solution - much thanks.

So WHY can't the virt-manager config allow you to add a CDROM ? You can add a hard disk or another enet but no cdrom ! That seems stupid.

On the virt-manager homepage all the folks are bust trying to netboot the guest using Xen on RHEL. Ithink that is very weird, but .... almost no talk of qemu.

Has anyone tried the other virtualization managers ?

jlumpkins
24th August 2007, 02:08 AM
I would just like to add my thanks to rsmithh for the help in getting my XPPro installed in Fedora7.

I had to make a minor modification given that I was installing from an ISO image instead of a physical device. But, aside from that the directions Rsmithh gave were concise, and effective.

Here's what I did to use the ISO image:
<disk type='file' device='cdrom'>
<source file='/home/lumpkins/WXPVOL_EN.iso'/>
<target dev='hdc'/>
</disk>

Thanks again,

Jerry Lumpkins

cmarenbach
19th September 2007, 06:18 AM
My thanks as well. posts like this save so much time.