PDA

View Full Version : waiting for X server to shut down FreeFontPath: FPE "unix/:7100"



pailott
26th July 2007, 05:14 AM
Ok after several days trying to get my DNS server to be seen by the outside world, I tried a seris of iptable commands I found on a web site. (After trying several other suggested iptable commnds) and it finally worked. I do not see why it worked and why the other attempts failed.

The I started to get my httpd server to work for aboutr 3 more days. Yesterday I hit the install updates button in the updates message. While I did other stuff it ran, but seemed to end with an error. I thought not much of it.
Today I restarted my computer after trying something for the httpd (I ha yesterday also put some iptable commands to allow httpd,,, but it did not work).

Now for the frustration of the day !@!!!!! :mad: :mad:
My X does not start now,,,, but gives the following message

waiting for X server to shut down FreeFontPath: FPE "unix/:7100" refcount is 2, should be 1; fixing

I have searched the web, and seen several refs to this (and variations on it) over the years, but with no satifactory answers. I've tried updating nvida driver, no good. I tried commenting out the FontPath unix/:7100 in xorg.conf, no change.

I've tried several things... I'm stuck (again).

On the old problems....... I think the security features in F7 have really messed things up,
and are not easy to control or setup !!! The firewall GUI does not help much.

Anyway,,,, WHAT ABOUT the FreeFontPath problem. I cannot get X to run anymore.

Pailott

Seve
26th July 2007, 05:21 PM
Hello:
From the info you posted on the thread Bob closed.

Boot into run-level 3
Hit the enter key, when grub appears, then type e and cursor to the kernel boot line and add the the number 3
your kernel boot line will look like this
....... 3 rhgb quiet
once there, log in as root and

yum install cairo

The cairo rpm provides libcairo.so.2

Seve

pailott
26th July 2007, 06:51 PM
Thanks for the reply. What is libcario, and why did this problem suddenly appear ?
(Did I screw it up somehow ?? Or was it an update thing ?)

I'll try your suggestion ASAP.

Peter

pailott
26th July 2007, 06:53 PM
Sorry again,

what is the 3 rhgb line doing ? Can I yum install cairo before doing the 3 rhgb.
I am at work and can run yum remotely, but not reboot and hit enter and so on.

Peter

pailott
26th July 2007, 06:57 PM
I ran yum install cairo remotely, and it seemed to install ok.
I tried startx remotely again (not expecting to be able to actually get a gnome window in my Exceed
virtual screen, but just to se what errors came up), and the message about a missing libcairo
is gone. I will have to wait until I get home to see if I can start X normally at home.

Thanks for the info.

Seve
26th July 2007, 08:48 PM
Hello:

What is libcario, and why did this problem suddenly appear ?
from a terminal type
yum info cairo
to find out what it is.
Check your /var/log/yum.log to see if cairo was somehow previously erased ? Other than that I have no idea why this problem suddenly appeared.


what is the 3 rhgb line doing
In simple terms, it is starting your F7 installation in in Multi-user text mode [not starting X]
You can google for man page init, or from a terminal type man init for more information on run-levels.

Seve

pailott
26th July 2007, 09:08 PM
I thougt that's what the 3 rhgb was all about.
Thanks. I had already changed my inittab to start in level 3, so I was not having the restart x cycling problem. Thanks for the yum info idea.

This is the first new Linux system I have setup in several years (my old server is rh7, and the hardware is at least 7 years old,,, and still running !!). But I am rusty and out of it for alot of the new stuff. I'm an old time newbie at this point. (My 1st unix experience was on a Vax ,,,, that'll tell you how old I am :)

Thanks everyone for helping an oldtimer !! I'll try to start X when I get home, and see if this Cario install fixed the problem.

pailott
27th July 2007, 02:09 AM
OK, I'm home and I tried to startx and guess what ????
It worked. So the missing library was the problem.
Why it was missing I don't know. But I suspect it had something to do with the auto update
function set up in fedora. I have answered yes ever since I installed f7, inclucding day before yesterday, but the last time I think it ended with an error. It must have been updating the Cairo library or something and ended before completing. I think I'll be more careful in the future allowing the update service to do whatever it wants. I wonder what else it screwed up. Guess I'll find out.

Thanks Seve for the help !!!

pailott
27th July 2007, 02:25 AM
So I asked what esle got screwed up by the auto update ?
Looks like firefox and thunderbird got erased or something.
I had to yum install them both again !!!

Warning !!! Watch out for the auto update feeature in F7 !!

Peter

Seve
27th July 2007, 02:31 AM
Hello Peter:
You might find it better to use yumex
yum - y install yumex
you can also turn off the auto-update notice
from a terminal
system-config-services
and stop and disable yum-updatesd

For more easy reading :) Yum Extender (http://www.yum-extender.org/cms/modules/news/)

Seve

lazlow
28th July 2007, 04:47 AM
Seve

Did you get your PM mailbox cleaned out so you can get more PMs? Send me another PM when you do. So I can reply to your last one.

To OP: Sorry to pollute your thread.

Thanks
Lazlow