PDA

View Full Version : Chinese input problem



djcissp007
26th July 2007, 02:45 AM
Hey, buddies,

I have a Dell D610 laptop, and FC7 installed on it.

I found I can't enable Chinese input on the machine. Here are some information:

packages I've installed on the machine:
$rpm -qa |grep scim
scim-chewing-0.3.1-9.fc7
scim-tables-0.5.7-3.fc7
scim-bridge-0.4.10-1.fc7
scim-m17n-0.2.1-1.fc7
scim-1.4.5-18.fc7
scim-bridge-gtk-0.4.10-1.fc7
scim-libs-1.4.5-18.fc7
scim-tables-chinese-0.5.7-3.fc7
scim-pinyin-0.5.91-16.fc7
scim-qtimm-0.9.4-6.fc7

$rpm -qa |grep chinese
fonts-chinese-3.03-4.fc7
m17n-db-chinese-1.3.4-9.fc7
scim-tables-chinese-0.5.7-3.fc7

I also run: scim-setup and found smart-pinyin is enabled, and "CTRL+Space" is the trigger.

But when I press "CTRL+space" on the laptop, nothing happens.

Instead, I have FC6 installed on a desktop, installed with the same packages, and with the same configuration. Everything works fine at that desktop.

Is this a problem related to laptop keyboard layout? Or what else can I do?

Any hints are appreciated.

djcissp007
26th July 2007, 03:48 AM
Hey, buddies,

I have a Dell D610 laptop, and FC7 installed on it.

I found I can't enable Chinese input on the machine. Here are some information:

packages I've installed on the machine:
$rpm -qa |grep scim
scim-chewing-0.3.1-9.fc7
scim-tables-0.5.7-3.fc7
scim-bridge-0.4.10-1.fc7
scim-m17n-0.2.1-1.fc7
scim-1.4.5-18.fc7
scim-bridge-gtk-0.4.10-1.fc7
scim-libs-1.4.5-18.fc7
scim-tables-chinese-0.5.7-3.fc7
scim-pinyin-0.5.91-16.fc7
scim-qtimm-0.9.4-6.fc7

$rpm -qa |grep chinese
fonts-chinese-3.03-4.fc7
m17n-db-chinese-1.3.4-9.fc7
scim-tables-chinese-0.5.7-3.fc7

I also run: scim-setup and found smart-pinyin is enabled, and "CTRL+Space" is the trigger.

But when I press "CTRL+space" on the laptop, nothing happens.

Instead, I have FC6 installed on a desktop, installed with the same packages, and with the same configuration. Everything works fine at that desktop.

Is this a problem related to laptop keyboard layout? Or what else can I do?

Any hints are appreciated.
two other info:

It didn't work even I choose the session language to Chinese,

It didn't work either if I choose the preferred input method to the option 4 (scim) by System-Preferences->Personal->input method

djcissp007
27th July 2007, 01:47 AM
After several test, now I know how to input Chinese under my FC7, it is still strange though.

I found when I use root to logon to the system, I can trigger the input keyboard by "CTRL+Space". But when I use a non-privileged account to logon, I can't invoke it.

But I can input Chinese by left-click the keyboard icon which is at the right up bottom. Then I can manually select the input method. I don't know why.

Anyway, I don't have anything changed on my laptop. I think maybe it is a bug on FC7.

Please share your experience.

Stian1979
1st August 2007, 11:02 AM
I have the same problem, I even installed the scim input pad and there I can type bo, po, fo, mo, on the buttons, but I have no input into browsers, wordprosesors or mesengers.

Wayne
1st August 2007, 11:29 AM
I had a similar problem when moving from FC6 to F7, I could no longer input Japanese, even though I had all the correct packages installed and had the correct hidden files in my /home. I solved it by opening:

System > Preferences > Personal > Input Method

and changing it from 'Use system wide configuration [SCIM]' to 'Use custom input method' set to 'scim' I don't know why, but after logging out and back in it started to work as normal.

Wayne

Stian1979
1st August 2007, 04:25 PM
I did the same and it work well now, I just can't use phonetical chinese in openoffice and I can't type chinese at all in amsn.

Atleast I have one problem less, but two new ones