PDA

View Full Version : changing from i386 to i686



plex0r
25th July 2007, 11:22 PM
i installed fedora 7 i386 and i tried to install madwifi for my atheros card, but it said that i have the wrong kernel and i need to have i686 install well i looked through the site and only say i686 as an live disc...any solutions?

lazlow
25th July 2007, 11:37 PM
Plex

In the description i386 fedora they mean 32bit Fedora for Pentiums(or equivalent) and above. The second reference is probably 586 vs 686. There has been a recent rash of 586 kernels getting installed instead of 686 ones (it has popped up before). So in a terminal type:

uname -a

And post back the results and we will work from there.

plex0r
25th July 2007, 11:46 PM
[plex0r@plex0r-pc ~]$ uname -a
Linux plex0r-pc 2.6.22.1-27.fc7 #1 SMP Tue Jul 17 17:13:26 EDT 2007 i686 athlon i386 GNU/Linux

lazlow
25th July 2007, 11:52 PM
Ok, have the 686 kernel installed.

How are you installing madwifif? If you are using livna's kmods there is a different version for every kernel version. So when you update the kernel you have to update madwifi at the same time. However it sometimes takes a few days for the kmod people to get the madwifi module made up.

plex0r
25th July 2007, 11:55 PM
this is what i did: http://fedoramobile.org/fc-wireless/madwifi-yum-livna/


and this is the error:
[plex0r@plex0r-pc ~]$ su -c "yum install madwifi kmod-madwifi"
Password:
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package madwifi.i386 0:0.9.3.1-1.lvn7 set to be updated
---> Package kmod-madwifi.i686 0:0.9.3.1-1.2.6.21_1.3228.fc7 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.21-1.3228.fc7 for package: kmod-madwifi
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.21-1.3228.fc7 is needed by package kmod-madwifi
[plex0r@plex0r-pc ~]$

JN4OldSchool
26th July 2007, 12:00 AM
this is what i did: http://fedoramobile.org/fc-wireless/madwifi-yum-livna/


and this is the error:
[plex0r@plex0r-pc ~]$ su -c "yum install madwifi kmod-madwifi"
Password:
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package madwifi.i386 0:0.9.3.1-1.lvn7 set to be updated
---> Package kmod-madwifi.i686 0:0.9.3.1-1.2.6.21_1.3228.fc7 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.21-1.3228.fc7 for package: kmod-madwifi
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.21-1.3228.fc7 is needed by package kmod-madwifi
[plex0r@plex0r-pc ~]$

There is your problem. Your madwifi driver doesnt match the kernel.

lazlow
26th July 2007, 12:01 AM
The kernel you are running is newer than the latest madwifi version.

You can still run the older kernel until the new madwifi kmod comes out. When you reboot a screen will pop up with a countdown timer. You should be able to hit any key to get a list of options. Select the next newest kernel in the list (hopefully .3228) and boot to it. Then install madwifi just as in post#5. Every time you boot you will have to do this(just the selecting kernel part) until the madwiffi update shows up.

plex0r
26th July 2007, 12:02 AM
thanks guys

plex0r
26th July 2007, 12:20 AM
well the other kernel isnt .3228 how can i change to that?

lazlow
26th July 2007, 12:39 AM
Ok, personally I find that a little trickier. I would install a graphical package manager. I like smart-gui.

yum install smart-gui

It will show up under Applications->System Tools-> Smart package manager. Search for kernel in the search field. There are going to be a lot of different kernels. Look for the green boxes that indicate what you have installed. Find the one that looks just like the one you have installed except that it has .3228 in it. Be careful there are both 586 and 686 versions available(you want 686). When you find the one you want and click on it. It will bring up a popup for you to check over. After you are done with that you will have to hit the second Icon from the left (action icon) and another popup will be shown for your approval. Then it should install. Reboot as before.