PDA

View Full Version : KDE crash under FC6



ms1234
25th July 2007, 06:01 PM
Was watching a movie with mplayer when the screen froze and kde crashed. It tried to restart 3 times I guess but after a while all I had was a black screen. Ctrl-Alt-Backspace had no effect.

I took out the the battery from the laptop and started the computer again. Boot went fine until X started in which case it restarted 3 times I guess and then I had a black screen. A new hardboot with the battery out and in and in with runlevel 3. startx started KDE fine after login in textmode but crashed horribly after around 4 minutes. Tried the same 3 times with the same result. After finally getting things somewhat stable (without doing anything really?) rebooted the laptop and KDE started fine under runlevel 5.

Is there any kind of crash log generated? The text I saw in runlevel 3 went by too fast. In /var/log/gdm there are some X logs with a lockup as the basic error message and some references to fonts.

Quite confusing as the laptop has been up and running for closer to 70 days without a hitch.

Hlingler
25th July 2007, 06:09 PM
Hello:

Other places to look for relevant info: /var/log/Xorg.0.log, /var/log/messages, /var/log/dmesg, ~/.xsession-errors. Posting (or attaching if they're long) the file(s) would give us more info to diagnose.

regards,
Vince

pete_1967
25th July 2007, 06:18 PM
If you have save session option set in KDE, just delete the session file and try restarting the KDE. Often that sorts out the problem like yours.

Sorry, haven't used KDE for long time now so you need to find the location of saved session file yourself.

ms1234
25th July 2007, 06:32 PM
.xsession-errors attached if there could be any help

Hlingler
25th July 2007, 07:01 PM
Hello:

It appears from your ~/.xsession-errors that you are in fact saving your session when logging out. Check: KMenu=>Control Center=>KDE Components=>Session Manager=>On Login=>check "Start with empty session". Try that first.

I see several items of concern in your ~/.xsession-errors file: "Could not load library! Trying exec...." may be your media player trying to load it's library; if so, not a major problem;
"pad.cpp:203 can't access shared memory area. SHMConfig disabled?
pad.cpp:114 cannot access driver, please install and configure it properly!"
looks important, but I'm not sure what it refers to. Needs further investigation.

It's a long log: may take a little while to sort out. I see:
"xset: bad font path element (#77), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax"
on each session start - this does not appear to be a major problem. I also see messages like: "X Error: BadMatch (invalid parameter attributes) 8
Major opcode: 156
Minor opcode: 6
Resource id: 0x4d"
constantly - this does not seem to be a major problem.

Hope that helps.
Vince

ms1234
25th July 2007, 08:57 PM
Thanks.

Changed to start with an empty session. The SHMConfig is the Thinkpad configuration utility which apparently crashes (atleast when you quit it). Don't know about the fonts or the BadMatch (whatever that is).

Hlingler
25th July 2007, 09:18 PM
Hello:

As I mentioned, the "xset: bad font path element" and "X Error: BadMatch" errors do not seem to be major problems.

If your crashes stop after you start KDE with an empty session, then your problem is solved. If the crashes continue, then we need to investigate further.

Regards,
Vince

ms1234
26th July 2007, 07:01 AM
Now it seems stable so thanks for the help :)