View Full Version : Fedora 7 won't boot

25th July 2007, 05:55 PM
i was trying unsuccessfully to get the nvidia driver to work and after a reboot fedora won't load...i get a black screen and the monitor turns itself off and the only thing i can do is reset my computer(manually from the reset button on the case not with ctrl alt del or sth like that...) i tried reinstalling fedora but couldn't do it..it asked me where are the packages i wanted to install (i have fedora on dvd) so i chose the cdrom but it said it didn't find anything.. so reinstalling fedora didn't work either..is there anything i could do?(i'd love to find a solution that doesn't envolve reinstalling fedora..but if i must..i'll do..!

26th July 2007, 07:53 PM
anyone?i still can't find a solution :(

26th July 2007, 07:58 PM
can you get to text based terminal by typing Ctrl-Alt-F2
If so, you should be able to run system-config-display, or manually edit your xorg to not use the nvidia driver.
If you put a 'S' option on the grub boot parameters command line you will get to text terminal, and be given a shell. You have to hit an 'e' on the boot menu to edit this command line. It will boot the computer into single user mode for maintenance

5th August 2007, 11:01 AM
no unfortunately i can't get into the text based terminal :(
i tried what you told me on the grub but couldn't do it... maybe i didn't do it right i don't know.... :(
any other ideas please?

6th August 2007, 09:48 PM
You could boot into rescue mode from the install CD, then change the default run level to be a 2 or a 3, something that doesn't automatically start X. Once you change it, reboot from the hard disk into this runlevel, and try the system-config-display.

7th August 2007, 01:03 AM
i tried reinstalling fedora again...this time it started the installation normally but after i installed i had problems with the x server and now i'm trying to reinstall again cuz it doesn't let me do anything with it...why do i have so many probs :S:S:S