PDA

View Full Version : Nvidia 3D - Nvidia instructions failed. Please help!



wutbox
24th July 2007, 10:55 PM
I am trying to install the NVIDIA 3d drivers. I am at run level 3 and everything. NVIDIA couldn't find a thing to match my kernel. I am running F7. So it wanted to compile its own. I said "ok." It told me that it didn't find a kernel tree or something. How do I tell it where to look for one.... do I have one? Anyway, these drivers have been a real hassle. Any help would be awesome. Thanks

bob
24th July 2007, 11:05 PM
If you've messed up your title, ask a Community Manager or Administrator to fix it; don't double-post. And, if I were you, I'd follow this how-to: http://www.diffingo.com/blog/content/blogcategory/34/33/ which is written by Firewing1, who maintains the Kmod(s)-Nvidia for Fedora. Lots easier than trying to use the Nvidia 3D drivers from their site.

wutbox
24th July 2007, 11:24 PM
Yeah, sorry about the double post. My browser didn't load so I clicked again after I changed the title.

stevea
25th July 2007, 01:34 AM
do "yum install kernel-devel" (as root) and try the nvidia again.

bseltzer
25th July 2007, 04:48 AM
Actually, I think what's needed is both kernel-devel and kernel-headers



sudo su -
yum install kernel-devel kernel-headers

Then run the installer script. It should work just fine.

OR... Do as Bob suggested and use the nvidia-kmods per firewing's excellent instructions. Either method will work. As to which is better/easier... more a matter of personal preference and style.

Once you've got the nvidia module installed, search the forums for help setting up your /etc/X11/xorg.conf to properly use it. You'll end up with something like...


# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
FontPath "unix/:7100"
EndSection

Section "Module"
Load "fbdevhw"
Load "record"
Load "freetype"
Load "type1"
Load "glx"
Load "dbe"
Load "extmod"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell E171FPb"
DisplaySize 340 270
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "nVidia Corporation NV17 [GeForce4 MX 420]"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "AllowGLXWithComposite" "True"
Option "RenderAccel" "True"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
Option "MetaModes" "1280x1024_75 1152x864 1024x768 800x600 640x480"
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024_75" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

#Section "DRI"
# Group 0
# Mode 0666
#EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Regards,
Bert

wutbox
26th July 2007, 07:17 PM
Man, I have tried both of those ways. I am pretty sure I am doing it like it says.

I have all kinds of kernel stuff installed: headers, devel, source. Still the drivers from the Nvidia website say they can't find a kernel to compile against.

Then with the way from Firewing1. I had my xorg.conf set to "nv" already and it wasn't working. Is there any further config for that? I tried nouveau also and it wouldn't even start X.

Anyway, let me know if there is something I am not doing.

Thanks

bseltzer
26th July 2007, 09:47 PM
Anyway, let me know if there is something I am not doing.

Thanks

No offense, but since I don't know what you are doing, I have absolutely no way of guessing what you aren't.

So... let's try a more systematic approach. First, please post the output of the following commands;


rpm -qa|grep kernel


rpm -qa|grep nvidia


ls -l /lib/modules/`uname -r`


cat /etc/X11/xorg.conf

Next, could you tell me exactly what you mean by "doesn't work"? What commands are you running and what error messages are you getting? Please be as specific as you can. The help you'll get can only be as good as the information you provide about the problem.

Regards,
Bert

wutbox
27th July 2007, 06:33 AM
I know, sorry for the vagueness. I am just really new at all of this so I appreciate your help in my stumbling around. Here are the outputs of those commands:

rpm -qa|grep kernel

kernel-2.6.21-1.3228.fc7
kernel-devel-2.6.22.1-27.fc7
kernel-xen-2.6.20-2925.9.fc7
kernel-devel-2.6.21-1.3228.fc7
kernel-2.6.22.1-27.fc7
kernel-xen-2.6.20-2925.11.fc7
kernel-headers-2.6.22.1-27.fc7

rpm -qa|grep nvidia

kmod-nvidia-100.14.11-1.2.6.21_1.3228.fc7
kmod-nvidia-100.14.11-1.2.6.22.1_27.fc7
xorg-x11-drv-nvidia-100.14.11-1.lvn7

ls -l /lib/modules/`uname -r`

total 1388
lrwxrwxrwx 1 root root 52 2007-07-14 10:26 build -> ../../../usr/src/kernels/2.6.20-2925.11.fc7-xen-i686
drwxr-xr-x 2 root root 4096 2007-06-11 14:40 extra
drwxr-xr-x 9 root root 4096 2007-07-14 10:26 kernel
-rw-r--r-- 1 root root 293026 2007-07-14 10:26 modules.alias
-rw-r--r-- 1 root root 69 2007-07-14 10:26 modules.ccwmap
-rw-r--r-- 1 root root 287001 2007-07-14 10:26 modules.dep
-rw-r--r-- 1 root root 147 2007-07-14 10:26 modules.ieee1394map
-rw-r--r-- 1 root root 375 2007-07-14 10:26 modules.inputmap
-rw-r--r-- 1 root root 13633 2007-07-14 10:26 modules.isapnpmap
-rw-r--r-- 1 root root 74 2007-07-14 10:26 modules.ofmap
-rw-r--r-- 1 root root 237336 2007-07-14 10:26 modules.pcimap
-rw-r--r-- 1 root root 967 2007-07-14 10:26 modules.seriomap
-rw-r--r-- 1 root root 118026 2007-07-14 10:26 modules.symbols
-rw-r--r-- 1 root root 331781 2007-07-14 10:26 modules.usbmap
lrwxrwxrwx 1 root root 5 2007-07-14 10:26 source -> build
drwxr-xr-x 2 root root 4096 2007-06-11 14:40 updates
drwxr-xr-x 2 root root 4096 2007-06-11 14:40 weak-updates

cat /etc/X11/xorg.conf


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Sun 21-inch N3"
HorizSync 30.0 - 96.0
VertRefresh 48.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200" "1600x1024" "1440x900" "1400x1050" "1360x768" "1280x1024" "1280x960" "1280x800" "1280x720" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

What I mean by "it still doesn't work" is that when Linux is booting it has a "Failed" and a couple "Warnings" when it says it is loading Nvidia drivers. It says that it can't find one and that it won't load one until one is found.

I don't know if I was clear that I can see the monitor. I am using it right now, but I want the OpenGL and 3D stuff to work.

Thanks again for your time helping. I think that is the best thing about Linux, all the community support.

leigh123linux
27th July 2007, 06:36 AM
try


su -
yum erase kernel-xen-2.6.20-2925.9.fc7 kernel-xen-2.6.20-2925.11.fc7
reboot

Then



su -
yum update
nvidia-config-display enable
service nvidia restart
gdm-restart

wutbox
27th July 2007, 07:26 AM
ok, awesome! I did the first step :

su -
yum erase kernel-xen-2.6.20-2925.9.fc7 kernel-xen-2.6.20-2925.11.fc7
reboot

I think it is working. "NVIDIA" flashed for a second and it seems to work. Do I have to do the rest of what you said or am I good to go?

Thanks

leigh123linux
27th July 2007, 07:44 AM
ok, awesome! I did the first step :

su -
yum erase kernel-xen-2.6.20-2925.9.fc7 kernel-xen-2.6.20-2925.11.fc7
reboot

I think it is working. "NVIDIA" flashed for a second and it seems to work. Do I have to do the rest of what you said or am I good to go?

Thanks

you can leave it as it is ( did you boot the 3228 kernel ? )

bseltzer
27th July 2007, 10:31 PM
Leigh,

Thanks for picking this up!! Been tied up at work, but glad to see the OP's issue apparently resolved.

Regards,
Bert

wutbox
1st August 2007, 04:57 PM
ok, guys, I am back, I really appreciate you fixing the most frustrating problem I've had.

It stopped working. I tried to change the resolution. After I restarted it didn't work. When I type glx info | grep render it says "direct rendering: no." Is that a problem? Anyway, I'm not sure why it quit working. Any help would be awesome. Thanks.

wutbox
10th August 2007, 07:12 PM
I was wondering if you guys wouldn't mind helping me again. I had to reinstall Fedora. I had the white screen thing. I installed the Nvidia drivers from the Nvidia site. When I boot up the Nvidia screen flashes. I don't have a white screen when I start Beryl, but it won't let me select Beryl as the window manager. It always goes straight back to Gnome. Any help? I would really appreciate it. Thanks

Dies
11th August 2007, 12:11 AM
You may want to post your xorg.conf file.

But make sure you have the line

Option "AddARGBGLXVisuals" "1"

in there somewhere, either in the "Device" or "Screen" section.

leigh123linux
11th August 2007, 12:17 AM
You may want to post your xorg.conf file.

But make sure you have the line

Option "AddARGBGLXVisuals" "1"

in there somewhere, either in the "Device" or "Screen" section.

It goes in the "Device" section

wutbox
11th August 2007, 06:26 AM
Ok, here is my xorg.conf:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Jun 13 18:39:30 PDT 2007

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Sun 21-inch N3"
HorizSync 30.0 - 96.0
VertRefresh 48.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200" "1440x900" "1400x1050" "1360x768" "1280x1024" "1280x960" "1280x800" "1280x768" "1280x720" "1152x864" "1152x768" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400" "640x350"
EndSubSection
EndSection

thanks.. I wish I knew more what to look for on this. I am still learning. I appreciate the help.

wutbox
11th August 2007, 08:30 AM
Man, still nothing. What is the problem? I added that line to the device section.