PDA

View Full Version : how to java runtime firefox fedora 7 x86_64 ??



Arkan
24th July 2007, 03:33 PM
hello all

i have tried about three guides on the net on how to fix the java-plugin for firefox but non worked with me :( ... maybe cuz am too n00b :(.
i have now like 4 jre :( .. all are not working ... :(
can anyone help me?? :confused:
thanx

leigh123linux
24th July 2007, 04:27 PM
hello all

i have tried about three guides on the net on how to fix the java-plugin for firefox but non worked with me :( ... maybe cuz am too n00b :(.
i have now like 4 jre :( .. all are not working ... :(
can anyone help me?? :confused:
thanx

You only need one jre so remove the three oldest versions , then follow this guide


#rpm -q jre
jre-1.6.0_00-fcs
jre-1.6.0_01-fcs
jre-1.6.0_02-fcs
jre-1.6.0_03-fcs

su
rpm -e jre-1.6.0_00-fcs jre-1.6.0_01-fcs jre-1.6.0_02-fcs






http://forums.fedoraforum.org/showthread.php?t=158745

Arkan
24th July 2007, 04:59 PM
hi leigh123 :)

ok i removed all .. and installed the newst one (32-biy


[root@Arkan Desktop]# rpm -q jre
jre-1.6.0_02-fcs

i checked the thread .. i did the part related to java but i think my firefox is 64-bit version thats y its not working maybe?? .. :confused:

leigh123linux
24th July 2007, 05:03 PM
hi leigh123 :)

ok i removed all .. and installed the newst one (32-biy


[root@Arkan Desktop]# rpm -q jre
jre-1.6.0_02-fcs

i checked the thread .. i did the part related to java but i think my firefox is 64-bit version thats y its not working maybe?? .. :confused:


32 bit java needs firefox 32 bit to work

Arkan
24th July 2007, 05:10 PM
32 bit java needs firefox 32 bit to work

ok .. so either i use the firefox-32 and install the java-32 version .... or i install the java-64 on my firefox-64 .. but ofcourse java-64 doesnt work properly like every 64-bit thing :( ...
ok .. so now am downloading the firefox 32-bit ...

Arkan
24th July 2007, 05:14 PM
ofcourse ... u saved my day ....... again leigh :)
it worked like a charm :rolleyes:

thanx again :)

lphilosophy
1st August 2007, 07:27 AM
Arkan, do you have all your plugins with 32 bit firefox? When I did # yum install firefox.i386 then all my other multimedia plugins went away :-/ So I went back to 64 bit firefox

.. also.. your jre rpm's are from Sun? I have the .bin , I guess I don't need it?

Arkan
1st August 2007, 09:36 AM
Arkan, do you have all your plugins with 32 bit firefox? When I did # yum install firefox.i386 then all my other multimedia plugins went away :-/ So I went back to 64 bit firefox

.. also.. your jre rpm's are from Sun? I have the .bin , I guess I don't need it?

yeah ... i have the flash and java plug-ins in my (firefox-32bit) both are working well in firefox-32bit but the java runtime is not working in firefox-64bit .. only in my 32-bit firefox .. can u go to your browser and type in the address bar "about:_plugins" (remove the _) and hit enter ... post the result!!

Arkan
1st August 2007, 09:37 AM
_double post ____

lphilosophy
1st August 2007, 09:55 AM
Thanks for replying :) I've been trying to fix this for a while.

can u go to your browser and type in the address bar "about:_plugins" (remove the _) and hit enter ... post the result!!
I removed the 64 bit firefox and added 32 bit like this:
#yum remove firefox firefox.i386
#yum install firefox.i386 flash-plugin (I have the adobe repo)

now when I open about:plugins in firefox I get only 2 entries
Shockwave Flash (swf)
FutureSplash Player (spl)

EDIT: now I see why you added the space before! :P

about:plugins

I guess I don't need the other multimedia plugins (for example $yum search plugin shows a bunch for _64 but none for i386)

==> How did you install the jre? Where did you get the rpm? From Sun?

I installed using the .bin from Sun bjre-6u2-linux-i586.bin but I can't find any jre/plugin directory in /usr/lib. I must have something wrong. I was trying to follow www.fedorafaq.org but it seems like this stuff changed since FC6.

Arkan
1st August 2007, 10:02 AM
Thanks for replying :) I've been trying to fix this for a while.

I removed the 64 bit firefox and added 32 bit like this:
#yum remove firefox firefox.i386
#yum install firefox.i386 flash-plugin (I have the adobe repo)

now when I open about:plugins in firefox I get only 2 entries
Shockwave Flash (swf)
FutureSplash Player (spl)

EDIT: now I see why you added the space before! :P

about:plugins

I guess I don't need the other multimedia plugins (for example $yum search plugin shows a bunch for _64 but none for i386)

==> How did you install the jre? Where did you get the rpm? From Sun?

I installed using the .bin from Sun bjre-6u2-linux-i586.bin but I can't find any jre/plugin directory in /usr/lib. I must have something wrong. I was trying to follow www.fedorafaq.org but it seems like this stuff changed since FC6.

yeah... i had a hard time fixing this problem as well ... ok, are u sure u r opening the right firefox? cuz now i have 2 firefoxes ... .64and 32 bit ... make sure u opened the right version entitled "firefox-32" .... and have u checked this thread by leigh??
http://forums.fedoraforum.org/showthread.php?t=158745
i solved my problem by following his steps after i removed the older jres ...

Arkan
1st August 2007, 10:08 AM
after u removed the old jres


su -
gedit /etc/yum.repos.d/fedora32bit.repo

then, copy this in the file and save it ...


[core-32bit]
name=Fedora Core $releasever - i386
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Everything/i386/os/
enabled=1
gpgcheck=1
includepkgs=firefox libgnomeui libbonoboui libgnome SDL fribidi libXv libXvMC libdv mikmod slang aalib enca imlib2 libmpcdec lirc lzo openal portaudio xmms-libs libid3tag xine-plugin
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[updates-32bit]
name=Fedora Core $releasever - i386 - Updates
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/7/i386/
enabled=1
gpgcheck=1
includepkgs=firefox libgnomeui libbonoboui libgnome SDL fribidi libXv aalib enca imlib2 libmpcdec lirc lzo openal portaudio xmms-libs libid3tag libXvMC libdv mikmod slang xine-plugin
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

[livna-32bit]
name=Livna for Fedora Core $releasever - i386 - Base
baseurl=
http://rpm.livna.org/fedora/$releasever/i386/
http://livna.cat.pdx.edu/fedora/$releasever/i386/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/i386/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/i386/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/i386/
failovermethod=priority
enabled=1
gpgcheck=1
includepkgs=mplayer mplayer-gui mplayer-doc libdvdnav a52dec faac faad2 ffmpeg gsm lame libdvdread libmad libmp4v2 mplayer-fonts xvidcore lame-libs mplayerplug-in
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna

make sure u have the livna 7 is installed ... and then type


su -
yum install firefox.i386 firefox-32

after that download the latest java rpm (32 bit version ) (you can't have the 64 bit java rpm installed [ in addition to the 32 bit rpm ] as this will stop the plugin working , if you need 64 bit java please use the tar install )
after u downloaded it ...

su
yum -y install compat-libstdc++-33
sh ./jre*.bin
ln -sf "$(rpm -ql jre|grep plugin|grep ns7/|grep \\.so$)" /usr/lib/mozilla/plugins/libjavaplugin_oji.so


(all this is from leigh's guide http://forums.fedoraforum.org/showthread.php?t=158745 )
cheers :)

lphilosophy
1st August 2007, 10:12 AM
Looks good; will try it soon. But now it is dinner time in Tokyo. ARIGATOU

Arkan
1st August 2007, 10:19 AM
Looks good; will try it soon. But now it is dinner time in Tokyo. ARIGATOU
lol ?? ... its 1:16 pm here xD ... here its early even for lunch :p ...
anyways ... i think if u followed those steps ur java problem will be solved :)
cheers

lphilosophy
2nd August 2007, 07:27 AM
I'm posting up at Leigh's how-to

Arkan
2nd August 2007, 01:31 PM
ok .. i c u have it workin now :) .
cheers