PDA

View Full Version : fc5/ubuntu dual trouble



Sulblk27
22nd July 2007, 11:38 PM
Hello all, I have searched this forum, and others since yesterday...all things that I have tried have been in vain. Keeping in mind, I just installed this distro last night so if a reinstall is necessary I will not mind. There are other issues...like the no shutdown, but this one is more important to me. Boots to ubuntu just fine...trying fc5 is a hold nother ball of wax. I have posted the fdisk and menu.lst, any assistance will be greatly appreciated.

Disk /dev/hda: 13.6 GB, 13613064192 bytes
255 heads, 63 sectors/track, 1655 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 13 104391 83 Linux
/dev/hda2 14 1655 13189365 8e Linux LVM

Disk /dev/hdb: 6448 MB, 6448619520 bytes
255 heads, 63 sectors/track, 784 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1 248 1992028+ b W95 FAT32
/dev/hdb2 * 249 757 4088542+ 83 Linux
/dev/hdb3 758 784 216877+ 5 Extended
/dev/hdb5 758 784 216846 82 Linux swap / Solaris

## ## End Default Options ##

title Ubuntu, kernel 2.6.17-12-Lion
root (hd1,1)
kernel /boot/vmlinuz-2.6.17-12-generic root=/dev/hdb2 ro quiet splash
initrd /boot/initrd.img-2.6.17-12-generic
quiet
boot

title Ubuntu, kernel 2.6.17-12-Lion (recovery mode)
root (hd1,1)
kernel /boot/vmlinuz-2.6.17-12-generic root=/dev/hdb2 ro single
initrd /boot/initrd.img-2.6.17-12-generic
boot

#title Ubuntu, kernel 2.6.17-10-generic
#root (hd1,1)
#kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hdb2 ro quiet splash
#initrd /boot/initrd.img-2.6.17-10-generic
#quiet
#savedefault
#boot

#title Ubuntu, kernel 2.6.17-10-generic (recovery mode)
#root (hd1,1)
#kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hdb2 ro single
#initrd /boot/initrd.img-2.6.17-10-generic
#boot

title Ubuntu, memtest86+
root (hd1,1)
kernel /boot/memtest86+.bin
quiet
boot

title Fedora Core 5
root (hd0,0)
kernel /boot/vmlinuz-2.6.20-1.2320.fc5 root=/dev/hda1 ro quiet splash
initrd /boot/initrd-2.6.20-1.2319.fc5.img
quiet
boot

I have tried moving FC5 to the top, using chainloader +1, and a variety of other options I have found. The most I can get with the current system is file no found. Another way, starts the boot for fc5 then kernel panic (sort of the state I'm in now!)....one of the other errors mount: could not find filesystem '/dev/root' and unable to access resume device (/dev/VolGroup01/LogVol01) when I have LogVol00. Anyway...thank you for reading thru this post in order to try and assist a noobie in times of need.

stoat
23rd July 2007, 02:28 AM
Hi Sulblk27,

I'm not sure this will help, but it's something to try.

Your current Fedora section of grub.conf:
title Fedora Core 5
root (hd0,0)
kernel /boot/vmlinuz-2.6.20-1.2320.fc5 root=/dev/hda1 ro quiet splash
initrd /boot/initrd-2.6.20-1.2319.fc5.img
quiet
boot

Try modifying it to this:
title Fedora Core 5
root (hd0,0)
kernel /vmlinuz-2.6.20-1.23xx.fc5 root=[logical volume here?] ro quiet rhgb
initrd /initrd-2.6.20-1.23xx.fc5.img
You have different versions for vmlinuz and initrd. I haven't seen that before. Check and see what is present in the boot partition and change them appropriately.

With that LVM, you have a separate boot partition for Fedora. That should mean that your kernel and initrd paths are relative to /boot and it should not be in your paths.

The root partition is in that LVM and you probably need the logical volume instead of a device referenced in that vmlinuz line. If so, you need more help than me to figure how to write that. I don't use LVM anymore. Maybe one of the LVM experts will have an opinion about this.

This next one I wrote, then erased, now writing again after thinking more. Try replacing splash with rhgb to pass the Red Hat Graphical Boot parameter to the kernel.

I have never seen that second quiet used that way, so I removed it. But if you know more about that, leave it. Either way, I doubt it hurts.

The boot command at the end is a GRUB command-line command and usually not needed in a menu command, so I removed it too. But if you know more about that, leave it. Either way, I doubt it hurts.

There. Some more things to try. If I am wrong, no harm should have been caused.

mobsta
23rd July 2007, 02:39 AM
M8 can you post the fstab file from Fedora please. This will help a great deal in diagnosing your problem.

Sulblk27
23rd July 2007, 04:59 AM
Thank you so much for the reply stoat, I truly hope I haven't been missing that typo all this time! :eek: , but I will give it a go again, this last command was the last thing I have tried after reading and rereading post...but if I have been messing up the numbers ALL this time...lesson learned.
Hi mobsta, I am having trouble booting to the fc5, ubuntu commands are totally new for me...not sure how I will mount the drive/partition from it yet...if I can get to fc5, I will be alright....now off to redo some more changes....if it works I'll post back, if not I'll try again in the am...
:) stoat Thank you SOOOOOOO much....great eye...looking at my notes I had written the wrong number all along! That solved it I can boot into FC5--now that my eyes have blurred to the point my glasses don't help, time for a bit of snooze....