PDA

View Full Version : YUM is having conflicts.. on everything.



lanahans
20th July 2007, 08:08 AM
I did a clean install of F7 off an ftp.

Ever since I've installed it Yum is constantly conflicting and I haven't been able to update a single package (at least that I'm aware of). I've searched all week for a solution on the forums and have found none. Here's a copy of the transaction errors.



file /usr/share/gtk-doc/html/gdk/gdk.devhelp from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gdk/gdk.devhelp2 from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gdk/index.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gdk/index.sgml from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gdk/ix01.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gdk/ix02.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gdk/ix03.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gdk/ix04.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gdk/ix05.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gdk/ix06.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gdk/ix07.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gdk/multihead.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkAboutDialog.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkAccelLabel.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkAccessible.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkAction.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkActionGroup.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkAdjustment.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkAlignment.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkArrow.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkAspectFrame.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkAssistant.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkBin.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkBox.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkButton.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkButtonBox.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkCList.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkCTree.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkOldEditable.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkOptionMenu.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkPageSetup.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkPageSetupUnixDialog.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkPaned.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkPixmap.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkPlug.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkPreview.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkPrintContext.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkPrintJob.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkPrintSettings.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkPrintUnixDialog.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkPrinter.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkProgress.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkProgressBar.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkRadioAction.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkRadioButton.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkRadioMenuItem.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkRadioToolButton.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
file /usr/share/gtk-doc/html/gtk/GtkRange.html from install of gtk2-devel-2.10.13-1.fc7 conflicts with file from package gtk2-devel-2.10.11-7.fc7
etc..


I never had problems with 5 or 6, so could someone please enlighten me as to what I am doing wrong.

Thanks in advance,
Scott

ms1234
20th July 2007, 08:18 AM
What repositories do yo have in use? It used to be that livna didn't play well with other, with FC6 it seems to be atrpms while livna is everyones favorite.

lanahans
20th July 2007, 08:19 AM
Update: I disabled the GTK package from installing and all the other packages are now installing, but now the problem is how do I update that specific package?

I was using livna + the defaults, now I've disable livna.

lazlow
20th July 2007, 08:21 AM
Atrpms has been a problem child for a long time (at least FC4 days).

leigh123linux
20th July 2007, 08:41 AM
try


su -
rpm -e gtk2-devel-2.10.11-7.fc7