View Full Version : Installing Matlab 2007a on Fedora 7

Aardvark Freak
10th July 2007, 01:39 AM
If you try installing Matlab 2007a on Fedora 7 like it says in the instructions, you'll get some error message like this when you run the installer:

libXp.so.6: cannot open shared object file: No such file or directory
This post will tell you how to get rid of that error and run the installer.

First, you need to install the xorg-x11-deprecated-libs package, which hasn't been distributed since FC4 as far as I can tell. The FC4 RPM works fine though; get it here: http://rpm.pbone.net/index.php3/stat/4/idpl/2829969/com/xorg-x11-deprecated-libs-6.8.2-37.FC4.49.2.1.i386.rpm.html

After installing that RPM (either through the GUI or by typing "rpm -ihv xorg-x11-deprecated-libs-6.8.2-37.FC4.49.2.1.i386.rpm" as root), you need to put one of those libraries in the place Matlab looks for it. Run this as root:

ln -s /usr/X11R6/lib/libXp.so.6 /usr/lib/libXp.so.6

After that, you can just follow the instructions included with Matlab and it should work fine.

Older versions of Matlab require stranger forms of voodoo, I'm sure. My previous experience was installing Matlab 7 on FC5, which was a nightmare.

28th February 2008, 04:21 PM
When I ran into that problem, I just ran the following in a terminal as root.

yum install libXp-devel

This has worked for me on multiple installations of Matlab in Fedora 7 x86_64 and an installation of Fedora 8 x86_64.