PDA

View Full Version : cant access music on with duel boot os



ichiakahoshi
7th July 2007, 05:28 PM
hi,
this is my first week as a Linux user and ive installed Fedora core 6 onto my computer, which im duel booting with windows xp. i have 3 partitions on my hard drive. in theory, 1 for windows, 1 for Linux and another for my music and important documents. when using windows i was able to access my music simply by following the icons. but when im using Fedora i cant get to it? i don't know what other information i can give here that would help, but if anyone has a clue how to solve this, it would be massively appreciated.

Seve
7th July 2007, 05:38 PM
Hello:
In Fedora // linux you will have to mount the partition in Fedora.
To do so, you will first need to create a mount point then you can mount your other partition.

Open a terminal in Fedora and log in as root using
su -
and
type and post the output of
fdisk -l


Seve

ichiakahoshi
7th July 2007, 08:17 PM
i typed fdisk -l into the terminal window but do not know how to mount the partition. i dont know what the partition is called in linux (it was E in windows) and dont know the first thing about the specific workings of terminal comands. is there any way of finding what/where the partition is.

Seve
7th July 2007, 09:21 PM
Hello:

If you follow the previous response and post the output of
fdisk -l
I will provide you with the steps needed to mount the partition you like.
I or others, need to know which and what the available partitions on your computer are, in order to assist you.

Seve

ichiakahoshi
7th July 2007, 09:54 PM
guess i should of read your post a little better ^_^

here it is

[root@cpc1-cdif5-0-0-cust544 ~]# fdisk -l

Disk /dev/sda: 250.0 GB, 250000000000 bytes
255 heads, 63 sectors/track, 30394 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 8 64228+ de Dell Utility
/dev/sda2 * 9 10029 80493682+ 7 HPFS/NTFS
/dev/sda3 29989 30393 3253162+ db CP/M / CTOS / ...
/dev/sda4 10030 29988 160320667+ f W95 Ext'd (LBA)
/dev/sda5 10030 15069 40483768+ 7 HPFS/NTFS
/dev/sda6 20010 29988 80156286 7 HPFS/NTFS
/dev/sda7 15070 15082 104391 83 Linux
/dev/sda8 15083 20009 39576096 8e Linux LVM

Partition table entries are not in disk order
[root@cpc1-cdif5-0-0-cust544 ~]#

Seve
8th July 2007, 12:55 AM
Hello:
From Fedora
Open a terminal and log in as root using
su -
yourpassword
[then to create a mount point] type
mkdir /mnt/Vol01
then, while in the same open terminal type
gedit /etc/fstab
and add the following line
/dev/sda5 /mnt/Vol01 ntfs-3g defaults 0 0

[this will allow your windows [ntfs] partition to be mounted automatically each time you boot.]
Save your work, exit and reboot and your windows [ntfs] file partition should be mounted under /mnt/Vol01

You can add a similar entry for each of your ntfs partitions if you wish.
Just make a similar mount point for each partition you want to mount, using the the above as an example.

If, for some reason it does not mount automatically upon a reboot, the, from a terminal type
system-config-securitylevel
and under the SELinux Tab
set it to Permissive or Disabled, reboot and you should be good to go.

Seve

ichiakahoshi
8th July 2007, 02:21 PM
ive done all the above but it still isnt working.

here is what i typed into the "gedit /etc/fstab" window:

/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/sda5 /mnt/vol01 ntfs-3g defaults 0 0

and security level is set as disabled

when the system is booting up i noticed two failed entries
1. mounting local file system: [FAILED]
2. mounting other filesystem : mount: unknown filesystem type 'ntfs-3g' mount: mount point 0 (or 8 the font was to small to be exact) does not exist [FAILED]

??

multescugeorge@
8th July 2007, 03:17 PM
fix it with:


sudo yum -y install ntfs-3g

ichiakahoshi
8th July 2007, 04:13 PM
thanks!!! ^_^ its worked and i can access my music now
buuut

there is an erroro message when i attempt to play the actual files

Totem could not play 'file:///mnt/vol01/Entertainment/Music/Mo0O0osik/Alice in Videoland/Alice in videoland - Addicted.mp3'.
You do not have a decoder installed to handle this file.
You might need to install the necessary plugins.

where am i likely to find these plugins and what are they?

multescugeorge@
8th July 2007, 04:24 PM
see here:
http://www.mjmwired.net/resources/mjm-fedora-f7.html#mp3

ichiakahoshi
8th July 2007, 05:17 PM
i have downloaded Audacious from the above link but still am unable to play my mp3 files, this message keep coming up

Unable to play files.

The following files could not be played. Please check that:
1. they are accessible.
2. you have enabled the media plugins required.

i thought that this was the the media plugin? im getting more confused by this as im going along

multescugeorge@
8th July 2007, 05:23 PM
do:


sudo yum install xmms xmms-mp3 xmms-faad2

then start xmms by typing in a terminal: xmms
right click on the interface and:


Plugin settings: Options > Preferences >
Audio I/O Plugins > Input Plugins
Disable: MPEG Layer 1/2/3 Placeholder Plugin [librh_mp3.so]
==> UNCHECK [ ] Enable Plugin

also, audacious and xmms are not a plugins to play mp3's, they'r music players that have mp3 plugins.

ichiakahoshi
8th July 2007, 05:51 PM
ok, ive done all that bu still no music (arrrrrrrrrrrg) when i open xmms through a terminal window this message apears
** WARNING **: alsa_setup_mixer(): Failed to find mixer element: PCM

i dont know if this has anything to do with it? also im just trying to drag and drop the music into xmms. is that right?
when i press play (with no kind of playlist) a playfiles option opens, i looked for the tracks in the directories and files option
selected a track and play, buit this still nothing happens.

p.s thanks for the plugin lesson ^_^ things are a little less confusing now

multescugeorge@
8th July 2007, 05:55 PM
do you have any sound in Fedora ?

ichiakahoshi
8th July 2007, 08:56 PM
yea it does, i did a sound test when it was installed and im able to play CD's through it, just not the music on my other hard drive.
i do apreciate all this help and if theres any more information that i can give (if you tell me how to find it ^_^) id be more than happy to.

bigboss2200
8th July 2007, 11:11 PM
try to right-click ur sound icon then Preferences.. under "master", select ur device "which is Alsa mixer in my case"

if that didnt help, then open ur xmms, go to "option --> preferences", then change the "output" plugin "its also Alsa mixer in my case", just simply keep changing it till u get a sound :) .. i

I hope it helped :) ..

Regards,
Faris....

ichiakahoshi
11th July 2007, 10:08 PM
sounded like it would, but they both were set to Alsa v_v
ive tried opening the files with xmms, Audacious and Rythembox Music Player and none of them support MP3?
if i drag and drop a music file into the playlist of Rythembox for example a playback error message shows

The GStreamer plugins to decode "MP3" files cannot be found

and Audacious reads

The following files could not be played. Please check that:
1. they are accessible.
2. you have enabled the media plugins required.

am i missing something? are there specific things i was ment to have done to play mp3s?

ichiakahoshi
11th July 2007, 10:13 PM
also when i open xmms through a terminal it does open but in the terminal it reads


** WARNING **: alsa_setup_mixer(): Failed to find mixer element: PCM


may make some sense to someone