PDA

View Full Version : driver installing probs - lucent winmodem



ray15
5th July 2007, 10:05 AM
When I run 'make install' it sees Makefile, but not files in /proc folder. I also get permission errors.
Thanks.

giulix
5th July 2007, 10:11 AM
make install usually needs to be run as root.

ray15
5th July 2007, 10:16 AM
Sorry, I should have said that I was in a Terminal window as Root. I was in a sub folder of /home

giulix
5th July 2007, 10:19 AM
No problem. That was most likely problem #1. Now that we've taken care of that, can you post here the output with the error message(s), please ?

ray15
5th July 2007, 02:09 PM
[root@localhost Kernel_2.2.16]# uname -r
2.6.21-1.3194.fc7
[root@localhost Kernel_2.2.16]# ls -ls
total 1388
8 drwxrwxrwx 2 root root 4096 2007-07-04 22:04 i56lvp578
236 -rwxrwxrwx 1 Peter Peter 230743 2001-06-01 07:06 linux600.zip
8 -rwxrwxrwx 1 root root 2513 2000-05-14 20:51 linuxif.h
8 -rwxrwxrwx 1 root root 1528 2000-05-14 20:51 ltinst
408 -rwxrwxrwx 1 root root 409355 2000-05-14 20:50 ltmdmobj.o
16 -rwxrwxrwx 1 root root 8422 2000-05-14 20:51 ltmodem.c
408 -rwxrwxrwx 1 root root 409239 2007-07-04 19:20 ltmodem.o
8 -rwxrwxrwx 1 root root 1368 2000-05-14 20:51 ltuninst
8 -rwxrwxrwx 1 root root 1678 2001-05-17 21:32 Makefile
8 -rwxrwxrwx 1 root root 978 2000-05-14 20:52 readme.txt
172 -rwxrwxrwx 1 root root 167554 2000-05-14 20:51 serial24.c
100 -rwxrwxrwx 1 root root 92795 2000-05-14 20:51 serial.c
[root@localhost Kernel_2.2.16]# make install
./ltuninst
ERROR: Module ltserial does not exist in /proc/modules
ERROR: Module ltmodem does not exist in /proc/modules
make all
make[1]: Entering directory `/home/Peter/Download/lucent_zip/56K LUCENT/PCI/RED
gcc -D__KERNEL__ -DMODULE -DLT_KER_24 -DNO_EEPROM -w -O2 -fomit-frame-pointer -I c/linux-2.6.21/include -I/usr/src/linux-2.6/include -c -o ltmodem.a ltmodem.c
make[1]: gcc: Command not found
make[1]: *** [ltmodem.a] Error 127
make[1]: Leaving directory `/home/Peter/Download/lucent_zip/56K LUCENT/PCI/RED H
make: *** [install] Error 2
[root@localhost Kernel_2.2.16]#

giulix
5th July 2007, 03:40 PM
I suggest you start with the following (as root):


yum update

If you haven't any particular reason for staying with that kernel. Then you need the development packages


yum groupinstall "Development Tools"

Then proceed installing the kernel headers and compiling the driver


yum install kernel-headers
make

and try installing again. Can you also post here the modem model and a link to download those drivers, please ?