PDA

View Full Version : Apt Install dependencies



Bana
22nd February 2004, 09:34 PM
I'm trying to install the apt rpm (apt-0.5.5cnc6-1ark.x86_64.rpm) yet I am getting dependencies that I cannot fix, specifically, these three:
librpm-4.0.4.so()(64bit) is needed by apt-0.5.5cnc6-1ark
librpmdb-4.0.4.so()(64bit) is needed by apt-0.5.5cnc6-1ark
librpmio-4.0.4.so()(64bit) is needed by apt-0.5.5cnc6-1ark
These are already on my computer in /usr/lib64 yet they are the newer version ie: librpm-4.2.so so I created links of librpm-4.0.4.so to the newer ones yet it doesn't seem to be helping, any ideas?

sundanceloki
22nd February 2004, 10:04 PM
Hi,

The only thing I can think of to help right now is to either install with --nodeps, (ugly idea) or downgrade your versions of librpm etc, install and apt-get update, (not very attractive either) I'll do some more checking around and see if I can find a more recent apt for 64bit and post.

SDL

Bana
22nd February 2004, 10:17 PM
What I think I'm gonna do is ditch this x86_64 install as my main one and install a nice clean FC1 as my main boot and use this to test the 2.6.3 kernel.

There, Problem Solved :p

(there are many more reasons for doing this as well)