PDA

View Full Version : using a specific kernel



100%digital
4th July 2007, 07:47 AM
Hello All,

I'm currentlyusing kernel 2.6.20 and I would like to use kernel 2.6.18, how do i downgrade my version? and once i get the 2.6.18 kernel source files installed can do i just need to modify my grub.conf and boot the older kernel????? I haven't a clue, much thanx for your help.

leigh123linux
4th July 2007, 08:51 AM
Posts # 6 & 8 of this thread should help

http://forums.fedoraforum.org/forum/showthread.php?t=157437&highlight=downgrade+kernel

100%digital
5th July 2007, 01:03 AM
many thanx, that was just the information i was looking for. Fedora doesn't support the wget command??? or atleast, not on my system anyway :) but i used the link to get the kernel/kernel src, i had no idea it was that easy, rpm -i (gotta love not haveing to complie), anyway thanks for your help.

I'm actually having another problem, and I was sort of hoping you'd have some insight;

I've installed the Madwifi driver, and had it working... but once i rebooted my computer, if i modprobe ath_pci, i get the following errors;

WARNING: Error inserting ath_hal (/lib/modules/2.6.20-1.2962.fc6/net/ath_hal.ko): Invalid module format
WARNING: Error inserting wlan (/lib/modules/2.6.20-1.2962.fc6/net/wlan.ko): Invalid module format
FATAL: Error inserting ath_pci (/lib/modules/2.6.20-1.2962.fc6/net/ath_pci.ko): Invalid module format

thanks for you help.

leigh123linux
5th July 2007, 01:12 AM
many thanx, that was just the information i was looking for. Fedora doesn't support the wget command??? or atleast, not on my system anyway :) but i used the link to get the kernel/kernel src, i had no idea it was that easy, rpm -i (gotta love not haveing to complie), anyway thanks for your help.

I'm actually having another problem, and I was sort of hoping you'd have some insight;

I've installed the Madwifi driver, and had it working... but once i rebooted my computer, if i modprobe ath_pci, i get the following errors;

WARNING: Error inserting ath_hal (/lib/modules/2.6.20-1.2962.fc6/net/ath_hal.ko): Invalid module format
WARNING: Error inserting wlan (/lib/modules/2.6.20-1.2962.fc6/net/wlan.ko): Invalid module format
FATAL: Error inserting ath_pci (/lib/modules/2.6.20-1.2962.fc6/net/ath_pci.ko): Invalid module format

thanks for you help.

Did you boot the new kernel then get this error ?
Where did you get the driver ?

yetigrey0864
18th September 2007, 01:41 PM
I ran into this same problem after installing a more recent madwifi.rpm than my kernel. Updating the kernel using

$ yum update kernel

updated the kernel, which included an updated dkms. This solved the problem with ath_pci not loading.
It is fairly painless to use these drivers once they are loaded. Once they are, make sure that Network Manager and Network Manager Dispatch are running in system>admin>services, make sure that wpa_supplicant.rpm is installed if you need to access a secured network (Does Not need to be run in system>admin>services), and run as root

$ modprobe ath_pci

$ depmod -a

$ dmesg

and you should see output from the wifi0 at the end or you can use

$ iwconfig

and you should see a listing for wifi0 and ath0.

Reboot, and Network Manager should have an icon in the menu bar, when clicked it will show available wireless networks. You may need to create a password for the keyring manager (a bag in the bag in the bag... ) to enable Network Manager to store WEP, WPA keys.

yetigrey0864
18th September 2007, 01:51 PM
I believe that using latest madwifi-0.9.4-0.1.r2594.fc7.x86_64.rpm released 23-07-2007 requires an updated dkms, moving away from kmod, found in the new kernel. Using the packaged kernel from an fc7 disro (2207-05-31) returned the same error. Updating the kernel allowed ath_pci to load properly.