PDA

View Full Version : I messed up my server - Please help



ShaunRigby
3rd July 2007, 12:36 PM
Hi Guys,

I had my FC5 LAMP server setup successfully for a while now, and I used the HTTP config tool to try and add a virtual host to my config, after doing this and restarting apache I got the 'SSLEngine' error, so after some googling I found that the problem was caused by the actual HTTP config utility, so i thought OK nt to worry, so I uninstalled and Re-Installed the HTTPD daemon, and to my suprise the error was still there.

So i downloaded, compiled and installed Apache 2.0.4 and then PHP4 (Devel & webhost issues), and now after following the INSTALL for PHP i get the following error when i load up Apache (NOT httpd)


[root@mx1 shaun]# /usr/local/apache2/bin/apachectl start
Syntax error on line 233 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server: /usr/local/apache2/modules/libphp4.so: cannot open shared object file: No such file or directory

After looking in the original PHP tarball that I downloaded I couldn't find the module, and now after installing mod_ssl and trying to restart httpd daemon i get the following error:


[root@mx1 shaun]# /etc/init.d/httpd start
Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


Is there something that Im missing, im a linux noob so i apologise if it is something REALLY simple.

Thanks in advance for your help

Rgds,

Shaun