PDA

View Full Version : LDAP Authentication, problems with root account



nncanepa
2nd July 2007, 05:53 PM
I've Fedora 7 installed, authenticating with an LDAP server.
The authentication works fine when I have connection to the LDAP server.
The problem arises when I try to authenticate root account, when the ldap server is unreachable (I have the same problem with FC6)

my nsswith.conf has the following lines:

passwd: files ldap
shadow: files ldap
group: files ldap

this is my pamd./system-auth :

#%PAM-1.0
# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.
auth required pam_env.so
auth sufficient pam_unix.so nullok try_first_pass
auth requisite pam_succeed_if.so uid >= 500 quiet
auth sufficient pam_ldap.so use_first_pass
auth required pam_deny.so

account required pam_unix.so broken_shadow
account sufficient pam_localuser.so
account sufficient pam_succeed_if.so uid < 500 quiet
account [default=bad success=ok user_unknown=ignore] pam_ldap.so
account required pam_permit.so

password requisite pam_cracklib.so try_first_pass retry=3
password sufficient pam_unix.so md5 shadow nullok try_first_pass use_authtok
password sufficient pam_ldap.so use_authtok
password required pam_deny.so

session optional pam_keyinit.so revoke
session required pam_limits.so
session [success=1 default=ignore] pam_succeed_if.so service in crond quiet use_uid
session required pam_unix.so
session optional pam_ldap.so


the pam files are edited by the fedora gui for configuring authentication, I marked the option Local authorization is enough for local users . But still doesn't work.
I googled for this problem, but I couldn't find any working solution.

Has anyone solved this?

Thanks