PDA

View Full Version : Dual Monitor Problem



Daniel114
2nd July 2007, 02:23 PM
hello,

I'm having a problem with dual monitors.

basically I have a tft screen at 1024x768 in front of me, which I would like to use as the primiary monitor, and a crt to the right of it which I would like to use as secondary.

Using the system-admin-disply tab didn't seem to work, it allowed dual head (I want them to be independant) but switched them around so that the crt was primary and apparently situated where the tft is.

I channged the xorg.conf to try and allow the monitors settings to stay (kept reverting) and now all I am able to get is a clone of my tft on the crt no matter what I change

xorg is

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "Multihead layout"
Screen 1 "Screen0" LeftOf "Screen1"
Screen 0 "Screen1" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "off"
Option "Clone" "off"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor 1280x1024"
HorizSync 31.5 - 79.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.5
VertRefresh 40.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "radeon"
VendorName "Videocard Vendor"
BoardName "ATI Technologies Inc R480 [Radeon X800 GTO (PCIE)] (Secondary)"
BusID "PCI:1:0:1"
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

anybody any ideas? incidentally when startx was reinitialised it picked up the make of my tft (LG L1510s) but now it wont display that

any help wouldbe greatly appreciated, im sure its something quite simple

dan

VictorienSardou
7th July 2007, 12:54 PM
in this section, you are missing 'Monitor "Monitor0"'
Section "Screen"
Identifier "Screen1"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection