PDA

View Full Version : FC6 kernel 2962 ext3 not booting



jaminJay
30th June 2007, 02:25 PM
I got my (new) internet connection up and FC6 proceeded with the latest updates. It is having issues with elfutils and python conflicting with stuff, which is annoying in itself (and prevents me from 'upgrading' to F7 when I finish backing everything up.

Anyway, my /boot partition failed the other day and I had to boot into windoze to backup the partition, FC5 (on another drive) and format the partition and copy the boot files back. Okay, so that all worked and I continued updating software.

It had been having trouble updating the kernel, then it decided to do it and installed the new kernel and kmod-ntfs and -nvidia and I fixed up the grub files on the other 'real' boot partition with the information about the new kernel.

When I go to boot, it says it can't mount any of the partitions (I'll have to transcribe the message and post it when I get home later). Trying to boot into FC5 fails the same way. Windoze reads the drive fine. Then I tried booting with the previous FC6 kernel and it gets in all the way (except the kmod-ntfs and -nvidia fail as they're wanting the new kernel and I have to reset xorg.conf).

So, any info on what direction I should head in here? I have searched a lot on the web for two days now and it's driving me crazy. I need to get the system back up and working properly so I can get back to work.

Will post any data I can in the morning. Thanx for any replies in the meantime, maybe someone already has solved this? (PS. my message files are all empty, WTF?).

jaminJay

jaminJay
2nd July 2007, 09:05 AM
And, here is a transcribed photo of the screen at bootup (where it panics and won't even let me give the three-fingered salute successfully...).



Booting 'Fedora Core (2.6.20-1.2962.fc6)'

root (hd1,0)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.20-1.2962.fc6 ro root=LABEL=/1 rhgb quiet
[Linux-bzImage, setup=0x1e00, size=0x1e28b4]
initrd /initrd-2.6.20-1.2962.fc6.img
[Linux-initrd @ 0x1fe9e000, 0x14d357 bytes]

Uncompressing Linux... Ok, booting the kernel.
ACPI: Invalid PBLK length [5]
Red Hat nash version 5.1.19.0.3 starting
insmod: error inserting '/lib/ext3.ko': -1 Unknown symbol in module
mount: error mounting /dev/root on /sysroot as ext3: No such device
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!
_


Continuing my search...

:-(

jJ

lmo
2nd July 2007, 01:39 PM
insmod: error inserting '/lib/ext3.ko': -1 Unknown symbol in module
It sounds like the initrd for 2.6.20-1.2962.fc6 is messed up.

It sounds like you have one of the kernels that you can boot into, but X bombs.
Boot into that one and let X bomb.
Then CTRL-ALT-F1 and login: root

Once there, do:
ls /lib/modules

One of the ones listed is 2.6.20-1.2962.fc6 right?

If you are cautious, like me, you could backup the suspected initrd:
cd /boot
cp initrd-2.6.20-1.2962.fc6.img initrd-2.6.20-1.2962.fc6.img.bak

If this is the messed up one that you want to remake the initrd for, you could try:
mkinitrd -f /boot/initrd-2.6.20-1.2962.fc6.img 2.6.20-1.2962.fc6

jaminJay
3rd July 2007, 12:35 PM
Well, it's no trouble to fix the X conf., I'm in X right now (just without dual-head or glx or beryl...).

I thank you for your suggestion, but that appears not the solution (at least on the surface). I am going to try downloading the packages that yum is having issues with and installing them manually with RPM, just to see if that fixes the problem (not that I'm expecting it to).

Seems funny that I'm having issues now after such a long and stable time and noone else appears afflicted... :-( /me cues violins

jJ

lmo
3rd July 2007, 02:30 PM
Since post#1 indicated that the whole purpose is to upgrade FC6 to 7, I will just report that I did that last night.

I generally never updated anything. I had only updated something if I had a particular reason to update that one thing.

Media check is important.
I had a false start because one file on the dvd had an I/O error.
Once I overcame that, there was no complaint.

I actually overcame that bum file by copying the f7 .iso to disk, magically downloading the bum file and remaking the .iso and making a cd from the boot.iso and booting from that.

I am sure that my ways of not updating and of upgrading are ill-advised by the majority, but it works for me.

Note that I have a backup installation on another partition which enabled me to rescue myself.

jaminJay
4th July 2007, 12:47 AM
Yes, that's my main issue. It is taking ages for me to backup what is approaching half of a terabyte of data, and I don't want to go to F7 too soon as I need to ensure ICA, VMware and other things are all go first (I downloaded FC6 the day of release and installed it along side FC5, and am glad I did as I spent nearly a month using FC5 primarily until I could get everything running in FC6).

So, unfortunately, the primary goal is to get my system running in the condition it was last fortnight. Then I will download F7. I should note that I had a lot of trouble 'upgrading' from FC4 to FC5 on another box. It was small enough for me to take all the files I needed off and just reinstall from scratch and put the files back on. This is why I am cautious of jumping in to F7 so soon.

/me dreams of the day when F8 is just another yum update like any other day, with more material...

The other issue I'm worried about is why it affected my "completely stable" install of FC5. I'm hoping it's not the hardware. That drive's not very old and is the bigger of the two... :-(

jJ

jaminJay
4th July 2007, 03:40 AM
Well, I've successfully got all updates done. Now I just need to get it booting up with the new kernel so I can get my dual head desktop back (nothing in the remaining updates fixed the problem).

:-(


jJ

jaminJay
4th July 2007, 09:13 AM
Okay. Have decided to manually install nvidia drivers and am 'back to square one'. I have yet to test whether FC5 works again or not, but at least I have dual-head back, maybe i can get some work done in the meantime.

I might wait until the next kernel release before trying again. It's funny, however, that kmod-ntfs wants to update to the next kernel version, but nothing else is marked as an update? Ho-hum.

Thanx for all help.

I will post any issue that stems from this in this thread (for instance, if FC5 continues to not boot), or any solutions I find.


jJ

jaminJay
29th March 2009, 10:34 AM
Guess I never solved that one, huh..? :)