PDA

View Full Version : X wont start after yesterdays Fedora 7 software update



winterman
29th June 2007, 09:07 AM
Sorry to be a bit vague I am still fairly new to linux (but not that new)..

Basically, as usual I ran Software Update yesterday (something I do everyday) and noticed one update that required a reboot, can't remember which one it was though but I assume it was another Kernel patch.

Following advice I received a while back from a Linux guru mate of mine I duly unchecked all of the other updates and installed that one on it's own and went for the reboot.

X is now refusing to load apparently due to a corrupt config. I know nothing about configuring X from the console so am a bit stuck.

I have an NVidia 6800GT gfx card which I have had no issues with so far apart from having to reinstall the drivers every now and then due to other Kernel patches.

Can someone offer any advice or point in the direction of a good guide on configuring/fixing X under Fedora 7. I can get console so should hopefully be able to sort it from there.

Many thanks and apologies for making my first post here a question.

Mic

leigh123linux
29th June 2007, 09:23 AM
can you post the output from the commands below

login as root

then type these commands

cat /var/log/yum.log | grep Updated

cat /var/log/Xorg.0.log | grep EE

cat /var/log/Xorg.0.log | grep WW

and

yum list *nvidia*

winterman
29th June 2007, 09:30 AM
Thanks for the quick response Leigh.. At the moment I am at work (the box is at home and not powered on).

I will try and get an update to you this evening. In the mean time I do use the kmod rpms from LIVNA and they were updated Tuesday successfully.

a_small_cake
29th June 2007, 10:42 AM
Maybe its NVidia driver version and Kernel version that don't match?

winterman
29th June 2007, 10:46 AM
I did try starting the OS with an earlier kernel build but to no avail..

Basically I am lost when I get to the rescue mode command prompt (always been a lazy point and click urchin since GEM desktop was released really)

Dieter88
29th June 2007, 02:22 PM
I'm happy to see this treath, because I have the same problem. But I didn't know what is was, so searching was difficult.
Yesterday I did some updates, and after logging in my background was blue/green, my clock was analoge, when I click somewhere I get a list of some commands, but thats all. I allready had this problem, but then I just reinstalled fedora.

Those commands you said, what am I looking for when I run them. I see the updates I performed and an error (multiple off this:)
(WW) AIGLX: 3D driver claims to not support visual 0x23

I hope someone can help

winterman
29th June 2007, 02:34 PM
Ah.. I have stumbled upon this link over lunch which seems to relate very closely to my issues..

Will try this tonight as well and report back

http://www.cyberciti.biz/tips/black-screen-while-starting-x-window.html

notmyrealemail
29th June 2007, 02:46 PM
Hmm, im ganna with a small cake on this prably.

uname -r # running kernel
rpm -q kernel-devel # installed kernel headers

Try that, see if they match, if they dont, you should be able to

yum -y upgrade kernel kernel-devel

If you are still having teh problem, maybe uninstall and reinstall xwindows?

Dieter88
2nd July 2007, 09:43 AM
Yesterday, I removed evolution (I prefer thunderbird) after having Fedora reinstalled, and again the same problem. I checked the librarys Fedora removed with it, but I didn't saw something to do with X. And when I try to upgrade the kernel (yum -y upgrade kernel kernel-devel) it sais there's nothing to upgrade. Also the method of http://www.cyberciti.biz/tips/black-screen-while-starting-x-window.html doesn't work. I really need to get this clear, because it is really to annoying.

winterman
2nd July 2007, 04:49 PM
Hi gang,

Just thought I ought to update on this so you didn't think I was a leech! :D

Didn't get a chance to play over the weekend really (very intensive ale consuming weekend!! :D) but tried most of the suggestions posted to no avail. Left machine on when I came to work today and NoMachine NX came up straight away remotely (bizarre!), after ssh'ing in and removing XOrg and reinstalling it I got Gnome to come up over NX but it keeps hanging (no panels work but the desktop icons do), installed KDE which has come up fine over NX.

Will check out whether it works at all from home tonight and post back..

Cheers
Mic

winterman
3rd July 2007, 09:11 AM
Well, I'm back!! :D

It wasn't the prettiest of solutions but I finally managed to get GNOME running again locally and it is performing better than ever, so it looks like I really screwed something up somewhere.

My final resolution to the problem was to totally uninstall the group "GNOME Desktop Environment" and all "GNOME Development" files, totally remove the "X" group, then manually go through and "rm" any reference to XORG! Maybe a bit overkill but it worked!

I then re-installed the "GNOME Desktop Environment" using yum which brought in the basics of XORG and added any packages required to get the nvidia drivers installed. I did have to use the official NVIDIA installer as I could not get LIVNA's to work this time but I have found the performance to be so much better (quick test with FallOut2 and HalfLife2 under Wine).

Phew! Thanks to everyone for their advice and help on this one.. Much appreciated!

Dieter88
3rd July 2007, 11:40 AM
After all, isn't it easier to reinstall fedora?

At this moment, I'm just looking very good if I install/remove something (especially removing), just till I hear something about a new about for this.