PDA

View Full Version : Qeury about boot-up sequence



1jackjack
28th June 2007, 07:03 PM
When I start my computer and load F7 (on a dual partition with XP), everything loads fine until it gets to the login screen. It finished "starting first-time boot configuration", then the screen goes black for 10 seconds. The 'loading' LED on my laptop stops flashing, and stays off, and there is only a mouse pointer on the screen (not the loading animation), and I cant move it with the mouse. After, I get a flash of command prompt to do with "localhost login", before the login screen loads. Then everything is fine. This is not a problem, I was just wondering what was happening!

Cheers
Jack

JoeyJoJoe
28th June 2007, 07:30 PM
not sure why it would do that but i might have a fix...

log into GNOME once its stopped being weird, then go System > administration > services and enter your root password

Then stop the service called "firstboot" and uncheck the tick box so that it won't start again. Then save that config and try restarting... hopefully that'll fix your problems

JoeyJoJoe
28th June 2007, 07:32 PM
actually firstly you should make sure that you actually have the /etc/sysconfig/firstboot file... if you don't then that could cause the issue, but so long as you do its still worth stopping the service

1jackjack
28th June 2007, 08:23 PM
yer, i have that firstboot file, and no, this didnt stop the 10 seconds of black screen....

it just seems so pointless! I'm sure the computer is not doing anything during this time!

JoeyJoJoe
28th June 2007, 08:42 PM
alright, I still that that there might be some utility out of looking at stopping this service. Looking at it I think that you'll need to stop it in all run levels, if when you open up the services you go to "edit runlevel" (at the top, where I think "file" is, or would be) and go to edit all, then stop it in run level 3 (and 4 if it is running in that) as well as 5 (which is the default)...

This might still not work, but I'm hoping that it can...

1jackjack
29th June 2007, 10:37 AM
Stopped firstboot on all levels, and nothing has changed. is there any way to run a verbose startup?
Thanks

lmo
29th June 2007, 01:45 PM
Search for "BootChart whats your boot time" in these forums.
The bootchart captures data which is then converted into a picture and this "snapshot" may help to identify how time is being used during the boot process.

1jackjack
29th June 2007, 04:01 PM
edit: here is my boot pic. Any ideas?
(i think on the chart, im talking about the period 75 to 88 seconds)

Thanks

lmo
29th June 2007, 10:39 PM
Well, I don't really know, but I turned off yum-updatesd and readahead_early and readahead_later with:

chkconfig <service-name> off

and it didn't cause me any problems that I know about.

I know that I don't want yum-updatesd running, but apparently a lot of people do want that one running. On my system, I was not able to detect any benefit of running readahead_early and readahead_later.

I noticed long pink bars associated with yum-updatesd and readahead.
I really don't know.

rhgb adds about 10 seconds

JordanN
30th June 2007, 03:15 PM
Is your video card configured correctly? It sounds to me like the XServer may be having difficulty loading, and is having to auto-detect to override the settings in the config file.

1jackjack
1st July 2007, 10:47 PM
sorry, but how would i know if my video card is configured correctly, and what is the XServer?
But this sounds promising, thanks for your help!

Saint Mike
2nd July 2007, 03:42 AM
Do you have an ATI or Nvidia graphics card?

1jackjack
2nd July 2007, 12:03 PM
ATI Radeon Xpress 200M IGP

Saint Mike
3rd July 2007, 03:06 PM
Then try installing following this guide to get fedora recognizing it, see it that helps

http://www.diffingo.com/blog/content/view/31/33/

1jackjack
3rd July 2007, 03:28 PM
http://www.diffingo.com/blog/content/view/31/33/

It is not clear whether to use the 'fglrx' driver or the 'radeon' driver, but following the instructions, i found that I'm already setup to use the radeon one, so that can't be the fix! So I thought I'd give the fglrx one a go, but on the 3rd command:

fglrx-config-display enable
I get

-bash: fglrx-config-display: command not found

Any other ideas?
Thanks

edit: I have the normal f7 kernel (with all the available updates), and have the normal 32-bit arch