PDA

View Full Version : qt dependancy issue



Wangberg
28th June 2007, 04:09 PM
i'm trying to ./configure scim-panel-kde app and i get this error:



checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and libraries)
not found. Please check your installation!



thing is, i have qt, qt-devel, qt4, and qt4-devel packages all installed....




[****@sam ~]$ sudo yum list qt*
Loading "installonlyn" plugin
Installed Packages
qt.i386 1:3.3.8-4.fc7 installed
qt-devel.i386 1:3.3.8-4.fc7 installed
qt4.i386 4.3.0-2.fc7 installed
qt4-devel.i386 4.3.0-2.fc7 installed
qt4-x11.i386 4.3.0-2.fc7 installed

RobertoVanto
28th June 2007, 05:04 PM
Why don't you use yum?

% yum install scim

Wangberg
28th June 2007, 07:30 PM
i'm not installing scim, i'm installing the scim-panel-kde app. Here is the link: http://www.nongnu.org/scim/htdocs/ I can see that the site hasn't been updated since 2004, so maybe this app is out of date....but nevertheless i am having SCIM problems (see below).

the real problem that i'm having here is, after i install SCIM, it won't stay in the KDE task bar, nor will it switch to chinese characters. I've tried uninstalling all chinese and SCIM packages, then reinstalling them and to no avail, it still won't work. I tried setup features in SCIM and switching between english and chinese, and it just won't switch character sets or allow me to type chinese.

I have to execute the "scim" command in a terminal in order for the SCIM icon to appear in the task bar, and even after it's there, it still won't allow me to type chinese simplified characters.

I thought that this scim-panel-kde app would solve the problem, but maybe i'm taking the wrong approach

as you can see, SCIM is installed:



[****@sam ~]$ sudo yum list scim*
Loading "installonlyn" plugin
livna 100% |=========================| 2.1 kB 00:00
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 1.9 kB 00:00
primary.sqlite.bz2 100% |=========================| 706 kB 00:13
macromedia 100% |=========================| 951 B 00:00
Installed Packages
scim.i386 1.4.5-21.fc7 installed
scim-chewing.i386 0.3.1-9.fc7 installed
scim-devel.i386 1.4.5-21.fc7 installed
scim-doc.i386 1.4.5-21.fc7 installed
scim-fcitx.i386 3.1.1-6.fc6 installed
scim-input-pad.i386 0.1.1-7.fc7 installed
scim-libs.i386 1.4.5-21.fc7 installed
scim-pinyin.i386 0.5.91-16.fc7 installed
scim-tables.i386 0.5.7-3.fc7 installed
scim-tables-chinese.i386 0.5.7-3.fc7 installed

RobertoVanto
28th June 2007, 08:27 PM
Check this out: http://www.scim-im.org/wiki/documentation/installation_and_configuration/fedora_core

Wangberg
28th June 2007, 09:22 PM
Check this out: http://www.scim-im.org/wiki/documentation/installation_and_configuration/fedora_core

well, i think i found the issue...there is no scim folder in /etc/X11/xinit/xinput.d/ so the symbolic link is going nowhere. i believe this is why i cannot switch languages...

any ideas ? i really have no clue where to go from here



[root@sam ****]# cd .xinput.d/
[root@sam .xinput.d]# ls
default
[root@sam .xinput.d]# ls -al
total 12
drwxrwxr-x 2 **** **** 4096 2007-06-26 20:31 .
drwx------ 42 **** **** 4096 2007-06-28 16:12 ..
lrwxrwxrwx 1 **** **** 28 2007-06-26 20:31 default -> /etc/X11/xinit/xinput.d/scim
[root@sam .xinput.d]# cd /etc/X11/xinit/xinput.d/
[root@sam xinput.d]# ls
none.conf scim.conf xim.conf
[root@sam xinput.d]#