PDA

View Full Version : how to enter the text mode installer if I install FC7 from a hard drive?



lancedance
21st June 2007, 09:49 AM
how to enter the text mode installer if I install FC7 from a hard drive? It seems impossible

johno12345
21st June 2007, 10:29 AM
what is your install method? i know you are trying to install from hard drive, but how are you loading the installer? from CD?

lancedance
21st June 2007, 10:46 AM
first, I copy the vmlinuz, initrd.img and the fc7 iso to my hda3(fat32).
then, added the following lines to the grub.conf

title fc7 install
kernel (hd0,2)/vmlinuz
initrd (hd0,2)/initrd.img

after that, reboot the computer and selected the fc7 install from the grub menu.
that's the way I trying to install fc7 from my hard drive, but it only can enter the graphic mode. because my ATI card sucks, I must use the text mode to install fc7. :(

stoat
21st June 2007, 12:01 PM
Hello lancedance,




first, I copy the vmlinuz, initrd.img and the fc7 iso to my hda3(fat32).
then, added the following lines to the grub.conf

title fc7 install
kernel (hd0,2)/vmlinuz
initrd (hd0,2)/initrd.img

after that, reboot the computer and selected the fc7 install from the grub menu.
that's the way I trying to install fc7 from my hard drive, but it only can enter the graphic mode. because my ATI card sucks, I must use the text mode to install fc7.After you select fc7 from your GRUB menu and vmlinuz starts, you should arrive at a graphic Welcome to Fedora! menu. While that menu is on the screen, press the <ESC> key. You will get a black screen with a boot prompt (boot:_) in the upper left corner. At that boot prompt you can enter the usual boot options like linux text in your case to start the installer in text mode.

EDIT FOR THE RECORD: I now realize that boot options like linux text and linux askmethod can be appended to the vmlinuz line by pressing the <TAB> key during that graphic menu screen. I am so steeped in certain traditions that I didn't really see that or consider it before. What I have been saying is not wrong, just unnecessary. Live. Learn.

EDIT FOR THE RECORD: Even better, as I realized farther below...for this particular method of launching vmlinuz, just add options such as linux text and linux askmethod to the vmlinuz line in the grub.conf.

lancedance
21st June 2007, 01:51 PM
Hello lancedance,

After you select fc7 from your GRUB menu and vmlinuz starts, you should arrive at a graphic Welcome to Fedora! menu. While that menu is on the screen, press the <ESC> key. You will get a black screen with a boot prompt (boot:_) in the upper left corner. At that boot prompt you can enter the usual boot options like linux text in your case to start the installer in text mode.

I did as you told me, when I saw the Welcome to Fedora on the upper left corner, I press the <ESC> key, but it didn't tak any effect, I didn't see the boot prompt. I am wondering if I've miss something.
thanks

stoat
21st June 2007, 02:03 PM
I did as you told me, when I saw the Welcome to Fedora on the upper left corner, I press the <ESC> key, but it didn't tak any effect, I didn't see the boot prompt. I am wondering if I've miss something.See the first thumbnail for the screen that I meant. Pressing the <ESC> key when you see that screen produces a boot:_ prompt (second thumbnail). At least it does for me.

lancedance
21st June 2007, 02:13 PM
but I did't see that first screen you attached. only saw a screen with text on the blue background.

stoat
21st June 2007, 02:23 PM
I apologize for misunderstanding. I thought you said you were seeing the graphical installer and did not want that.


after that, reboot the computer and selected the fc7 install from the grub menu.
that's the way I trying to install fc7 from my hard drive, but it only can enter the graphic mode. At the moment, I don't know what else to say. When I start the F7 installation, I always arrive at that graphic menu I showed. From there the graphic installation starts. However, pressing the <ESC> key aborts the menu and presents a working boot:_ prompt from which the usual familiar boot options can be entered and restart the installation (like with previous Fedora versions). Entering linux text at that boot prompt continues the installation in text mode. Entering linux askmethod causes it to prompt for an installation method. Etc., etc. At least it did for me. Sorry.

lancedance
21st June 2007, 02:52 PM
ok stoat.
thank you all the same.

stoat
21st June 2007, 06:06 PM
lancedance,

I'm back again. I downloaded vmlinuz and initrd.img and modified my grub.conf to launch vmlinuz to see exactly what you are seeing. It started vmlinuz normally, and I understand now what you mean about not being able to install from the hard drive in text mode booting vmlinuz that way. You are never given the opportunity to select text mode.

Here is my new idea: add linux text to your vmlinuz line in your grub.conf. For example, this is the section from my grub.conf after I added that to my vmlinuz line...

title Fedora Installer
root (hd1,4)
kernel /vmlinuz linux text
initrd /initrd.imgIt started vmlinuz normally again, but I did not actually enter the anaconda installer because I don't want to download that huge DVD ISO file just to try this. You can try it in 30 seconds. If I am wrong, I again am sorry and will go away. But it might work.

P.S.: If that didn't work, you could also download the small F7 boot.iso file and create an F7 boot CD to boot your computer and install F7 from your hard drive in text mode. Select the text mode option from the graphical Welcome to Fedora! menu. Soon after that, you will be offered the dialog box to select Hard drive as the installation method. I would expect it to proceed from there with a hard drive installation in text mode.

lancedance
22nd June 2007, 04:33 PM
hey stoat, with your help, finally I success install the FC7 in the text mode with hard drive.
thank you very much!