PDA

View Full Version : Strange Printing Problem in Fedora 6 and 7



pstrang
21st June 2007, 06:05 AM
The last couple of Fedora releases have been getting worse for my printer, a USB HP PSC 2210. When I print a test page, it prints almost all of the top ruler, then page feeds, then prints another 1/2" or so including the words "Printer Test Page", then page feeds, and so on. Very annoying behavior.

In Fedora Core 6, even though the test page acted like this, I could still print normally from applications. But now in Fedora Core 7, my applications exhibit similar behavior, so i have no printing. :(

I've tried the PPD file for my driver as well as the hpijs driver. Paper size and margins seem correctly configured.

Any ideas? Thanks in advance.

pstrang
22nd June 2007, 02:16 AM
So is the HPLIP driver jacked up? Or is CUPS screwed up? Anyone have any ideas? This sucks. :( The spurious page feeds are really annoying.

stevea
22nd June 2007, 02:37 AM
WTF - mine works fine. You have to load both the hplip packages (there is a dependency missing I think).
hplip and hplip-gui I believe.

pstrang
22nd June 2007, 03:16 AM
Thanks, installed the hplip-gui. From that utility I installed the printer and printed a test page. Wow, it worked! Well, the HP test page anyway. The CUPS test page is still screwed up.

I then tested with a text document in Openoffice. Page 1 printed okay. Page 2 made it half way, then page feed, next page was 1 line cut off half height, then another page feed, then 4 or 5 lines on the next page, then another page feed.

I then canceled the print. Grrrrr. :(

I should mention, that the pages following the spurious form feeds print on the page where they should have been on the previous page. Does this help anyone diagnose?

phm
10th July 2007, 10:31 PM
http://forums.fedoraforum.org/showthread.php?t=160530

rhka
20th July 2007, 08:26 PM
Help!
Fedora (6 and7) says my printer works, but no paper are coming out.

And how did you install hplip-gui? I can't find such a program.
I did a: yum list *hplip*
Answer: hplip.x86_64 1.7.2-3.fc6 installed

My HP LaserJet 1018 is automatic configured this way:
Starting daemon cups (The GUI way with system-config-sevices). (Turned it of earlyer, didn't have a printer then).
Attach cables, turn on printer and reboot machine. (Maybe not necessary to reboot, who knows).
Then the printer was there. Some info:
Name: HP_LaserJet_1018 (changed the name to just p; I only have one printer).
Description: HP LaserJet 1010 Foomatic/hpijs
URI for unit: usb:///HP%20LaserJet%201018

Then I did following:
gedit testpage (put in some text and saved)
lp testpage
lpq -la
p is ready and printing
root: active [job 9 localhost]
testpage 1024 bytes

But my printer is quiet, don't eat any paper.
Never used Linux with printer before. Now for 2 days(and nights) I have searched through man -k print, and tried all different commands. The printer is stone dead, but it is working with Windows XP after installed CD.

Anyone? Help!

Henning

rhka
20th July 2007, 08:35 PM
Some more info!
[root@henning ~]# lpstat -t
scheduler is running
system default destination: p
device for p: usb:///HP%20LaserJet%201018
p accepting requests since fre 20-07-2007 18:14:51 CEST
printer p now printing p-9. enabled since fre 20-07-2007 18:14:51 CEST
Printer not connected; will retry in 30 seconds...
p-9 root 1024 tor 19-07-2007 19:16:46 CEST

Helpfull?
Henning

pstrang
20th July 2007, 09:57 PM
<snip>
And how did you install hplip-gui? I can't find such a program.
<snip>


The program is executed from the command line. Open a terminal and type 'hp' then hit your tab key to match all executables for that name. You should see the gui and other utilities available for your printer.

rhka
20th July 2007, 10:51 PM
Helpfull, as I said: never used printer with Linux.
No executables worked exept this one: hp-check | less
And there I foun those lines:
ESC[01m
HPLIP running?ESC[0m
No, HPLIP is not running (OK).
ESC[01m
HPOJ running?ESC[0m
No, HPOJ is not running (OK).
Then I did a: service hplip start (didn't know it was a own daemon).

Now I have a lot of options, see you later.

Henning

rhka
22nd July 2007, 03:02 PM
No! I can't get this printer work, the status is:

[root@henning ~]# lpstat -t
scheduler is running
system default destination: p
device for p: usb:///HP%20LaserJet%201018
p accepting requests since søn 22-07-2007 13:44:27 CEST
printer p now printing p-21. enabled since søn 22-07-2007 13:44:27 CEST
Printer not connected; will retry in 30 seconds...
p-21 root 19456 søn 22-07-2007 13:44:27 CEST

The driver I and the system choose is for HP LaserJet 1010, maybe it's not compatible?
I don't know what to do.

Is there anyone who can help?

Henning