PDA

View Full Version : Dial-up external modem problems



Yavo Lem
20th June 2007, 04:26 PM
Yes, I installed FC 7 and it looks pretty, but will it work? Apparently not, at least with regard to trying to connect to the Internet with my external modem, a Best Data Smart One 56X, which incidently I am currently using, under (gasp!) Windows 98 SE, to post this message. The same modem served me well under Mandrake 8.0 (or 8.2) and RH 9, but due to data incompatibilities between Windows and Linux, I stopped using Linux a few years ago.

I must have lost my marbles because having a surplus 40 Gig hard drive, I purchased "barebone" DVDs of both Fedora Core 7 and Madriva Linux 2007.1 (Spring). I installed both, sequentially, on my Ibex 1.80 Gig. Pentium, which has 512 Meg RAM, 100 Mhz. Bus Clock, ECS P4S5A/DX+ 1.0 motherboard, American Megatrends BIOS 07.00T (4/2/01), on a 40 Gig. WD harddrive D, as part of a dual OS system, with Windows 98 SE on the primary 40 Gig. hard drive C.

Both versions of Linux installed without a problem, but neither could recognize the modem, although I meticulously followed the directions provided by Fedora, Konquerer (Ha, what a misnomer!), and Gnome. This is in spite of the fact that the very same modem worked under RH 9 on this very same computer a few years ago, and still does. I tried the same procedure with both new distros, but substituting a US Robotics V.92 modem and the same thing happened, NOTHING, not even using "kppp", which I had used under both RH and Mandrake. So I am here, hoping someone can help, before I write off both these versions of Linux, and perhaps Linux itself, as totally worthless and a waste of the money I paid for them.

I remain pessimistically optimistic ...

Yavo Lem

Yavo Lem
21st June 2007, 02:21 PM
Some additional information: under Windows 98 SE, my Best Data Smart One 56x is installed on COM-2, IRQ-3 and downloads quite rapidly. It is my understanding that it contains its own driver (and necessary "software" on board), and that if necessary, it can be identified as "Hayes compatible" for installation purposes. It requires no 'jump-starting", but I do have, and have used, the initialization string on kppp, to no avail, under either FC-7, or Mandriva Spring. Nothing happens under FC-7, other than that when I try to install it, the location is shown as being COM-2, but still, whether I set it up under automatic recognition, or enter all the information manually, the OS does not recognize it as being installed., even though it shows as being "active".

Another question I have is just what does all this Ethernet and DCHC nonsense mean? My desktop is a stand-alone machine and is not connected to any network whatsoever, and never will be. So, is there something that can be "disconnected" or adjusted so that I can work around this problem, as I see it? There must be something that has changed between RH-9, under which the very same modem worked fine, after having been set up via kppp, and FC-7. Also, why is it that FC-7 comes without kppp, and why is it that it won't take it from the Mandriva distro? Perhaps I'll try to load it from the old RH-9 disks, before I give them away or throw them out.

One last thing, I find it really annoying and quite hurtful to read various posts in which people dismiss external dial-up modems as passe or antique, which implies that those of us who use them, and I believe there are quite a few of us in this world, are simply and hopelessly out-of-date, or ignorant, or both. Well, you are entitled to your view, and your silly world of Linux, where everything is promised, but little is delivered that actually works, or is that superior to what I have with my Windows system. Besides, over the years, I have accumulated masses of data under Windows that apparently can't be used under either FC-7, or Mandriva Spring. I know, because I downloaded Open Office for Windows and tried importing various files, to no avail. However, I was able to "cut and paste" some information from a Windows Works spreadsheet into an OO spreadsheet and it worked well enough (it is only text data and I use the spreadsheet for sorting purposes, and as a mater list in my translation projects), but if I can do that in Windows, why go through the contortions to get either distro of Linux hammered into shape. I'm too old, too tired of all these "learning curves", and too many times I've been led down the primrose path of Linux (Mandrake 7.1, 8.0 or 8.2, Red Hat-9 and now Fedora Core 7 and Mandriva Spring. I am not so flush with cash that I can constantly go out and buy new systems or periphals, or explanatory "Bibles", that don't match up with the reality of the software, just because a new "distro" has come out and that the former is no longer supported (or because the new "distro" omits something that worked), nor am I a "power user", who needs the latest and greatest. To me, a computer is a tool, and it really can't do anything that the one on each person's head can't do, (with some exceptions) and there are some things it does very poorly compared to the human brain. I guess I am just one of those old-fashioned people who still reads books, and drives a standard-shift car (analogous to using a dial-up external modem), who just wants to use a computer to do what he wants to do, and not what the OS developers think he should be doing. I still have a small, color TV, with no cable, and therefore only get 3 channels on a good day, but how much "information" overload and "entertainment" stupiditiy do I need in my life? And I have come to the conclusion that Linux is STUPID and a big waste of time and money. So, if anyone wants my FC-7 distro...

Perhaps the message contained in Clifford Stoll's book, "Silicon Snake Oil", is finally sinking in for me.

http://mh.cla.umn.edu/ebibks3.html

Yavo Lem

P.S. - I'm really not expecting an answer to this post, but maybe I'll get a rant or two.

Coolerthanyou
21st June 2007, 02:50 PM
well, what steps did you follow? I assume it's a serial modem not usb. as I remember, all I ever had to do was set the modem device to /dev/ttyS0 in the network settings and enable it. disable ethernet if you don't need it. maybe try changing the speed to 11520. I never ran into a hardmodem that refused to work, that I can remember.

Yavo Lem
21st June 2007, 03:19 PM
Hi,

Thanks for responding.

I. Yes, it is a serial modem.

2. The setup process recognizes it as being on COM2, by highlight, but no matter what I enter manually, or whether I put it on different network setting, and here I confess I don't know what I am doing, only on modem light blinks, and then goes off and then I get the message that the system is not connected to the internet, at which point I try another port. But then the modem doesn't even blink.

3. The speed is set at 115200 and always has been.

4. I do not know how to disable ethernet.

5. Right now I have Mandriva Spring installed, as I got quite "POed" at FC-7 last night. So, if you can guide me through the set up process in either distro, I will be happy to reinstall FC-7.

Sorry, but although I am not a "newbie", when it comes to computers, it is only 'Trial and Error" that works for me. I've bought a number of books, and tried to follow their instructions, but they don't seem to work, either. Lack of good documentation is a very big problem with Linux, at least in all my experiences to date. But I am willing to be putty in the hands of someone who can help.

Yavo Lem

P.S. - One thing I have noticed, though, is that after having tried to get the modem recognized under Linux, and having seen the lights flash at various times, when I go and reboot into Windows, I can't connect to the Internet as usual because I get a message to the effect that my modem is not installed properly, or something to that effect. However, this problem is quickly solved by simply turning the modem off for about 15 seconds and turning it back on, at which point everything is fine again. So, obviously, Linux has accessed the modem and changed something, but I don't know what. Also, turning the modem off and on under Linux seems to have no effect.

Coolerthanyou
21st June 2007, 05:11 PM
Ok, well I went back to check an external US Robotics modem, and this is basically all I need to do on Fedora to get it going (i'm not too clear if you have already done this, I don't know where you're seeing this COM2 stuff):

On the gnome menu, go to System > Administration > Network

There, first go to the Hardware tab, then click on new. Hardware type: select Modem. On that dialog, the first option make it /dev/ttyS0. The rest are up to you, though you can set the rate at 11520 to be safe. OK

Then go to the Devices tab, click new. Add a new Modem connection. There add all your info, basically all you need is the phone #, username and password for the ISP, but you most likely already know that. On this tab you can also disable the ethernet. Forward. You can edit all this stuff later if needed.

Then go to File and Save.

Now if it's working you can connect through System tools > Network device control, or with the Modem lights gnome applet.

Yavo Lem
21st June 2007, 09:20 PM
Hi Cooler,

OK, I reinstalled FC-7, and did as you suggested. The result:

1. Modem shows as active on /dev/ttyS0, but it isn't.

2. Ethernet shows as inactive.

3. When I saved this setup I got Error 8 - Cannot activate network device (my ISP name).

4. I tried to log out, but the system locked up and I had to use my computers Restart button.

5. Once FC-7 reloaded, I looked at Network Configuration > Devices. It showed my modem under my ISP's name as Active ppp0, but it really was't.

6. I looked under System Tools, but there was no listing for Network Device Control, or any other means of connecting to the Internet, such as KPPP.

7. So, thank you for trying.

8. As far as I am concerned, I have wasted enough time and money on Linux, both FC-7, which I think is really bad, in that RH-9 actually worked on this very same computer with the very same modem, and Mandriva Spring. The RPM process really stinks in my not so humble opinion. The final nail is the basic incompatibility between Windows and Linux, coupled with the fact that there is little in the way of useful documentation for the latter, and in addition, you have to fight your way into the "system", which is definitely something I am very tired of doing.

9. Well, it is back to Windows 98 SE for me. Unsupported though it may be, it works and does what I want it to do, and in addition, I have too much data to lose and don't want to invest in any more hardware.

Windows may have its problems, but there is a light at the end of the tunnel; Linux is like being in the light and then going into a big dark tunnel where there is no light at the end, at least for me.

I can't deal with these Linux distros any more and believe me, I have tried. Windows has won, but I won't go past 98 SE. Beyond that, it is back to books, snail mail and all those good things. :)

Yavo Lem

Coolerthanyou
22nd June 2007, 12:16 AM
It's funny that you say Win98 not XP. Does this modem not work on XP? If it doesn't it might not be a full hardware modem and those old linux distros just happened to have it's driver which was discontinued (by the vendor), perhaps. I couldn't find definitive info, but if this is your modem, why does it need a driver? And why is it only for Win9x? Like I said, are you sure it's a full hardware modem?

Yavo Lem
22nd June 2007, 01:40 AM
It's funny that you say Win98 not XP. Does this modem not work on XP? If it doesn't it might not be a full hardware modem and those old linux distros just happened to have it's driver which was discontinued (by the vendor), perhaps. I couldn't find definitive info, but if this is your modem, why does it need a driver? And why is it only for Win9x? Like I said, are you sure it's a full hardware modem?

================================================== ==========

Hi Cooler,

Sorry, but I was writing a long reply and somehow I hit a wrong button and the message disappeared. I was attempting to answer your question about Win98 vs. XP. It is long and complicated and I really don't want to go through it all again. Let's just say that I have become very disenchanted with computers, the Internet, Cyberspace, E-Mail and the whole ball of wax that comes with it. Try reading the Stoll book, because he pretty much says what I feel.

Regarding the modem, it is a Best Data Smart One 56 serial external that I bought for $135 back in 1997, after a lot of research about UART chips, as I recall. Literally, at the time, it was recommended as the best (no pun intended) and it has served me extremely well over the years, always downloading at near 50K. It always outperformed the U.S. Robotics V. 92 that I got with the Ibex. I did some more research today and found out that it has a FN6USA-31385-M5-E, whatever that is, and according to Linmodem.org meets the requirements for Linux EXT formatting, but that is old information. Obviously, neither the Red Hat, nor the Mandriva people are particularly concerned about what kind of hardware real users have, or these forums wouldn't be needed. As I said earlier, this modem worked under both Mandrake 8.0 (or 8.2) and Red Hat v. 9 configured under KPPP and connected at will to the Internet via my ISP, which was Erols at the time, but which was later merged into RCN, and which I still use, although my E-mail address is still yavolem@erols.com.

Yes, I am as sure as I can be that the Best is a full hardware modem, Hayes compatible, and carries its own driver on board. The Gateway computer, on the other hand, has a US Robotics Winmodem and can only download at 45K because of the UART chip problem, which is why I got the Ibex system, and I made sure I was getting something that would do what the other one wouldn't. I really hate to say it, but even though I am not that well-versed in Linux and even though I am not a "techie" or a "geek", I am not stupid, ranking as I do, above the 98th percentile. However, for some reason, you don't seem to believe I know what I am talking about. I am also retired and on a very limited income, and so I can't go out and buy new operating system software every time Bill Gates needs more money, or pay Mandriva $66 to join their "support" forum, just to be told that I need a new modem, because they created a complicated OS that doesn't take into account what is used in the real world. As I said before, Windows 98 SE works for me and I have too much already invested in data and hardware that works fine with what I have. In short, Windows 98 SE and this little super duper Best Data modem MEET MY NEEDS, AND AS LONG AS THAT IS THE CASE, I WILL GO WITH WHAT I KNOW WORKS.

That is all. I trust I have made my point(s).

Regards,

Yavo Lem

zenarcher
22nd June 2007, 02:08 AM
This isn't really a rant, but as someone who used Microsoft from DOS 5.0 through Windows XP and been on active on the Internet since 1991, I've had a fair bit of experience with both hardware and software.

I just had an experience pretty much the opposite as what you're discussing here. A family member brought me an old Dell Dimension L733r yesterday. It was built for Windows ME. Overall, it wasn't a bad looking little computer, for being so old. A Pentium III, 10GB slow hard drive, onboard video and 128M of RAM.

Someone had tried to install Windows XP on this system and it was a mess. The sound card was not recognized, the LAN card wasn't recognized, vague Windows errors popping up all over the place. It wasn't even booting without errors. Anyway, the family member thought I could strip it for parts. Even the monitor wasn't too bad, for a 15 inch CRT display, which had come with the system originally.

I don't recall ever having a copy of Windows ME and I can't remember when I had a copy of Windows 98 lying around. I do have a couple of copies of Windows XP, which I haven't used in two years on anything.

Well, I added 256M of RAM to this little box, bringing the total RAM to 384M...I'd rather have at least 512M, which is the maximum for this machine, but thought I'd give a try with Fedora 7, which I had downloaded and burned and installed on two of my other computers, just fine.

I installed Fedora 7 this morning, using the KDE desktop, but also installing GNOME packages. Likewise, I added Livna as a source and installed Mplayer, Flash and so forth. I then installed Java, too.

The bottom line is that this little antique Dell computer, with Fedora 7, installed without a hitch, recognizing every piece of hardware, connected to the Internet and performed all the updates, just as it should. The sound works, which did not with Windows....the LAN port works, which did not with Windows....and considering the amount of RAM in the system, it runs very respectably, so far as speed goes. Yes, I'll add some more RAM, but the point is.....it works perfectly with Fedora 7, with no special configuration....and that's a lot more than it would do with Windows XP.

I run Fedora 7 and SUSE 10.2 on five computers here in my house and not a problem with a one of them....and I'm just an old retired guy and not a Linux pro by any stretch of the imagination. Even my HP laptop works perfectly, right from the initial install....except for simply installing video drivers.

As for RPM's being such difficult to install....if one cannot install an RPM using KPackage, you should probably not try to install using a Windows installer either, as it is equally difficult. Of course, using YUM and KYUM isn't exactly rocket science either.

But, considering your experiences and frustration, I'd certainly agree that Windows 98 is the way to go for you. Just try to keep in mind that Fedora 7 works flawlessly for an awful lot of people, so it's not the fault of Fedora. Often, IMHO, it's a matter of trying to install Linux while in a Windows mindset. Just my thought.

Cheers,
zenarcher

Yavo Lem
22nd June 2007, 06:21 AM
zenarcher,

"The smart man knows what to say;
The wise man knows when to not say it."

Yavo Lem

P.S. - I have no Windows "mindset", I have needs that cannot be met by the Linux "distros" I have tried, and believe me, I have tried.

zenarcher
22nd June 2007, 11:43 AM
And my whole point was that the same "needs" you mention that Linux distros cannot meet, are met for tens of thousands of other people....therefore, it is not the fault of the Linux distros. If the fault was with the distro, everyone would experience the same problem.

Here is a simple analogy. If I went to the auto parts store and bought a new transmission for my car....and brought it home....I am sure I would be unable to install it. Could I then claim that replacement automobile transmissions were unable to do the job they were intended to do? I think not.

Cheers,
zenarcher

Yavo Lem
22nd June 2007, 02:52 PM
zenarcher,

You offer specious arguments:

1. My needs have little in common with the needs of others, aside from the basics, air, water, food, shelter, and things on that level. Beyond that, intellectual needs are on a whole different level, as has been demonstrated here. Please note that personal computers are not necessary to life, and in some cases, have been detrimental to it, as some antisocial people have proven, and continue to prove.

2. Your "analogy" is in error. You are trying to compare a part with a whole.

3. My argument is evidence based; what worked under Red Hat does not work under FC-7 on the same system. Same "manufacturer" of both products.

4. If Linux worked as touted, there would be little need for these forums. You should try reading through them and helping, as "Cooler" tried to help me, instead of attacking me for my expressed needs and final conclusion.

5. In spite of all its faults, at least Microsoft maintains a support presence, and, in fact, has been reachable by both telephone and E-mail. They also responded, albeit not to my satisfaction. Try that with the Red Hat or Mandriva "organizations". I did, and I am still waiting for a reply, hence my resorting to this and two other forums for help. Thus far, I have heard from exactly two people, you and "Cooler". One person was helpful and the other, well ...

"Cooler" aside, I believe I have come to an empty well at this forum, and also that I have come to the end of the road with Linux. As for the "tens of thousands", obviously, their needs are not mine, and if Linux works for them, great, but Linux is very small potatoes in the computing world, similar to Macintosh's position. With regard to you, frankly, I don't understand why you would need to run 5 computers, but I guess there is a reason, maybe boredom. I hope they continue to work and meet your needs, whatever they may be, but in all sincerity, I hope our paths never cross again.

Please do not bother responding to this post, as I will not answer, but I don't know how to withdraw my membership here. And to any others who might be following this little discussion, I hope you have enough important things to do and do not send me any responses. Thank you in advance.

Lebewohl,

Yavo Lem

zenarcher
22nd June 2007, 04:13 PM
"3. My argument is evidence based;"

"Well, you are entitled to your view, and your silly world of Linux, where everything is promised, but little is delivered that actually works, or is that superior to what I have with my Windows system."

"2. Your "analogy" is in error. You are trying to compare a part with a whole."

Apparently, your computer does not use an O/S as a component of the system, but rather is one intregal unit of hardware and software. Quite interesting!

And for the record, I was not "attacking" you personally, but merely pointing out that while Fedora, nor any other Linux distro was working for you....that did not follow your conclusion that the Linux distros are all flawed and fail to deliver. In fact, as I stated, Windows 98 is probably your best choice. Use it and enjoy it. I happily use Linux and have found no need to go to a Windows forum and complain that Microsoft just doesn't deliver as promised.

All I have to say on the matter. End of discussion.

Cheers,
zenarcher

Dan
22nd June 2007, 06:55 PM
Dang, Yavo!

You sure have had some troubles. No wonder you've gotten peevish. Sorry it didn't work out for you.

However, you've got just the right take on the situation, if not the software. Use what works for you. In this case, that looks like Windows 98 SE.

In closing I will offer this. I have run external modems in Linux for a long time. (RH9, Sun Java Desktop, FC1-7, Mandriva 2006 and Spring, *buntus, Debian, Vector, PCLOS and elive. In those years I discovered that the USR v92 external does not play well with Linux. Oddly enough, the cheapest modem I found was also the most solid performer. That being the TRENDnet TFM-560X. I also have excellent luck with a ZOOM 2948C.

A search here on the forums regarding the modem lights applet may be in order too.

Again, however, I fully understand your reluctance to engage the added learning curves this late in life. The added aggravation of trying to solve these kinds of puzzles probably isn't helping your blood pressure at all. So, take a deep breath, flip those offending Linux CDs over your shoulder, and go have a great time with Windows 98 SE!


Dan