PDA

View Full Version : Key stroke problem



satimis
19th June 2007, 06:15 PM
Hi folks,


F-7 x86_64


For unknown cause keyboard does not work on KDE as user (satimis). All key strokes have no response. However there is no problem on GNOME. Before login keystroke works w/o problem.


Please advise where I have to check. TIA


B.R.
satimis

Simon_6162
19th June 2007, 08:45 PM
With the mouse go through the kde menu and start the control center. Go to Regional & accessibility -> keyboard layout.

I would guess try some other layouts.

satimis
20th June 2007, 04:21 AM
Hi Simon_6162,


Tks for your advice. Something strange happens here.




With the mouse go through the kde menu and start the control center. Go to Regional & accessibility -> keyboard layout.

I would guess try some other layouts.
I found "Enable Keyboard Layout" un-checked. After rechecking it, "US 104 keyboard, en" was selected automatically --> Apply.

Keyboard is still not working including logout/relogin/reboot PC.


Login KDE as root. Keyboard is working.


Control center --> Regional & accessibility --> Keyboard Layout.
also unchecked. All items there are greyout. But the keyboard is working w/o problem.


Is there any file locking keyboard operation on User? Tks


Edit:
Checked "Enable Keyboard Layout" as root. Logout and login KDE as user. Keyboard is still not working. Relogin KDE as root, keyboard is working properly.


B.R.
satimis

Simon_6162
20th June 2007, 01:05 PM
Actually all of my setting are unchecked as well, but my keyboard still works.

Have you tried rerunning system-config-keyboard and loging out and back in ?
What type of keyboard do you have ? USB or PS2 ?
After that maybe try logging in as the user then log out, log in as root and run dmesg and see if there is anything in there that might give you a clue of what is going wrong. Its sounding like some sort of permission issue.

Also have a look in the xorg log
cat /var/log/Xorg.0.log

Simon

satimis
20th June 2007, 03:36 PM
Hi Simon,

KDE desktop



Have you tried rerunning system-config-keyboard and loging out and back in ?

No. I can't type on Terminal as user.



What type of keyboard do you have ? USB or PS2 ?

I have been running wireless keyboard and wireless mouse on this F-7 box since F-7 was installed.

The receiver is connected to PS/2 keyboard socket and PS/2 mouse socket. with 2 plugs. I don't think it is the problem of the keyboard. Changing the wireless keyboard and mouse with PS/2 keyboard and mouse can't solve the problem.

However the keyboard works w/o problem on GNOME both as user and root.



After that maybe try logging in as the user then log out, log in as root and run dmesg and see if there is anything in there that might give you a clue of what is going wrong. Its sounding like some sort of permission issue.

# dmesg

It is a big file. I attach it to this posting. Because I'm not allowed to display its content here

What is follow?

Call Trace:
[<ffffffff80229e7b>] local_bh_enable+0x42/0x98
[<ffffffff8025c008>] cond_resched_softirq+0x35/0x4b
[<ffffffff8022e9f5>] release_sock+0x59/0xaa
[<ffffffff80253351>] inet_stream_connect+0x12c/0x23a
[<ffffffff80293107>] autoremove_wake_function+0x0/0x2e
[<ffffffff803e8283>] sys_connect+0x7e/0xae
[<ffffffff802ac2ff>] audit_syscall_entry+0x141/0x174
[<ffffffff8025729c>] tracesys+0xdc/0xe1

eth0: no IPv6 routers present

It is on dmesg output.



Also have a look in the xorg log


# cat /var/log/Xorg.0.log | tail

(**) Option "CorePointer"
(**) <default pointer>: Core Pointer
(==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
(**) <default pointer>: ZAxisMapping: buttons 4 and 5
(**) <default pointer>: Buttons: 9
(II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(--) <default pointer>: PnP-detected protocol: "ExplorerPS/2"
(II) <default pointer>: ps2EnableDataReporting: succeeded
(II) 3rd Button detected: disabling emulate3Button


B.R.
satimis

Simon_6162
20th June 2007, 04:09 PM
I'm lost then !

To clarify,
In gnome keyboard works for user and root ?
In kde the keyboard doesn't work as the user, what about root, is this ok ?

Try disabling selinux and reboot and try again. I doubt it will make a difference but worth a shot.
Have you tried making another user and seeing if it still happens ?

I found this http://www.kde-forum.org/thread.php?threadid=16886

Anyone else have any thoughts ?

satimis
20th June 2007, 05:28 PM
To clarify,
In gnome keyboard works for user and root ?

Yes, correct.



In kde the keyboard doesn't work as the user, what about root, is this ok ?

Yes. root is OK.



Try disabling selinux and reboot and try again. I doubt it will make a difference but worth a shot.

Pls advise how to disable it with command line. TIA



Have you tried making another user and seeing if it still happens ?

Created a new user. Keyboard works on KDE, as user and root, and on GNOME as user and root. Only user, satimis, got problem.

Others noted with tks.


B.R.
satimis

Simon_6162
20th June 2007, 06:26 PM
Created a new user. Keyboard works on KDE, as user and root, and on GNOME as user and root. Only user, satimis, got problem.

In which case can you not just delete the user and remake it ? Or try and removing all the kde settings files so when in gnome do:
mv ~/.kde ~/.kde-broke

satimis
21st June 2007, 03:00 AM
In which case can you not just delete the user and remake it ?

I think I can delete it but there are lot of subdirectoris and files on /home/satimis (my working document). I can temporarily move them to another new-user created for such a purpose. But how about the embedded links?



Or try and removing all the kde settings files so when in gnome do:
mv ~/.kde ~/.kde-broke
I'll try if its removal wouldn't affect the data (my working documents) on /home/satimis. Please advise. TIA


B.R.
satimis

daneel971
21st June 2007, 06:45 AM
My bet is that you probably enabled "sticky keys" in KDE - with only the mouse you can fix that in the KDE control center.

Simon_6162
21st June 2007, 12:49 PM
doing mv ~/.kde ~/.kde-broke will not effect your documents but it ill remove all kde settings as well as kde program settings. So konqueror will be reset, smb4k, ktorrent etc ! you can copy things back though one by one to find out which file broke kde.

Check out the sticky key suggestion, its a good point

satimis
21st June 2007, 01:31 PM
Hi daneel971 and Simon,


Tks for your advice.


daneel971 is right. Solution is as follow;

Control Center --> Reginal & Accessibility --> Keyboard Filters

Uncheck the box "Use slow keys"


I have no idea how it came??? I haven't checked this box.


IIRC I encountered similar problem before "slow response on keystroke". It was becuase this box checked.


Anyway tks again, Simon, for your support.


B.R.
satimis

daneel971
21st June 2007, 04:13 PM
"Sticky Keys" are activated by pressing the SHIFT key for more than a few secs. It's easy do this without even noticing.

satimis
22nd June 2007, 03:48 AM
"Sticky Keys" are activated by pressing the SHIFT key for more than a few secs. It's easy do this without even noticing.
Hi daneel971,

Your advice noted with tks,

Another problem encountered by me is occasionally some keystrokes will repeat automatically until hitting [BackSpace] to delete them. Hitting the same character will repeat again but not all characters. I haven't tried hitting numbers and got no idea on them. I can't get rid of this mistake until rebooting the PC. It happened occasionally. Have you had any idea of its cause? Tks.


B.R.
satimis

daneel971
22nd June 2007, 07:02 AM
Never heard of this, sorry.