PDA

View Full Version : F7, cannot start X since last Nvidia driver update



roberthauck
18th June 2007, 04:12 PM
Hello

I have a problem with my Nvidia 100.14.09 driver. Since the last Nvidia update from Livna last Sunday, X doesn't start anymore. The driver loads when booting F7, but in xorg log I get

(EE) Failed to load modulde "wfb" (module does not exist, 0)
...
(EE) Failed to initialize the GLX module
...
(EE) Need libwfb but wfbScreenInit not found

I have F7 32bit, a Geforce 8800GTX, working with 2 monitors in Twinview, and it worked without a problem until the last update. I found libnvidia-wfb-so.100.14.09 and libnvidia-wfb-so.1 in /usr/lib/xorg/modules/extensions/nvidia. There are also the GLX-libs.
With a standard xorg.conf with the nv driver, X is starting, if I change nv to nvidia in the standard xorg.conf, I get the same error.

Can someone please help me?

My xorg.conf:


# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"


EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
Option "Buttons" "10"
Option "ButtonMapping" "1 2 3 6 7 8 9 10 4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "ch"
Option "XkbVariant" "de_nodeadkeys"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "TwinViewXineramaInfoOrder" "DFP-1"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "True"
Option "TwinView" "True"
Option "AddARGBGLXVisuals" "True"
Option "DynamicTwinView" "True"
Option "MetaModes" "nvidia-auto-select, nvidia-auto-select"
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Seve
18th June 2007, 07:27 PM
Hello:
geit /etc/X11/xorg.conf
and add back

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection
Save, exit and Ctrl Alt Backspace to restart your Xserver and see how it goes.

Seve

roberthauck
18th June 2007, 08:39 PM
Hello Seve

Thank you, that worked..... Great work :-)

Robert