PDA

View Full Version : Usb automount disappeared



simberl
18th June 2007, 08:32 AM
Using FC6. Suddenly usb devices (e.g. memory sticks) have ceased to automount. The devices are there - i.e. I can mount them manually using, for example, 'mount -t vfat /dev/sda /media/xxx'. Automount used to work fine, I don't know what has happened so that it suddenly stops working.

Looked in dmesg and nothing seems to be amiss. E.g. mounting an external disc gives:

usb-storage: device found at 8
usb-storage: waiting for device to settle before scanning
scsi 5:0:0:0: Direct-Access Maxtor 3200 0344 PQ: 0 ANSI: 4
SCSI device sdb: 781422768 512-byte hdwr sectors (400088 MB)
sdb: Write Protect is off
sdb: Mode Sense: 17 00 00 00
sdb: assuming drive cache: write through
SCSI device sdb: 781422768 512-byte hdwr sectors (400088 MB)
sdb: Write Protect is off
sdb: Mode Sense: 17 00 00 00
sdb: assuming drive cache: write through
sdb: sdb1 sdb2 sdb3
sd 5:0:0:0: Attached scsi disk sdb
sd 5:0:0:0: Attached scsi generic sg1 type 0
usb-storage: device scan complete

udevinfo gives:
P: /block/sdb
N: sdb
S: disk/by-id/usb-Maxtor_3200_2CAH7YYS
S: disk/by-path/pci-0000:00:08.1-usb-0:1:1.0-scsi-0:0:0:0
E: ID_VENDOR=Maxtor
E: ID_MODEL=3200
E: ID_REVISION=0344
E: ID_SERIAL=Maxtor_3200_2CAH7YYS
E: ID_TYPE=disk
E: ID_BUS=usb
E: ID_PATH=pci-0000:00:08.1-usb-0:1:1.0-scsi-0:0:0:0

Anyone any ideas - where could I look?

simberl
19th June 2007, 07:12 PM
I'll answer my own question. Maybe it will help somebody else out there someday....

I've had to go poring through gnome-volume-manager and hal debug output and numerous google searches to get to this. Eventually (2 days later) found the answer on:
http://www.nabble.com/gnome-volume-manager-not-mounting-USB-drives-t3206706.html

What happened was that I had formatted a new external disk drive using gparted.

Obviously it exited maybe somehow uncleanly (or not?)
At any rate it created the file:
/usr/share/hal/fdi/policy/gparted-disable-automount.fdi

This sets ignore=true in hal for all disk drives, which causes nothing to be auto-mounted thereafter.

Remove this and you're off running again!

cursed_sword
18th July 2007, 06:04 PM
Thanks! that helped me to get auto-mount enabled again. I did the same thing, i formatted an external device with gparted and stopped getting auto-mount. I just deleted /usr/share/hal/fdi/policy/gparted-disable-automount.fdi and everithing is normal again.