PDA

View Full Version : Dell 1390..... why oh why oh why.........



moonshinerat
15th June 2007, 08:01 PM
Okay, this must be the most threaded problem (after 915res) on every forum in the world. Why us nutters keep buying Dell wireless stuff will probably never be known but I can advise to take better attention for words like "Intel" at ordering time.

Anyway, the problem:

I have a Dell 640m laptop with 1gb RAM, T5600 Core 2 Duo and a bloody Dell 1390 wireless card. I thought that by waiting 'til Fedora 7 that someone might have finally cracked the Broadcom catastrophe that has occured in laptops for the last two years.

I have installed ndiswrapper from AT-rpm specifically for Fedora 7 x64. I have tried both 64bit and 32bit Windows drivers with less success than Paris Hilton's court appeal. The drivers were based on the R151517.EXE editions from Dell. I still can't get the WiFi light on and I've tried reinstalling Fedora 4 times.

# iwconfig & lspci brings up the following information:

[root@localhost ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Channel:0 Access Point: Not-Associated
Retry min limit:7 RTS thr:off Fragment thr=2346 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

[root@localhost ~]# lspci

0c:00.0 Network controller: Broadcom Corporation Dell Wireless 1390 WLAN Mini-PCI Card (rev 01)

No matter how hard I try I still can't get this thing to appear in Network Devices or in Network Configuration. It doesn't appear on the list of available drivers for wireless cards either.

If I understood Linux better I would write a full tutorial on getting this to work so none of you would ever ever have to respond to these 1390 threads again...... but unfortunately I don't and I would much much prefer a solution than following the footsteps of Satan to the dark realms of Vista.

I don't normally sound this desperate but I have been hacking away at this now for 37 hours without sleep. Thanks for any input guys. (and I promise the tutorial when it works)

scotta3234
15th June 2007, 08:25 PM
Yes.... These cards have been causing quite a commotion! Keep in mind support for these cards didn't even exist until just a few months ago. Have you already checked out here? http://www.fedoraforum.org/forum/showthread.php?t=156282

moonshinerat
15th June 2007, 08:41 PM
Top one Scott, just givin' it a whirl. If it works okay how am I for putting it on a new website I am helping to produce (it's called tuxrevolution.com but it's not released 'til next week)?

Thanks for the help.....

scotta3234
15th June 2007, 08:47 PM
Also.... as of right now I only have this working with the 2.6.21-1.3194 kernel. The updated one seems to be causing me some trouble although I haven't tested it much yet.

Mathias25
26th June 2007, 02:02 PM
go to terminal as root and type "setup wireless"
This should bring up a screen with some options one of which is network configuration or something close to that. It will allow you to make a new connection an will allow you to type in the device name wlan0. I deleted mine from the network config and this was the only way i could get it back.